[Bbagi] Koneksi Internet dg USB-modem + driver + storage

Membahas Perangkat-perangkat keras yang belum dideteksi dengan baik oleh Ubuntu serta solusinya.
User avatar
thrvers
Posts: 4458
Joined: 01 Jan 2010, 13:28
Location: Jombang, Indonesia
Contact:

[Bbagi] Koneksi Internet dg USB-modem + driver + storage

Post by thrvers » 28 Jan 2011, 16:58

'
Assalamu'alaikum :D

Berawal dari coba2 modem, venus vt18, haier c700 dan venus [unknown] :D yg semuanya terdapat storage [mmc slot] dan driver [hanya usb-modem venus]
dan semua modem tersebut lancar buat koneksi inet :grin: [tanpa pancing2 win$, cuma liat VID+PID di win]
Q menggunakan ubuntu 10.04 atau 10.10 atau mint9

Deteksi Modem:
  • biar gampang, masih bantuan win [pertama saja -terutama nubi linux spt q :grin:]. koneksikan dahulu modem [[color:#CC0000]sampai bisa akses inet[/color]], kemudian buka DeviceManager

    Image

    Keterangan:
    1. buka modems
    2. klik Properties
    3. TAB Details dan Device Instance ID
    4. Perhatikan kode VID_1D09&PID_AEF4 dan catat.
    .
  • sekarang masuk ubuntu, buka terminal:
    $ lsusb

    usb-modem [punya q] dikenali pertama sebagai �qualcom �.� [[color:#3333FF]VendorID dan ProductID beda dengan yg diatas, biarkan saja[/color]]
  • edit modules
    $ sudo nano /etc/modules

    masukkan Vendor dan Product [yg dilihat dr win$ tadi]
    usbserial vendor=0x1d09 product=0xaef4
    lp
  • save dan reboot
  • Nyalakan [size:14pt][color:#FF0000]�detektor�[/color][/size] :grin: terminal:
    $ tail -f /var/log/syslog
  • System - Preferences - NetworkConnections - TAB MobileBroadband - add
    cek apakah sudah muncul modemnya?? seperti:

    Image
Kalau belum konek coba:
  • savely remove [usb dan/atau ROM] di nautilus
  • remove ROM pke terminal:
    $ eject /dev/sr1
    sr1 bisa di deteksi dari $ ls /dev/sr* [CDROM yg terpasang juga akan di deteksi]
  • remove storage [mmc slot] pke terminal:
    $ sudo rmmod usb_storage
    Flashdisk usahakan jangan dicolok dulu
Dalam eksekusi 3 cara diatas [nautilus, eject atau rmmod] perhatikan [size:14pt][color:#FF0000]�detektor�[/color][/size] sampai ada �[color:#3333FF]Now managed[/color]� Pakai salah satu saja [kalau bisa].

contoh output 'detektor' waktu koneksi sudah siap, perhatikan ada 'now managed':
[spoiler]

Code: Select all

.....
NetworkManager[1099]: <warn> (ttyUSB0): failed to look up interface index
NetworkManager[1099]: <info> (ttyUSB0): new CDMA device (driver: 'generic' ifindex: -1)
NetworkManager[1099]: <info> (ttyUSB0): exported as /org/freedesktop/NetworkManager/Devices/1
NetworkManager[1099]: <info> (ttyUSB0): now managed
NetworkManager[1099]: <info> (ttyUSB0): device state change: 1 -> 2 (reason 2)
NetworkManager[1099]: <info> (ttyUSB0): deactivating device (reason: 2).
NetworkManager[1099]: <info> (ttyUSB0): device state change: 2 -> 3 (reason 0)
.....
atau panjangnya: link pastebin[/spoiler]

Koneksi Modem:
  • buka: System - Preferences - NetworkConnections - TAB MobileBroadband - add
  • modem yg terdeteksi lihat gambar diatas, next.
    Isi negara, provider, jenis modem 3G/CDMA.
  • edit lagi username, password bila belum terhubung.
BONUS:
BONUS wrote:bila koneksi putus [tiba2 atau tersenggol :grin:] biasanya akan sulit melakukan koneksi lagi, selain di restart ubuntunya. Sedikit trik, coba cabut dulu semua FD yg sedang tercolok, lalu:
$ sudo rmmod usb_storage

Lalu koneksikan modem seperti biasa :D InsyAllah akan bisa lagi [tanpa restart ubuntunya, mungkin hanya perlu cabut-colok saja]
NB:
  • Buat modem selain q sebutin diatas [venus_vt, haier c700] bisa di coba sendiri, kalau bisa lanjutkan trit dibawah
  • cara ini tanpa instal paket 'usb-modeswitch' jadi remove purge dulu biar gak bentrok.
    $ sudo apt-get remove --purge usb-modeswitch
= Slamet berinternet, safe and clean =
Last edited by thrvers on 27 Feb 2016, 16:25, edited 1 time in total.
Reason: tambah link buat 'Detektor'


User avatar
thrvers
Posts: 4458
Joined: 01 Jan 2010, 13:28
Location: Jombang, Indonesia
Contact:

Post by thrvers » 28 Jan 2011, 16:58

'
modem yg sudah tested: UPDATE MENYUSUL.


User avatar
aptfast
Posts: 3847
Joined: 03 Jan 2010, 23:38
Location: Jakarta, Indonesia
Contact:

Post by aptfast » 28 Jan 2011, 17:09

ngakunya newbie, tapi ternyata expert abis... :D
mantap sharing nya bro...


User avatar
zarkasichan
Posts: 1527
Joined: 01 Jan 2010, 01:57
Location: Samarinda, Indonesia
Contact:

Post by zarkasichan » 28 Jan 2011, 23:30

ijin nyimak dah bro :D


User avatar
_Newbie_
Posts: 188
Joined: 19 Dec 2010, 17:29

Post by _Newbie_ » 29 Jan 2011, 00:29

wah dah saya coba bang thrvers dan modem terdeteksi..........
nice info.........


User avatar
thrvers
Posts: 4458
Joined: 01 Jan 2010, 13:28
Location: Jombang, Indonesia
Contact:

Post by thrvers » 29 Jan 2011, 01:37

'
bisa dishare modem apa + pakai yg mana??
mau masukin list gt :D


User avatar
papacibong
Posts: 6
Joined: 22 Jan 2011, 07:39
Location: sulawesi

Post by papacibong » 30 Jan 2011, 05:35

thanks berat atas pencerahannya aku akan coba....


User avatar
SaGa
Posts: 188
Joined: 19 Jan 2010, 09:09
Location: Banyuwangi
Contact:

Post by SaGa » 30 Jan 2011, 06:48

alhamdulillah bisa konek...

#modem venus VT 21 EVDO has been tested#

thanks bro thrvers


User avatar
deny26
Posts: 2450
Joined: 03 Jan 2010, 09:24
Location: ubuntu-indonesia.com

Post by deny26 » 30 Jan 2011, 06:49

masukin ke wiki dunkz mastah... top abiz nie :grin:


User avatar
thrvers
Posts: 4458
Joined: 01 Jan 2010, 13:28
Location: Jombang, Indonesia
Contact:

Post by thrvers » 30 Jan 2011, 06:54

'
kagak bisa nulis na di wiki :D
[suka binun masalah script2 web :grin:]

= :malu =


User avatar
_Newbie_
Posts: 188
Joined: 19 Dec 2010, 17:29

Post by _Newbie_ » 31 Jan 2011, 06:57

modem venus vt-80n, dah bisa detek tapi koneknya masih gagal gak bisa dapat ip......... malah muncul pesan error.......
kira2 knp y? :D


User avatar
thrvers
Posts: 4458
Joined: 01 Jan 2010, 13:28
Location: Jombang, Indonesia
Contact:

Post by thrvers » 31 Jan 2011, 07:35

'
pke provider apa?? mungkin perlu set DNS-manual :D


User avatar
_Newbie_
Posts: 188
Joined: 19 Dec 2010, 17:29

Post by _Newbie_ » 31 Jan 2011, 20:26

Pake Flexi bro thrvers....

cara setting DNS-nya gmn mas bro..


User avatar
thrvers
Posts: 4458
Joined: 01 Jan 2010, 13:28
Location: Jombang, Indonesia
Contact:

Post by thrvers » 31 Jan 2011, 21:10

'
buka lagi NetworkManager - TAB MobileBroadband - Edit - TAB IPv4Setting:
Method: Automatic (PPP) address only
DNS Servers: isi dg DNS (bila ada lebih dari satu tulis dg dipisah tanda koma: contoh: 10.17.3.244, 10.17.3.252 - smar)

beberapa contoh DNS:

Aceh : 125.160.10.2
Medan : 203.130.206.250
Batam : 203.130.193.74
Jakarta : 202.134.0.155 (pri), 203.130.196.5 (sec1), 202.134.0.61 (sec2)
Bandung : 222.124.204.34
Semarang : 203.130.208.18
Surabaya : 202.134.1.10 (pri), 202.134.1.7 (sec)
Balikpapan : 203.130.209.242

= :D =


User avatar
tutnut
Posts: 483
Joined: 02 Jul 2010, 22:05
Location: denpasar
Contact:

Post by tutnut » 31 Jan 2011, 21:51

mantaps


User avatar
zarkasichan
Posts: 1527
Joined: 01 Jan 2010, 01:57
Location: Samarinda, Indonesia
Contact:

Post by zarkasichan » 31 Jan 2011, 22:12

Modem ane juga keknya berhasil jika diterapkan cara dari bro thrvers diatas eh., langsung terdeteksi oleh Network Manager ubuntu
Modem ane : ZTE MF627


User avatar
goesst
Posts: 10
Joined: 24 Jan 2011, 11:33
Location: Wonosobo, Indonesia
Contact:

Post by goesst » 01 Feb 2011, 00:50

Modem Venus VT-80, tidak terdeteksi di Acer Aspire One

acer@ubuntu:~$ sudo rmmod usb_storage
[sudo] password for acer:
ERROR: Module usb_storage is in use

acer@ubuntu:~$ tail -f /var/log/syslog
Feb 1 00:21:43 ubuntu kernel: [ 720.548501] [] ? dput+0x91/0x130
Feb 1 00:21:43 ubuntu kernel: [ 720.548513] [] do_last+0x66/0x3a0
Feb 1 00:21:43 ubuntu kernel: [ 720.548526] [] do_filp_open+0x19d/0x4c0
Feb 1 00:21:43 ubuntu kernel: [ 720.548538] [] ? do_anonymous_page+0x135/0x340
Feb 1 00:21:43 ubuntu kernel: [ 720.548553] [] do_sys_open+0x55/0x150
Feb 1 00:21:43 ubuntu kernel: [ 720.548564] [] ? filldir+0x0/0xd0
Feb 1 00:21:43 ubuntu kernel: [ 720.548576] [] sys_open+0x2e/0x40
Feb 1 00:21:43 ubuntu kernel: [ 720.548588] [] syscall_call+0x7/0xb
Feb 1 00:22:11 ubuntu udevd[356]: worker [484] unexpectedly returned with status 0x0100
Feb 1 00:22:11 ubuntu udevd[356]: worker [484] failed while handling '/devices/pci0000:00/0000:00:1d.1/usb3/3-1/3-1:1.0'

jika dilepas terus ditancap lagi maka muncul...

Feb 1 00:25:57 ubuntu kernel: [ 974.884152] usb 3-1: new full speed USB device using uhci_hcd and address 4

gimana nih...


User avatar
thrvers
Posts: 4458
Joined: 01 Jan 2010, 13:28
Location: Jombang, Indonesia
Contact:

Post by thrvers » 01 Feb 2011, 04:51

'
kok lgsg rmmod :D coba yg 'safely remove di nautilus' tungguin bentar sambil lihat 'detektor' :wink:

kalau 'detektor' sudah berhenti tapi modem belum juga 'now managed' baru coba tambahin 'rmmod'

NB: 'ERROR: Module usb_storage is in use' = berarti masih ada FD yg colok yah :D

= silakan dicoba lagi =


User avatar
goesst
Posts: 10
Joined: 24 Jan 2011, 11:33
Location: Wonosobo, Indonesia
Contact:

Post by goesst » 01 Feb 2011, 14:54

thanks...


User avatar
_Newbie_
Posts: 188
Joined: 19 Dec 2010, 17:29

Post by _Newbie_ » 02 Feb 2011, 13:09

ok makasih mas bro thrvers ntar ane coba dulu


User avatar
_Newbie_
Posts: 188
Joined: 19 Dec 2010, 17:29

Post by _Newbie_ » 07 Feb 2011, 14:35

dah saya setting pake DNS tetap gak bisa
thrvers wrote:'
Kalau belum konek coba:
  • savely remove [usb dan/atau ROM] di nautilus
  • remove ROM pke terminal:
    $ eject /dev/sr1
    sr1 bisa di deteksi dari $ ls /dev/sr* [CDROM yg terpasang juga akan di deteksi]
  • remove storage [mmc slot] pke terminal:
    $ sudo rmmod usb_storage
    Flashdisk usahakan jangan dicolok dulu
kok punya saya gak ada buat remove di nautilusnya.....
cd-rom cuma ada sr0
terus saya rmmod muncul pesan:
ERROR: Module usb_storage is in use
gmn mas bro???


User avatar
thrvers
Posts: 4458
Joined: 01 Jan 2010, 13:28
Location: Jombang, Indonesia
Contact:

Post by thrvers » 07 Feb 2011, 14:44

'
bro _Newbie_ dari atas dolo gmn?? VID dan PID waktu inet nyambung sudah dicek ??

- :confused: -


User avatar
_Newbie_
Posts: 188
Joined: 19 Dec 2010, 17:29

Post by _Newbie_ » 07 Feb 2011, 15:02

dah saya cek saya pake win7 ngeceknya jadi gak ada device instance ID adanya device instance patch
disana ada keterangan VID_05C6&PID_6500
dah saya masukkin ke /etc/modules kaya gini:
usbserial vendor=0x05c6 product=0x6500
terus habis itu saya reboot dan jalanin detektornya dan modem dah kedetek....
dah sampai disin saya coba edit koneksinya seperti yang kak thrvers kasih tau kemarin tetap z gak bisa.........


User avatar
thrvers
Posts: 4458
Joined: 01 Jan 2010, 13:28
Location: Jombang, Indonesia
Contact:

Post by thrvers » 07 Feb 2011, 15:04

'
seperinya bisa juga itu DeviceInstantPatch [maap coba hanya pake eSPe].

abis masukin /etc/modules spt nya perlu restart dolo :D biar teridentifikasi dg baik di ubuntu nya :wink:

abis itu baru step yg selajutnya.


User avatar
_Newbie_
Posts: 188
Joined: 19 Dec 2010, 17:29

Post by _Newbie_ » 07 Feb 2011, 15:10

dah saya restart kak tapi sama z ...... :(
masa harus pake wedus terus kalau mau ngenet....


User avatar
thrvers
Posts: 4458
Joined: 01 Jan 2010, 13:28
Location: Jombang, Indonesia
Contact:

Post by thrvers » 07 Feb 2011, 15:22

'
btw instal usb-modeswitch ?? coba remove purge dolo :grin:


User avatar
_Newbie_
Posts: 188
Joined: 19 Dec 2010, 17:29

Post by _Newbie_ » 07 Feb 2011, 16:06

wah harus diremove dulu y? ok saya coba deh kak......


User avatar
saa7_go
Posts: 464
Joined: 21 Jan 2011, 23:37
Contact:

Post by saa7_go » 08 Feb 2011, 22:36

thrvers wrote:'
modem yg sudah tested:
Pertanyaan untuk haier c700. Saya juga pake hape itu tp tidak perlu melakukan eject dan rmmod dulu, langsung me-modprobe module usbserial. Apa karena hapenya diisi dengan memori card?


User avatar
_Newbie_
Posts: 188
Joined: 19 Dec 2010, 17:29

Post by _Newbie_ » 08 Feb 2011, 23:43

wah tetap gak bisa bro thrvers nyerah Ane.......


User avatar
thrvers
Posts: 4458
Joined: 01 Jan 2010, 13:28
Location: Jombang, Indonesia
Contact:

Post by thrvers » 09 Feb 2011, 00:18

'
saa7_go wrote:.....
Pertanyaan untuk haier c700. Saya juga pake hape itu tp tidak perlu melakukan eject dan rmmod dulu, langsung me-modprobe module usbserial. Apa karena hapenya diisi dengan memori card?

kalau dipikir2 bener juga :D padahal kagak ada memorycard yg nancep, tapi masih dikenali sebagai usb-card

pernah coba2 kalau kompi dimatikan c700 tidak bisa lgsg dipakai.
kecuali restart, lgsg bisa.

= seingat q gitu :grin: =


User avatar
saa7_go
Posts: 464
Joined: 21 Jan 2011, 23:37
Contact:

Post by saa7_go » 09 Feb 2011, 00:26

thrvers wrote: kalau dipikir2 bener juga :D padahal kagak ada memorycard yg nancep, tapi masih dikenali sebagai usb-card

pernah coba2 kalau kompi dimatikan c700 tidak bisa lgsg dipakai.
kecuali restart, lgsg bisa.

= seingat q gitu :grin: =
kok bisa beda ya, punyaku malah ga pernah kedetek sebagai usb-card. yang jadi masalah sih biasanya kalo udah connect trus di-disconnect trus di-connect-kan lagi malah ga bisa. hapenya harus di-restart dulu baru bisa.


User avatar
hamm
Posts: 5
Joined: 12 Feb 2011, 23:33
Location: Denpasar
Contact:

Post by hamm » 13 Feb 2011, 00:30

thx brotha atas penerangannya :)
sangat lengkap, jelas, dan bermanfaat..
keep explaining ! :D


User avatar
lisnux
Posts: 1763
Joined: 02 Jan 2010, 16:26
Location: Samarinda
Contact:

Post by lisnux » 13 Feb 2011, 18:41

Modem iClick 9310 berhasil, dengan catatan SIM PIN harus di remove :D


User avatar
ilham2930
Posts: 1123
Joined: 02 Jan 2010, 19:30
Location: /indonesia/tangerang/bonank_city
Contact:

Post by ilham2930 » 14 Feb 2011, 08:51

Nice trick
thanks for sharing bro


User avatar
maleo
Posts: 2
Joined: 19 Feb 2011, 09:20
Location: tasikmalaya
Contact:

Post by maleo » 20 Feb 2011, 08:13

aku ikutin step2 yg diatas, udah jalan kak di hp modem smart nexian c951. ampe bisa browsing. tappi masalahnya, setelah koneksi itu di matikan. susah utk bisa koneksi lg...

mohon pencerahan kaka ???

aku pake ubuntu 10.10 di netbook axioo pjma615


User avatar
abiramujalulu
Posts: 21
Joined: 19 Feb 2011, 20:50

Post by abiramujalulu » 26 Feb 2011, 19:45

Mantabss Tq Juragan


User avatar
crimsonlynx
Posts: 18
Joined: 06 Jan 2011, 10:25

Post by crimsonlynx » 02 Mar 2011, 15:32

Aku pake venus vt-80 tp kok ga kedetect apa-apa yah?
aku pake ubuntu 10.10 netbook
mohon pencerahannya


User avatar
thrvers
Posts: 4458
Joined: 01 Jan 2010, 13:28
Location: Jombang, Indonesia
Contact:

Post by thrvers » 02 Mar 2011, 19:11

'
sudah sampai step yg mana bro crimsonlynx ??

binun jawabnya klo tidak detek apa?? :grin:
takutnya modemnya rusak


User avatar
crimsonlynx
Posts: 18
Joined: 06 Jan 2011, 10:25

Post by crimsonlynx » 02 Mar 2011, 19:52

Saya udah step terakhir setting apn broadbandnya. Itu ipv4 perlu diisi ga? Btw saya pake flexy


User avatar
thrvers
Posts: 4458
Joined: 01 Jan 2010, 13:28
Location: Jombang, Indonesia
Contact:

Post by thrvers » 02 Mar 2011, 20:07

'
IPv4 automatic saja.

mungkin kalau belum 'nyambung' perlu edit yg DNS saja.


User avatar
thrvers
Posts: 4458
Joined: 01 Jan 2010, 13:28
Location: Jombang, Indonesia
Contact:

Post by thrvers » 06 Mar 2011, 21:27

'
saa7_go wrote:
thrvers
kalau dipikir2 bener juga :D padahal kagak ada memorycard yg nancep, tapi masih dikenali sebagai usb-card

pernah coba2 kalau kompi dimatikan c700 tidak bisa lgsg dipakai.
kecuali restart, lgsg bisa.

= seingat q gitu :grin: =
kok bisa beda ya, punyaku malah ga pernah kedetek sebagai usb-card. yang jadi masalah sih biasanya kalo udah connect trus di-disconnect trus di-connect-kan lagi malah ga bisa. hapenya harus di-restart dulu baru bisa.

bener ternyata :D langsung modprobe saja, restart = sudah detek

THX


User avatar
Anak_Macho
Posts: 1
Joined: 06 Mar 2011, 11:22
Location: indonesia
Contact:

Post by Anak_Macho » 07 Mar 2011, 10:09

wah newbie ijin coba dulu ya :D


User avatar
gelby
Posts: 1
Joined: 06 Mar 2011, 22:13
Location: kernel
Contact:

Post by gelby » 07 Mar 2011, 11:57

makasih ilmunya mas bro...
ijin praktek...
klo g bisa ijin report disini


User avatar
kokabiel
Posts: 109
Joined: 16 Oct 2010, 00:57
Location: Grisee, Indonesia
Contact:

Post by kokabiel » 07 Mar 2011, 13:27

wew, mangtebs tenan tutor'e kang.....
LIKE THIS......
:P


User avatar
offline
Posts: 2672
Joined: 17 Feb 2010, 21:03
Location: Kebumen

Post by offline » 07 Mar 2011, 16:40

main topic
-catat vendor sama id productnya
-masukan ke /etc/modules
harus diinget neh :grin:


User avatar
fant48t1k
Posts: 3
Joined: 22 Jan 2011, 14:12

Post by fant48t1k » 11 Mar 2011, 20:19

thrvers wrote:'
Assalamu'alaikum :D

Berawal dari coba2 modem, venus vt18, haier c700 dan venus [unknown] :D yg semuanya terdapat storage [mmc slot] dan driver [hanya usb-modem venus]
dan semua modem tersebut lancar buat koneksi inet :grin: [tanpa pancing2 win$, cuma liat VID+PID di win]
Q menggunakan ubuntu 10.04 atau 10.10 atau mint9

Deteksi Modem:
  • biar gampang, masih bantuan win [pertama saja -terutama nubi linux spt q :grin:]. koneksikan dahulu modem [[color:#CC0000]sampai bisa akses inet[/color]], kemudian buka DeviceManager

    Image

    Keterangan:
    1. buka modems
    2. klik Properties
    3. TAB Details dan Device Instance ID
    4. Perhatikan kode VID_1D09&PID_AEF4 dan catat.
    .
  • sekarang masuk ubuntu, buka terminal:
    $ lsusb

    usb-modem [punya q] dikenali pertama sebagai �qualcom �.� [[color:#3333FF]VendorID dan ProductID beda dengan yg diatas, biarkan saja[/color]]
  • edit modules
    $ sudo nano /etc/modules

    masukkan Vendor dan Product [yg dilihat dr win$ tadi]
    usbserial vendor=0x1d09 product=0xaef4
    lp
  • save dan reboot
  • Nyalakan [size:14pt][color:#FF0000]�detektor�[/color][/size] :grin: terminal:
    $ tail -f /var/log/syslog
  • System - Preferences - NetworkConnections - TAB MobileBroadband - add
    cek apakah sudah muncul modemnya?? seperti:

    Image
Kalau belum konek coba:
  • savely remove [usb dan/atau ROM] di nautilus
  • remove ROM pke terminal:
    $ eject /dev/sr1
    sr1 bisa di deteksi dari $ ls /dev/sr* [CDROM yg terpasang juga akan di deteksi]
  • remove storage [mmc slot] pke terminal:
    $ sudo rmmod usb_storage
    Flashdisk usahakan jangan dicolok dulu
Dalam eksekusi 3 cara diatas [nautilus, eject atau rmmod] perhatikan [size:14pt][color:#FF0000]�detektor�[/color][/size] sampai ada �[color:#3333FF]Now managed[/color]� Pakai salah satu saja [kalau bisa].

contoh output 'detektor' waktu koneksi sudah siap:
.....
NetworkManager[1099]: (ttyUSB0): failed to look up interface index
NetworkManager[1099]: (ttyUSB0): new CDMA device (driver: 'generic' ifindex: -1)
NetworkManager[1099]: (ttyUSB0): exported as /org/freedesktop/NetworkManager/Devices/1
NetworkManager[1099]: (ttyUSB0): now managed
NetworkManager[1099]: (ttyUSB0): device state change: 1 -> 2 (reason 2)
NetworkManager[1099]: (ttyUSB0): deactivating device (reason: 2).
NetworkManager[1099]: (ttyUSB0): device state change: 2 -> 3 (reason 0)
.....
Koneksi Modem:
  • buka: System - Preferences - NetworkConnections - TAB MobileBroadband - add
  • modem yg terdeteksi lihat gambar diatas, next.
    Isi negara, provider, jenis modem 3G/CDMA.
  • edit lagi username, password bila belum terhubung.
BONUS:
BONUS wrote:bila koneksi putus [tiba2 atau tersenggol :grin:] biasanya akan sulit melakukan koneksi lagi, selain di restart ubuntunya. Sedikit trik, coba cabut dulu semua FD yg sedang tercolok, lalu:
$ sudo rmmod usb_storage

Lalu koneksikan modem seperti biasa :D InsyAllah akan bisa lagi [tanpa restart ubuntunya, mungkin hanya perlu cabut-colok saja]
NB:
  • Buat modem selain q sebutin diatas [venus_vt, haier c700] bisa di coba sendiri, kalau bisa lanjutkan trit dibawah
  • cara ini tanpa instal paket 'usb-modeswitch' jadi remove purge dulu biar gak bentrok.
    $ sudo apt-get remove --purge usb-modeswitch
= Slamet berinternet, safe and clean =
Hu hu hu hu . . . Cara anda tidak bisa saya pakai pada modem saya,

venus vt_12.

Cara anda mudah dimengerti, hanya saja benar-benar saya belum

menemukan solusinya untuk modem saya punya.

Terima kasih telah berbagi pengetahuannya.


User avatar
SaGa
Posts: 188
Joined: 19 Jan 2010, 09:09
Location: Banyuwangi
Contact:

Post by SaGa » 14 Apr 2011, 13:13

sedikit sharing juga.
Setelah modem berhasil dikenali Ubuntu, bisa juga dialnya pake WVdial. lumayan lebih kenceng.[pake flexi]
1. Instal wvdial

Code: Select all

$sudo apt-get install wvdial
2. Edit konfigurasi wvdial

Code: Select all

$sudo gedit /etc/wvdial.conf
3. Ubah konfigurasinya sehingga seperti ini

Code: Select all

    [Dialer flexi]
    init1 = ATZ
    init2 = AT+CRM=1
    Stupid mode = 1
    Phone = #777
    SetVolume = 0
    FlowControl = Hardware(CRTSTCS)
    Inhents = Modem0
    Modem = /dev/ttyUSB0
    Username = *******@free
    Password = telkom
    DialCommand = ATDT
    Baud = 115200
nb : bagian username, isi dengan username masing-masing.

4. Pada terminal ketik

Code: Select all

$sudo wvdial flexi
source : My Blog


User avatar
thrvers
Posts: 4458
Joined: 01 Jan 2010, 13:28
Location: Jombang, Indonesia
Contact:

Post by thrvers » 14 Apr 2011, 16:29

'
THX kak SaGa buat sharingnya :D

btw itu detek modemnya gmn?? apa colok lgsg detek tanpa perlu eject, savely-remove, rmmod??
kalau boleh tahu sekalian merk, type, gambar juga :grin:

THX


User avatar
SaGa
Posts: 188
Joined: 19 Jan 2010, 09:09
Location: Banyuwangi
Contact:

Post by SaGa » 14 Apr 2011, 19:45

kan udah masuk list bro di forums/ubbthreads.php/topics/57650/1 :grin:

caranya ya seperti yang bro thrvers share..
cuma dialnya aja yang pake Wvdial, ga pake network manager :grin::grin:


User avatar
MasDjo
Posts: 1260
Joined: 03 Jan 2010, 17:38
Location: Bayuangga City
Contact:

Post by MasDjo » 26 Apr 2011, 14:25

Modem Prolink P2000 masih belum bisa nih... sampai pusing saya :(


User avatar
saa7_go
Posts: 464
Joined: 21 Jan 2011, 23:37
Contact:

Post by saa7_go » 26 Apr 2011, 14:32

MasDjo wrote:Modem Prolink P2000 masih belum bisa nih... sampai pusing saya :(
dah dicoba pake Sakis3G?

Update:
maap, saya kirain modem GSM. :D
btw, belum bisanya waktu dial atau deteksi modemnya?
Last edited by saa7_go on 27 Feb 2016, 16:25, edited 1 time in total.
Reason: ralat


User avatar
MasDjo
Posts: 1260
Joined: 03 Jan 2010, 17:38
Location: Bayuangga City
Contact:

Post by MasDjo » 26 Apr 2011, 22:08

Belum bisa jika diaktifkan 'hanya' dg Ubuntu.
Deteksi modem cdma Prolink P2000 tetap sbg usb-storage, meskipun sudah dilakukan modprobe ataupun usb_modeswitch.
Namun jika 'dipancing' dulu dg MS Windows (diaktifkan dulu modemnya di windows) baru bisa berubah/terdeteksi sbg usb-modem dg id v=0x0fc6 p=0x6000. Tetapi jika modem kita cabut, lalu ditancapkan lagi maka akan kembali sbg usb-storage.
Namun jika 'hanya' lewat Ubuntu maka modem tetap terdetek sbg usb-storage dg id=0x05c6 p=0x1000, meskipun telah dilakukan langkah2 seperti yg telah disebutkan di trit ini


User avatar
saa7_go
Posts: 464
Joined: 21 Jan 2011, 23:37
Contact:

Post by saa7_go » 26 Apr 2011, 23:06

Saya bingung dengan modem Prolink P2000. Maksudnya, kok device modemnya bisa beda-beda. Ada yang 05c6:6000, tp punya MasDjo 0fc6:6000 (beneran 0fc6?). Btw, mungkin saja ada konflik dengan konfigurasi-konfiguras lain yang memiliki device 05c6:1000, karena ada banyak konfigurasi dengan device seperti itu. Setelah saya liat, ada 6 buah file konfigurasi:

Code: Select all

05c6:1000:sVe=Option   05c6:1000:uMa=Option   05c6:1000:uMa=SSE
05c6:1000:uMa=AnyDATA  05c6:1000:uMa=SAMSUNG  05c6:1000:uMa=Vertex
Bagaimana kalo file-file konfigurasi di atas dipindah ke folder lain kecuali yang sesuai dengan devicenya MasDjo? Moga-moga aja bisa.


User avatar
MasDjo
Posts: 1260
Joined: 03 Jan 2010, 17:38
Location: Bayuangga City
Contact:

Post by MasDjo » 27 Apr 2011, 10:00

Sorry, salah tulis tuh saya... :grin:
yg benar v=05c6 .... :grin:

Maksudnya ini konfigurasi pd usb_modeswitch ya, ok akan saya coba, trims :D


User avatar
MasDjo
Posts: 1260
Joined: 03 Jan 2010, 17:38
Location: Bayuangga City
Contact:

Post by MasDjo » 28 Apr 2011, 11:28

Masih belum sukses nih, memang bandel banget nih modem, tetep saja terdetek sbg usb_storage. Saya sudah coba pd beberapa distro, seperti Puppy (Lupu 5) dan Mandriva, sama saja hasilnya :(


User avatar
saa7_go
Posts: 464
Joined: 21 Jan 2011, 23:37
Contact:

Post by saa7_go » 28 Apr 2011, 11:32

MasDjo wrote: Maksudnya ini konfigurasi pd usb_modeswitch ya, ok akan saya coba, trims :D

oh iya. lupa bilang. :D
MasDjo wrote:Masih belum sukses nih, memang bandel banget nih modem, tetep saja terdetek sbg usb_storage. Saya sudah coba pd beberapa distro, seperti Puppy (Lupu 5) dan Mandriva, sama saja hasilnya :(
Wah, brati mirip2 hape modem haier d1200p itu ya, butuh dipancing di Windows dulu... :(
Last edited by saa7_go on 27 Feb 2016, 16:25, edited 1 time in total.
Reason: nambah merk & seri hape


User avatar
sipelaut
Posts: 1965
Joined: 03 Jan 2010, 17:25
Location: madura-sampang
Contact:

Post by sipelaut » 28 Apr 2011, 15:56

wow... nice inpohhhh


User avatar
ilham2930
Posts: 1123
Joined: 02 Jan 2010, 19:30
Location: /indonesia/tangerang/bonank_city
Contact:

Post by ilham2930 » 29 Apr 2011, 09:43



User avatar
Glentchromat
Posts: 8
Joined: 07 May 2011, 13:56
Location: Cikarang
Contact:

Post by Glentchromat » 18 May 2011, 23:54

Gan ane mau nanya.... modem ane ke deteck seperti dibawah.. gimana ejectnya gan ?? soalnya masih mass storage.. thanks ..
[ 102.232038] usbcore: registered new interface driver usbserial
[ 102.232092] USB Serial support registered for generic
[ 102.232139] usbserial_generic 3-1:1.1: generic converter detected
[ 102.232381] usb 3-1: generic converter now attached to ttyUSB0
[ 102.232419] usbserial_generic 3-1:1.2: generic converter detected
[ 102.232610] usb 3-1: generic converter now attached to ttyUSB1
[ 102.232643] usbserial_generic 3-1:1.3: generic converter detected
[ 102.232826] usb 3-1: generic converter now attached to ttyUSB2
[ 102.232858] usbserial_generic 3-1:1.4: generic converter detected
[ 102.233033] usb 3-1: generic converter now attached to ttyUSB3
[ 102.233087] usbcore: registered new interface driver usbserial_generic
[ 102.233095] usbserial: USB Serial Driver core
[ 107.663208] PPP BSD Compression module registered
[ 107.703875] PPP Deflate Compression module registered
[ 158.838099] __ratelimit: 6 callbacks suppressed
[ 158.838112] soffice.bin[3883]: segfault at 4d885e9 ip 04d885e9 sp b2b8d1a0 error 4 in libresolv-2.11.1.so[4e5b000+10000]
[ 4735.729149] usb 3-1: USB disconnect, address 2
[ 4735.730099] generic ttyUSB0: generic converter now disconnected from ttyUSB0
[ 4735.730209] usbserial_generic 3-1:1.1: device disconnected
[ 4735.730991] generic ttyUSB1: generic converter now disconnected from ttyUSB1
[ 4735.731077] usbserial_generic 3-1:1.2: device disconnected
[ 4735.731772] generic ttyUSB2: generic converter now disconnected from ttyUSB2
[ 4735.731875] usbserial_generic 3-1:1.3: device disconnected
[ 4735.748761] generic ttyUSB3: generic converter now disconnected from ttyUSB3
[ 4735.749125] usbserial_generic 3-1:1.4: device disconnected
[ 4742.264151] usb 2-2: new full speed USB device using uhci_hcd and address 2
[ 4742.429582] usb 2-2: configuration #1 chosen from 1 choice
[ 4742.435396] scsi5 : SCSI emulation for USB Mass Storage devices
[ 4742.436037] usb-storage: device found at 2
[ 4742.436051] usb-storage: waiting for device to settle before scanning


dan akeluar juga

[ 1.385175] usb 3-1: new full speed USB device using uhci_hcd and address 2
[ 1.404170] ata1: SATA link up 1.5 Gbps (SStatus 113 SControl 300)
[ 1.405968] ata1.00: ACPI cmd ef/10:03:00:00:00:a0 (SET FEATURES) filtered out
[ 1.438123] ata1.00: ATA-8: WDC WD2500BJKT-00F4T0, 11.01A11, max UDMA/133
[ 1.438139] ata1.00: 488397168 sectors, multi 16: LBA48 NCQ (depth 31/32), AA
[ 1.440765] ata1.00: ACPI cmd 00/00:00:00:00:00:a0 (NOP) rejected by device (Stat=0x51 Err=0x04)
[ 1.441126] ata1.00: configured for UDMA/133
[ 1.456494] scsi 0:0:0:0: Direct-Access ATA WDC WD2500BJKT-0 11.0 PQ: 0 ANSI: 5
[ 1.456896] sd 0:0:0:0: Attached scsi generic sg0 type 0
[ 1.456942] sd 0:0:0:0: [sda] 488397168 512-byte logical blocks: (250 GB/232 GiB)
[ 1.457317] sd 0:0:0:0: [sda] Write Protect is off
[ 1.457329] sd 0:0:0:0: [sda] Mode Sense: 00 3a 00 00
[ 1.457430] sd 0:0:0:0: [sda] Write cache: enabled, read cache: enabled, doesn't support DPO or FUA
[ 1.457847] sda: sda1 sda2
[ 1.507663] sd 0:0:0:0: [sda] Attached SCSI disk
[ 1.545624] usb 3-1: configuration #1 chosen from 1 choice
[ 1.571006] Initializing USB Mass Storage driver...
[ 1.571518] scsi4 : SCSI emulation for USB Mass Storage devices
[ 1.572132] usb-storage: device found at 2
[ 1.572139] usb-storage: waiting for device to settle before scanning
[ 1.572214] usbcore: registered new interface driver usb-storage
[ 1.572363] USB Mass Storage support registered.
[ 1.984832] EXT4-fs (sda6): mounted filesystem with ordered data mode
[ 6.573311] usb-storage: device scan complete
[ 6.576253] scsi 4:0:0:0: Direct-Access Qualcomm MMC Storage 2.31 PQ: 0 ANSI: 2
[ 6.577362] sd 4:0:0:0: Attached scsi generic sg1 type 0
[ 6.587231] sd 4:0:0:0: [sdb] 63895552 512-byte logical blocks: (32.7 GB/30.4 GiB)
[ 6.592213] sd 4:0:0:0: [sdb] Write Protect is off
[ 6.592229] sd 4:0:0:0: [sdb] Mode Sense: 0b 00 00 08
[ 6.592240] sd 4:0:0:0: [sdb] Assuming drive cache: write through
[ 6.606218] sd 4:0:0:0: [sdb] Assuming drive cache: write through
[ 6.606236] sdb: sdb1
[ 6.625239] sd 4:0:0:0: [sdb] Assuming drive cache: write through
[ 6.625256] sd 4:0:0:0: [sdb] Attached SCSI removable disk
[ 7.467142] Adding 2970616k swap on /dev/sda7. Priority:-1 extents:1 across:2970616k


gimana tu gan please........


User avatar
thrvers
Posts: 4458
Joined: 01 Jan 2010, 13:28
Location: Jombang, Indonesia
Contact:

Post by thrvers » 19 May 2011, 02:54

'
kak Glentchromat, sudah baca dari awal?? [ :( kok masih tanya gimana eject-nya]

silakan dibaca dolo.


Post Reply

Who is online

Users browsing this forum: No registered users and 9 guests