[SOLVED] dpkg error:libqt5printsupport5

Semua mengenai lingkungan desktop Ubuntu.
Locked
User avatar
iColdPlayer
Posts: 4
Joined: 22 Mar 2018, 22:19

dpkg error:libqt5printsupport5  [SOLVED]

Post by iColdPlayer » 22 Mar 2018, 23:29

Selamat malam sesepuh sekalian,

Saya member baru di forum FUI ini,
saya juga masih pengguna baru terutama untuk yang berhubungan dengan Linux
saya pakai ubuntu 17.10 ( artful aardvark ).

sudah 2 hari kemarin saya mengalami kendala waktu mau upgrade melalui terminal,

Code: Select all

sudo apt upgrade -y

Code: Select all

dpkg: unrecoverable fatal error, aborting:
 reading files list for package 'libqt5printsupport5:amd64': Input/output error
E: Sub-process /usr/bin/dpkg returned an error code (2)
saya sudah coba beberapa cara juga yang saya dapat dari google, askubuntu, stackoverflow, facebook group, dll tapi masih sama,

barangkali ada agan2 sekalian yang pernah mengalami...

sudah coba juga buat remove & reinstall file tsb tapi masih failed,..


User avatar
#RisX
Posts: 31
Joined: 18 Jul 2014, 13:29
Location: jakarta

Post by #RisX » 23 Mar 2018, 10:03

Penyebabnya bisa jadi ada 2 kemungkinan om :
  • Hardisknya Error (bad sector)
  • package statusnya error
kita coba cara fix yg kedua "package statusnya error" :
  • buka terminal, masuk sebagai root atau sudo
  • buat backup dulu, buat jaga2 : sudo cp /var/lib/dpkg/status /var/lib/dpkg/status-bacup
  • sudo gedit /var/lib/dpkg/status
  • tekan CTRL+F, cari libqt5printsupport5, hapus baris (seperti pada foto attachment)
  • save & exit
  • ketik : sudo dpkg --configure -a
Attachments
libqt5printsupport5.png
Hapus baris bagian ini :

Package: libqt5printsupport5
Status: install ok installed
Priority: optional
Section: libs
Installed-Size: 579
Maintainer: Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Architecture: amd64
Multi-Arch: same
Source: qtbase-opensource-src
Version: 5.2.1+dfsg-1ubuntu14.3
Depends: libc6 (>= 2.14), libqt5core5a (>= 5.0.2), libqt5gui5 (>= 5.0.2) | libqt5gui5-gles (>= 5.0.2), libqt5widgets5 (>= 5.2.0), libstdc++6 (>= 4.1.1), qtbase-abi-5-2-1
Pre-Depends: dpkg (>= 1.15.6~), multiarch-support
Recommends: libcups2
Description: Qt 5 print support module
Qt is a cross-platform C++ application framework. Qt's primary feature
is its rich set of widgets that provide standard GUI functionality.
.
The QtPrintSupport module provides classes to make printing easier and
portable.
Homepage: http://qt-project.org/
Original-Maintainer: Debian Qt/KDE Maintainers <debian-qt-kde@lists.debian.org>
libqt5printsupport5.png (69.95 KiB) Viewed 196 times


User avatar
iColdPlayer
Posts: 4
Joined: 22 Mar 2018, 22:19

Post by iColdPlayer » 23 Mar 2018, 21:11

gan saya udah coba barusan,...

setelah di hapus

Code: Select all

Package: libqt5printsupport5
saya coba update,
di ending muncul output kurang lebih :

Code: Select all

E: The repository 'cdrom://Ubuntu 17.10 _Artful Aardvark_ - Release amd64 (20171018) artful Release' does not have a Release file.
N: Updating from such a repository can't be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.
E: The repository 'http://ppa.launchpad.net/gregory-hainaut/pcsx2.official.ppa/ubuntu artful Release' does not have a Release file.
N: Updating from such a repository can't be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.
berarti saya harus lakuin boot repair dari cd / live usb kah?
atau bagaimana gan?


User avatar
iColdPlayer
Posts: 4
Joined: 22 Mar 2018, 22:19

Post by iColdPlayer » 23 Mar 2018, 21:42

iColdPlayer wrote:
23 Mar 2018, 21:11
gan saya udah coba barusan,...

setelah di hapus

Code: Select all

Package: libqt5printsupport5
saya coba update,
di ending muncul output kurang lebih :

Code: Select all

E: The repository 'cdrom://Ubuntu 17.10 _Artful Aardvark_ - Release amd64 (20171018) artful Release' does not have a Release file.
N: Updating from such a repository can't be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.
E: The repository 'http://ppa.launchpad.net/gregory-hainaut/pcsx2.official.ppa/ubuntu artful Release' does not have a Release file.
N: Updating from such a repository can't be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.
berarti saya harus lakuin boot repair dari cd / live usb kah?
atau bagaimana gan?
Oke Solved gan,....

Terima kasih banyak gan,
sewaktu di hapus saya update

Code: Select all

sudo apt update

sudo apt upgrade -y : output error:libqt5printsupport5

sudo apt install libqt5printsupport5

sudo apt update && apt dist-upgrade

sudo apt upgrade -y

and done, 35 updated!
Terima kasih banyak gan untuk ilmunya,
btw ini juga berlaku kalau nanti semisalnya ada package lain yang rusak kan?
atau optional?


Locked

Who is online

Users browsing this forum: No registered users and 10 guests