Modem aha EC167 On Ubuntu 10.04

Membahas Perangkat-perangkat keras yang belum dideteksi dengan baik oleh Ubuntu serta solusinya.
Post Reply
User avatar
Cyb3erFr3ed0M
Contact:

Modem aha EC167 On Ubuntu 10.04

Post 20 Oct 2010, 19:45

pagi brother2 and master2 ubuntu indonesia....hehe gini ane mau sedikit share buat teman2 ubuntu yang menggunakan modem aha EC167 on ubuntu 10.04 kemarin aku coba modem aha ku dibeberapa kompi milik temen yang gunakan ubuntu 10.04 ternyata tidak bisa terkoneksi hanya bisa buat sms doang....hehehhe tapi jangan kawatir langsung aja kita praktekan.......
==========================================================================
pertama : Tancapkan Modem aha EC167 di kompi....dengan sendirinya modem terdeteksi sebagai cd driver

kedua :buka terminal masuk sebagai root ketikan "cd /media/AHA\/Dialer/" trus enter

ketiga :masih diterminaL ketikan "sudo bash ./install_linux" dengan sendirinya dia akan menginstall

keempat :installasi selesai...coba ente koneksikan aha dan hasilnya pasti tidak bisa hehehehe jangan khawatir...

kelima :close Dialer aha dan eject cd driver dengan cara klik kanan => eject" jika sudah download kelima file ini
=======================================================================
http://kambing.vlsm.org/ubuntu/pool/main/x/xplc /libxplc0.3.13_0.3.13-1build1_i386.deb

http://kambing.vlsm.org/ubuntu/pool/mai ... 2_i386.deb

http://kambing.vlsm.org/ubuntu/pool/mai ... 2_i386.deb

http://kambing.vlsm.org/ubuntu/pool/mai ... 2_i386.deb

http://kambing.vlsm.org/ubuntu/pool/mai ... 2_i386.deb
=======================================================================
kalau udah download dan install mari kita lanjutkan ketahap berikutnya
masuk terminal lagi...ketikkan "sudo gedit /etc/wvdial.conf" hapus semua ganti dengan script ini
========================================================================
[Dialer AHA]
Init1 = ATZ
Init2 = ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
Stupid Mode = 1
Modem = /dev/ttyUSB0
Phone = #777
Idle Seconds = 300
Password = aha
Modem Type = USB Modem
Compuserve = 0
Baud = 921600
Auto DNS = 1
Dial Command = ATDT
Ask Password = 0
ISDN = 0
Username = aha@aha.co.id
=======================================================================
jika sudah save and close...........!!!! oke mulai tahap koneksi..
ketik "lsusb" jika modem terdeteksi ada tulisan kayak gini
"Bus 005 Device 003: ID 12d1:140c Huawei Technologies Co., Ltd."
lalu lanjutkan dengan ini "sudo modprobe usbserial vendor=0x12d1 product=0x140c" lalu enter satu kali lagi ketikkan "sudo wvdial AHA"
=======================================================================
n3wbie@n3wbie-laptop:~$ sudo wvdial AHA
--> WvDial: Internet dialer version 1.60
--> Cannot get information for serial port.
--> Initializing modem.
--> Sending: ATZ
ATZ
OK
--> Sending: ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
OK
--> Modem initialized.
--> Idle Seconds = 300, disabling automatic reconnect.
--> Sending: ATDT#777
--> Waiting for carrier.
ATDT#777
CONNECT
--> Carrier detected. Starting PPP immediately.
--> Starting pppd at Wed Oct 20 17:44:28 2010
--> Pid of pppd: 1866
--> Using interface ppp0
--> pppd: �o
--> pppd: �o
--> pppd: �o
--> pppd: �o
--> pppd: �o
--> local IP address xx.xx.xx
--> pppd: �o
--> remote IP address xx.xx.xx
--> pppd: �o
--> primary DNS address xx.xx.xx.xx
--> pppd: �o
--> secondary DNS address xx.xx.xx.xx
--> pppd: �o
=======================================================================
akhirnya modem AHA terkoneksi hohohohoh mantap


User avatar
lavigne

Post 26 Oct 2010, 09:45

wah bro, mohon bantuannya. setelah disave and clos wvdial.conf, ditahap selanjutnya tidak bisa...
--> no such file directory

mohon bantuannya...


User avatar
freeazy
Contact:

Post 26 Oct 2010, 10:24

lavigne wrote:wah bro, mohon bantuannya. setelah disave and clos wvdial.conf, ditahap selanjutnya tidak bisa...
--> no such file directory

mohon bantuannya...


no such file directory muncul sewaktu apa ? perintah apa yang dijalankan ?


User avatar
kurakuralemot

Post 04 Apr 2011, 14:06

itu yang sudo bash ./install_linux-nya masih di root kan yah??

masi nubi nih..baru gabung :)
mohon bantuannya yahh :))


User avatar
ajiemix
Contact:

Post 04 Apr 2011, 14:22

wah yg ane cari2 neh udh sebulan ...
modem aha ane ga konek2....
ane coba dlu gan....


User avatar
ajiemix
Contact:

Post 04 Apr 2011, 14:51

msh gagal gannn....no such file directory
pas step ini >>> cd /media/AHA\/Dialer/
ane pke ubuntu 10.10


User avatar
thrvers
Contact:

Post 04 Apr 2011, 15:09

'
ajiemix wrote:msh gagal gannn....no such file directory
pas step ini >>> cd /media/AHA\/Dialer/
ane pke ubuntu 10.10

coba dicek dolo bro
cd /media/

akan muncul daftar folder yg tersedia :D [mungkin beda penamaan mountpoint "AHA Dialer"]

CMIIW


User avatar
OmGenBun

Post 11 Apr 2011, 12:58

thrvers wrote:'
ajiemix wrote:msh gagal gannn....no such file directory
pas step ini >>> cd /media/AHA\/Dialer/
ane pke ubuntu 10.10

coba dicek dolo bro
cd /media/

akan muncul daftar folder yg tersedia :D [mungkin beda penamaan mountpoint "AHA Dialer"]

CMIIW
setelah tekan tab2x muncul
AHA Dialer/ cdrom/ cdrom0/
selanjutnya gimana lagi ya gan?


User avatar
OmGenBun

Post 11 Apr 2011, 15:06

dengan cara wvdial seperti di atas saya udah berhasil konek..
cuma kok agak lambat ya?
apa ga bisa kita install yang bawaan dari AHA ya?

Jadi share untuk yang berhasil?
yakinkan bahwa file wvstream dan lain2nya yang harus didownload di atas sudah terinstal semua di komputer kita.
kemudian ikuti langkah di atas secara detail satu persatu ya.. siapa tahu kaya aku ada yang terlewat..


User avatar
ironman

Post 10 May 2011, 10:37

boss, setelah
$ sudo wvdial AHA
kok keluarnya

--> WvDial: Internet dialer version 1.60
--> Cannot open /dev/ttyUSB0: No such file or directory
--> Cannot open /dev/ttyUSB0: No such file or directory
--> Cannot open /dev/ttyUSB0: No such file or directory

padahal step by step udah bener tuh...ada saran lain ga?
gila, gue udah stress ne :(


User avatar
thrvers
Contact:

Post 10 May 2011, 10:47

'
ada, coba ini dolo:
$ sudo wvdialconf

baru yg atas, jgn diubah yg modem [soalnya ttyUSB0 bukan modemnya]
sudo gedit /etc/wvdial.conf

CMIIW


User avatar
ironman

Post 10 May 2011, 12:49

thrvers wrote:'
ada, coba ini dolo:
$ sudo wvdialconf

baru yg atas, jgn diubah yg modem [soalnya ttyUSB0 bukan modemnya]
sudo gedit /etc/wvdial.conf

CMIIW
jadi untuk scriptnya di sudo gedit /etc/wvdial.conf jadi gimana ini boss?
soalnya habis masuk ke configurasinya scriptnya jadi ada dua, yang dialer defaults ama yang udah gue bikin (dialer AHA)


User avatar
riyanpermadi30
Contact:

Post 10 May 2011, 15:11

setau aq aq pakex aha kalau maslah sepreti itu coba cabut pasang lagi modemnya

trus jalanin sudo wvdial

semoga bermanfaat


User avatar
ironman

Post 10 May 2011, 16:34

udah bisa, tapi endingnya pas bagian koneksi PPPD yang seharusnya
--> Carrier detected. Starting PPP immediately.
--> Starting pppd at Wed Oct 20 17:44:28 2010
--> Pid of pppd: 1866
--> Using interface ppp0
--> pppd: �o
--> pppd: �o
--> pppd: �o
--> pppd: �o
--> pppd: �o
--> local IP address xx.xx.xx
--> pppd: �o
--> remote IP address xx.xx.xx
--> pppd: �o
--> primary DNS address xx.xx.xx.xx
--> pppd: �o
--> secondary DNS address xx.xx.xx.xx
--> pppd: �o

itu jadi
--> Carrier detected. Starting PPP immediately.
--> Starting pppd at Wed Oct 20 17:44:28 2010
--> Pid of pppd: 2170
--> Using interface ppp0
--> pppd: n
--> pppd: n
--> pppd: n
--> pppd: n
--> pppd: n
--> local IP address xx.xx.xx
--> pppd: n
--> remote IP address xx.xx.xx
--> pppd: n
--> primary DNS address xx.xx.xx.xx
--> pppd: n
--> secondary DNS address xx.xx.xx.xx
--> pppd: n

salahnya dimana ya?


User avatar
thrvers
Contact:

Post 10 May 2011, 18:48

'
ironman wrote:
thrvers
'
ada, coba ini dolo:
$ sudo wvdialconf

baru yg atas, jgn diubah yg modem [soalnya ttyUSB0 bukan modemnya]
sudo gedit /etc/wvdial.conf

CMIIW
jadi untuk scriptnya di sudo gedit /etc/wvdial.conf jadi gimana ini boss?
soalnya habis masuk ke configurasinya scriptnya jadi ada dua, yang dialer defaults ama yang udah gue bikin (dialer AHA)

maap lupa :grin:
yg default itu :D hasil dari wvdialconf
kira2 gini
[spoiler]

Code: Select all

[Dialer Default]
Init1 = ATZ
Init2 = ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
Stupid Mode = 1
Modem = /dev/ttyUSB0       ## <== baris ini yg jangan diubah2
Phone = #777
Idle Seconds = 300
Password = aha
Modem Type = USB Modem
Compuserve = 0
Baud = 460800
Auto DNS = 1
Dial Command = ATDT
Ask Password = 0
ISDN = 0
Username = aha@aha.co.id
[/spoiler]
gt aj triknya :D


User avatar
Glentchromat
Contact:

Post 18 May 2011, 23:52

Gan ane mau nanya.... modem ane ke deteck seperti dibawah.. gimana ejectnya gan ?? soalnya masih mass storage.. thanks ..

Tapi modem fast2 evdo ... kartu smart

[ 102.232038] usbcore: registered new interface driver usbserial
[ 102.232092] USB Serial support registered for generic
[ 102.232139] usbserial_generic 3-1:1.1: generic converter detected
[ 102.232381] usb 3-1: generic converter now attached to ttyUSB0
[ 102.232419] usbserial_generic 3-1:1.2: generic converter detected
[ 102.232610] usb 3-1: generic converter now attached to ttyUSB1
[ 102.232643] usbserial_generic 3-1:1.3: generic converter detected
[ 102.232826] usb 3-1: generic converter now attached to ttyUSB2
[ 102.232858] usbserial_generic 3-1:1.4: generic converter detected
[ 102.233033] usb 3-1: generic converter now attached to ttyUSB3
[ 102.233087] usbcore: registered new interface driver usbserial_generic
[ 102.233095] usbserial: USB Serial Driver core
[ 107.663208] PPP BSD Compression module registered
[ 107.703875] PPP Deflate Compression module registered
[ 158.838099] __ratelimit: 6 callbacks suppressed
[ 158.838112] soffice.bin[3883]: segfault at 4d885e9 ip 04d885e9 sp b2b8d1a0 error 4 in libresolv-2.11.1.so[4e5b000+10000]
[ 4735.729149] usb 3-1: USB disconnect, address 2
[ 4735.730099] generic ttyUSB0: generic converter now disconnected from ttyUSB0
[ 4735.730209] usbserial_generic 3-1:1.1: device disconnected
[ 4735.730991] generic ttyUSB1: generic converter now disconnected from ttyUSB1
[ 4735.731077] usbserial_generic 3-1:1.2: device disconnected
[ 4735.731772] generic ttyUSB2: generic converter now disconnected from ttyUSB2
[ 4735.731875] usbserial_generic 3-1:1.3: device disconnected
[ 4735.748761] generic ttyUSB3: generic converter now disconnected from ttyUSB3
[ 4735.749125] usbserial_generic 3-1:1.4: device disconnected
[ 4742.264151] usb 2-2: new full speed USB device using uhci_hcd and address 2
[ 4742.429582] usb 2-2: configuration #1 chosen from 1 choice
[ 4742.435396] scsi5 : SCSI emulation for USB Mass Storage devices
[ 4742.436037] usb-storage: device found at 2
[ 4742.436051] usb-storage: waiting for device to settle before scanning


dan akeluar juga

[ 1.385175] usb 3-1: new full speed USB device using uhci_hcd and address 2
[ 1.404170] ata1: SATA link up 1.5 Gbps (SStatus 113 SControl 300)
[ 1.405968] ata1.00: ACPI cmd ef/10:03:00:00:00:a0 (SET FEATURES) filtered out
[ 1.438123] ata1.00: ATA-8: WDC WD2500BJKT-00F4T0, 11.01A11, max UDMA/133
[ 1.438139] ata1.00: 488397168 sectors, multi 16: LBA48 NCQ (depth 31/32), AA
[ 1.440765] ata1.00: ACPI cmd 00/00:00:00:00:00:a0 (NOP) rejected by device (Stat=0x51 Err=0x04)
[ 1.441126] ata1.00: configured for UDMA/133
[ 1.456494] scsi 0:0:0:0: Direct-Access ATA WDC WD2500BJKT-0 11.0 PQ: 0 ANSI: 5
[ 1.456896] sd 0:0:0:0: Attached scsi generic sg0 type 0
[ 1.456942] sd 0:0:0:0: [sda] 488397168 512-byte logical blocks: (250 GB/232 GiB)
[ 1.457317] sd 0:0:0:0: [sda] Write Protect is off
[ 1.457329] sd 0:0:0:0: [sda] Mode Sense: 00 3a 00 00
[ 1.457430] sd 0:0:0:0: [sda] Write cache: enabled, read cache: enabled, doesn't support DPO or FUA
[ 1.457847] sda: sda1 sda2
[ 1.507663] sd 0:0:0:0: [sda] Attached SCSI disk
[ 1.545624] usb 3-1: configuration #1 chosen from 1 choice
[ 1.571006] Initializing USB Mass Storage driver...
[ 1.571518] scsi4 : SCSI emulation for USB Mass Storage devices
[ 1.572132] usb-storage: device found at 2
[ 1.572139] usb-storage: waiting for device to settle before scanning
[ 1.572214] usbcore: registered new interface driver usb-storage
[ 1.572363] USB Mass Storage support registered.
[ 1.984832] EXT4-fs (sda6): mounted filesystem with ordered data mode
[ 6.573311] usb-storage: device scan complete
[ 6.576253] scsi 4:0:0:0: Direct-Access Qualcomm MMC Storage 2.31 PQ: 0 ANSI: 2
[ 6.577362] sd 4:0:0:0: Attached scsi generic sg1 type 0
[ 6.587231] sd 4:0:0:0: [sdb] 63895552 512-byte logical blocks: (32.7 GB/30.4 GiB)
[ 6.592213] sd 4:0:0:0: [sdb] Write Protect is off
[ 6.592229] sd 4:0:0:0: [sdb] Mode Sense: 0b 00 00 08
[ 6.592240] sd 4:0:0:0: [sdb] Assuming drive cache: write through
[ 6.606218] sd 4:0:0:0: [sdb] Assuming drive cache: write through
[ 6.606236] sdb: sdb1
[ 6.625239] sd 4:0:0:0: [sdb] Assuming drive cache: write through
[ 6.625256] sd 4:0:0:0: [sdb] Attached SCSI removable disk
[ 7.467142] Adding 2970616k swap on /dev/sda7. Priority:-1 extents:1 across:2970616k


gimana tu gan please........


User avatar
streethardy

Post 11 Jun 2011, 22:23

gan, gw udh nyoba tuh smua cara dats, n smua lngkhny jg udh nympe smpe akhir. d terminl jg udh blg klo modemny udh connect, tp knytaanny blom jg bsa ngenet gw. udh sedeng nih dari tadi ga bisa bisa. salahnya dimana y???


User avatar
onokha

Post 23 Jun 2011, 15:33

Selamat sore Agan-agan....

Klo install Modem AHA EC167 di Ubuntu 11.4 dah ada yang bisa belum? saya nyobain gagal mulu.....


User avatar
thrvers
Contact:

Post 23 Jun 2011, 19:55

'
kak onokha gagalnya seperti apa [coba tulis errornya bila ada]
sudah dicoba seperti tutorial diatas??

= :o =


User avatar
Darma_Kusumah

Post 23 Jun 2011, 20:30

Good Job..
ilmu nya keren ni.. kpan" bleh coba ni om..

wvdial always.. never ending


User avatar
RockLinux

Post 10 Nov 2011, 17:17

om saya mau nanya ni........

saya pake modem aha my tv.......

udah install tu tapi ga bisa internetan lewat web browser.....

kalau lewat root bisa......update lewat terminal juga bisa.......

knapa ya mas ......maklum masih newbie.......hehehe????


User avatar
aptfast
Contact:

Post 11 Nov 2011, 09:15

saya berhasil konek dg lancar di kubuntu 11.10 dg network manager applet


User avatar
Malsasa

Post 16 Dec 2011, 20:27

Terima kasih, Kang. Trid ini saya jadikan rujukan untuk bahan artikel daftar modem Ubuntu di Ebook FUI v2.


Post Reply

Who is online

Users browsing this forum: No registered users and 21 guests