[Ask] nginx 404 not found panggil kelas codeignite

Diskusi tentang Ubuntu Server baik webserver, database server, samba server dan service lainnya serta jaringan menggunakan Sistem Operasi Ubuntu.
Post Reply
User avatar
thewizard
Posts: 133
Joined: 12 Apr 2012, 15:29
Contact:

[Ask] nginx 404 not found panggil kelas codeignite

Post by thewizard » 27 Jan 2015, 07:20

Permisi akang akang, mau bertanya, bagaimana konfigurasi web server Nginx agar bisa support dengan Codeigniter, pada awalnya ketika dipanggil alamat utamanya seperti http://localhost/folderci/index.php tidak ada masalah, namun ketika saya mulai memanggil nama kelas dan fungsinya malah jadi 404 not found, http://localhost/folderci/index.php/nam ... namafungsi,
sebelumnya kalau pakai webserver apache tidak ada masalah, mohon pencerahannya, sudah cari kesana kemari belum nemu juga solusi yang pas, terima kasih :)


User avatar
bang_andi
Posts: 398
Joined: 03 Sep 2010, 09:07
Location: Di sekitar sungai musi...
Contact:

Post by bang_andi » 27 Jan 2015, 09:53

saya sih kurang berpengalaman dengan nginx, tapi apa agan thewizard sudah setting access permission nya?


User avatar
thewizard
Posts: 133
Joined: 12 Apr 2012, 15:29
Contact:

Post by thewizard » 27 Jan 2015, 10:17

sudah diatur permissionnya kang, tapi tetep aja gabisa, pas baca review katanya itu masalah di parameter php, tapi begitu dikonfigurasi malah bad gateway


User avatar
bang_andi
Posts: 398
Joined: 03 Sep 2010, 09:07
Location: Di sekitar sungai musi...
Contact:

Post by bang_andi » 28 Jan 2015, 15:35

parameter php?

apa bisa agan kopas ke sini notifikasi errornya?


User avatar
thewizard
Posts: 133
Joined: 12 Apr 2012, 15:29
Contact:

Post by thewizard » 28 Jan 2015, 18:08

errornya cuma 404 not found kang, kalo pas dikasih parameter phpnya 502 bad gateway


User avatar
Etles_T3am
Posts: 260
Joined: 26 Nov 2014, 17:08
Location: Malang-Jatim, Indonesia

Post by Etles_T3am » 29 Jan 2015, 02:29

----Solusi ke-1----

Buka configurasi php5 ;

:~$ sudo nano /etc/php5/fpm/pool.d/www.conf

Kemudian hapus tanda (#) pada line-line berikut ini ;

listen.owner = www-data

listen.group = www-data
listen.mode = 0660


----Solusi ke-2----

Masih di file /etc/php5/fpm/pool.d/www.conf dengan mengubah ISPconfig pada php5, Cari line berikut ini ;

listen=/var/run/php5-fpm.sock

ubahlah menjadi seperti ini ;

listen=127.0.0.1:9000

----Solusi ke-3----

Apabila permasalahannya adalah "Owner & Permissions" tanpa mengubah pada bagian Solusi ke-2. Dengan kata lain sampean tetep menggunakan Unix Socket, Maka diharuskan untuk memberikan "Read-Write-Permissions To All" dengan perintah command ;

:~$ sudo chmod go+rw /var/run/php5-fpm.sock

Jangan lupa merestart php5 setelah melakukan perubahan, Baik pada solusi ke-1 sampai ke-3 dengan perintah command ;

:~$ sudo service php5-fpm restart

Semoga problem sampean bisa fixed :)


User avatar
thewizard
Posts: 133
Joined: 12 Apr 2012, 15:29
Contact:

Post by thewizard » 29 Jan 2015, 19:09

terima kasih jawabannya mas,
namun masih belum bisa mas, kalo bagian rewrite di sites-available/default harus diubah juga ga mas ? punya saya seperti ini :

server {
listen 80 default_server;
autoindex on;
# root /usr/share/nginx/html;
root /home/public_html/server1;
index index.php index.html index.htm;

# Make site accessible from http://localhost/
server_name localhost;
#rewrite ^(.*\.php)(/)(.*)$ last;

location / {
try_files $uri $uri/ =404;
#rewrite ^/(.*\.php)/(.*)$ last;
#try_files $uri $uri/ /index.php?$query_string;
# include /etc/nginx/naxsi.rules
}
location ~ \.php$ {
#try_files $uri $uri/ /index.php?$args;
fastcgi_split_path_info ^(.+\.php)(/.+)$;
fastcgi_param SCRIPT_FILENAME /home/public_html/server1$fastcgi_script_name;
fastcgi_param PATH_INFO $fastcgi_path_info;
fastcgi_pass unix:/var/run/php5-fpm.sock;
fastcgi_index index.php;
include fastcgi_params;

}
location ~ /\.ht {
deny all;
}
}

nah ketika dibagian location / { saya aktifkan rewrite dan menggunakan try_files yang dikomentar itu, malah kalau saya mengakses yang pake parameter seperti berikut http://localhost/folder/index.php/namakelas/namafungsi malah kebuka halaman awal localhost saja, rewritenya perlu diubah atau tidak ya mas ?


User avatar
Etles_T3am
Posts: 260
Joined: 26 Nov 2014, 17:08
Location: Malang-Jatim, Indonesia

Post by Etles_T3am » 30 Jan 2015, 20:43

Coba di reinstall "PHP5" nya Boss kemudian lakukan perubahan/settingan hanya pada "Solusi ke-2".


User avatar
thewizard
Posts: 133
Joined: 12 Apr 2012, 15:29
Contact:

Post by thewizard » 01 Feb 2015, 09:02

okedeh kang, saya coba lagi, terima kasih atas jawabannya kang :)


Post Reply

Who is online

Users browsing this forum: No registered users and 21 guests