tidak dapat menginstal apapun pada ubuntu 9.4

Semua mengenai teknik instalasi Ubuntu termasuk teknik instalasi aplikasinya dan migrasi dari Windows.
Post Reply
User avatar
angel
Posts: 15
Joined: 22 May 2010, 10:46
Contact:

tidak dapat menginstal apapun pada ubuntu 9.4

Post by angel » 22 May 2010, 11:02

Sebelumnya saya menginstal Empathy karena Pidgin-nya tidak daot di instal, tapi kemudian malah berefek panjang, setiap kali saya mengintal selalu saja error pesannya seperti di bawah ini, :

var/cache/apt/archives/gstreamer0.10-plugins-farsight_0.12.10-2_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1

Tolomg infonya donk, karena saya sudah copa dng berbagai macam cara tetep aja hsilnya seperti itu (sudo apt-get -f install, kemudian sudo apt-get update, yaitu .. semua perintah sayang saya input di terminal tetap saya bolak balik hasilnya seperti di atas)

Tolong infonya, duuuunk..


User avatar
thrvers
Posts: 4458
Joined: 01 Jan 2010, 13:28
Location: Jombang, Indonesia
Contact:

Post by thrvers » 22 May 2010, 11:11

'
udah ada yg bahas, ini mungkin malah triple post!!!
cari saja: 'dpkg returned an error code'

:D sulit jg carinya = dpkg-deb -i install


User avatar
angel
Posts: 15
Joined: 22 May 2010, 10:46
Contact:

Post by angel » 22 May 2010, 11:25

ya dah gw baca bro.., tapi tetep aja disitu caranya pake sudo apt-get -f instal trus sudo apt-get upgrade, dan cari ni dah gw cobain berekali2, yang ada malah bolak balik gitu lagi.

Errors were encountered while processing:
/var/cache/apt/archives/gstreamer0.10-plugins-farsight_0.12.10-2_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
marketing20@marketing12:~$

Mest diapain c, klo di hapus juga tetep.. mintanya balik lagi .. puyeng..


User avatar
thrvers
Posts: 4458
Joined: 01 Jan 2010, 13:28
Location: Jombang, Indonesia
Contact:

Post by thrvers » 22 May 2010, 11:32

'
hapus file itu (corrupt mkn):
$ sudo rm /var/cache/apt/archives/gstreamer0.10-plugins-farsight_0.12.10-2_i386.deb
$ sudo aptitude update


User avatar
angel
Posts: 15
Joined: 22 May 2010, 10:46
Contact:

Post by angel » 22 May 2010, 12:13

dah aku coba yang barusan negh, trus di coba di check pake
$ sudo apt-get update dan hasilnya adalah :

E: Could not get lock /var/lib/dpkg/lock - open (11 Resource temporarily unavailable)
E: Unable to lock the administration directory (/var/lib/dpkg/), is another process using it?

apa ya maksudnya?
Dah geto di compi gw bawahnya ada tanda setrip merah yang bilang " an error accurred, please run package manager from the right -clik menu or apt-get in terminal to see waht is wrong. means that you installed packges have unmet depencies "

walahhh.. apa gw salah instruksi yaa..??
maklum baru switch to ubuntu.. (berhubung mau ada sweeping :P)

help me


User avatar
thrvers
Posts: 4458
Joined: 01 Jan 2010, 13:28
Location: Jombang, Indonesia
Contact:

Post by thrvers » 22 May 2010, 12:25

'
retno
..............
E: Could not get lock /var/lib/dpkg/lock - open (11 Resource temporarily unavailable)
E: Unable to lock the administration directory (/var/lib/dpkg/), is another process using it?
.............

ada proses lain yg sedang menggunakan jadi tutup synaptic ato UbuntuSoftwareCenter nya, sis

NB:Salah satu saja yg dipake: terminal lewat aptitude, pke synaptic ato Ubuntu software center

cmiiw


User avatar
angel
Posts: 15
Joined: 22 May 2010, 10:46
Contact:

Post by angel » 22 May 2010, 12:36

gimana nutup nya :( nah tu package managernya ga bisa di tutup) apa mesti di restrart yaa compinya? pi tuh synaptic mangaer dari kemaren ga bisa bisa tutup, tau negh..


User avatar
thrvers
Posts: 4458
Joined: 01 Jan 2010, 13:28
Location: Jombang, Indonesia
Contact:

Post by thrvers » 22 May 2010, 12:44

'
logout ato restart jg bisa.

klo pake terminal jg bisa (tp lupa q perintahnya :D )


User avatar
angel
Posts: 15
Joined: 22 May 2010, 10:46
Contact:

Post by angel » 22 May 2010, 12:46

Nah sekarang dah gw coba lagi trus hasilnya ya tetep begini :


marketing20@marketing12:~$ sudo apt-get check
Reading package lists... Done
Building dependency tree
Reading state information... Done
You might want to run `apt-get -f install' to correct these.
The following packages have unmet dependencies:
libfarsight0.1-3: Depends: gstreamer0.10-plugins-farsight but it is not installed
E: Unmet dependencies. Try using -f.
marketing20@marketing12:~$

Ntar klo gw cobain pake -f jatuhnya balik lagi muter2 kesitu lagi2,

Gimana c..? please frustasi negh.. :@


User avatar
thrvers
Posts: 4458
Joined: 01 Jan 2010, 13:28
Location: Jombang, Indonesia
Contact:

Post by thrvers » 22 May 2010, 13:02

'
wew kek nya sources.list yg bermasalah sis. coba liat isi nya:
$ gedit /etc/apt/sources.list


User avatar
angel
Posts: 15
Joined: 22 May 2010, 10:46
Contact:

Post by angel » 22 May 2010, 13:08

Ini ada di source-nya:


# deb cdrom:[Ubuntu 9.04 _Jaunty Jackalope_ - Release i386 (20090420.1)]/ jaunty main restricted
# See http://help.ubuntu.com/community/UpgradeNotes for how to upgrade to
# newer versions of the distribution.

deb http://id.archive.ubuntu.com/ubuntu/ jaunty main restricted
deb-src http://id.archive.ubuntu.com/ubuntu/ jaunty main restricted

## Major bug fix updates produced after the final release of the
## distribution.

## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
## team. Also, please note that software in universe WILL NOT receive any
## review or updates from the Ubuntu security team.
deb http://id.archive.ubuntu.com/ubuntu/ jaunty universe
deb-src http://id.archive.ubuntu.com/ubuntu/ jaunty universe

## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
## team, and may not be under a free licence. Please satisfy yourself as to
## your rights to use the software. Also, please note that software in
## multiverse WILL NOT receive any review or updates from the Ubuntu
## security team.
deb http://id.archive.ubuntu.com/ubuntu/ jaunty multiverse
deb-src http://id.archive.ubuntu.com/ubuntu/ jaunty multiverse

## Uncomment the following two lines to add software from the 'backports'
## repository.
## N.B. software from this repository may not have been tested as
## extensively as that contained in the main release, although it includes
## newer versions of some applications which may provide useful features.
## Also, please note that software in backports WILL NOT receive any review
## or updates from the Ubuntu security team.
# deb http://id.archive.ubuntu.com/ubuntu/ jaunty-backports main restricted universe multiverse
# deb-src http://id.archive.ubuntu.com/ubuntu/ jaunty-backports main restricted universe multiverse

Abis tuh di apain tolong dunk.., gw bener buta negh.


User avatar
angel
Posts: 15
Joined: 22 May 2010, 10:46
Contact:

Post by angel » 22 May 2010, 13:11

## Uncomment the following two lines to add software from Canonical's
## 'partner' repository.
## This software is not part of Ubuntu, but is offered by Canonical and the
## respective vendors as a service to Ubuntu users.
# deb http://archive.canonical.com/ubuntu jaunty partner
# deb-src http://archive.canonical.com/ubuntu jaunty partner


User avatar
rhecizen
Posts: 427
Joined: 09 Jan 2010, 20:41
Location: Indonesia
Contact:

Post by rhecizen » 22 May 2010, 13:12

wew,,
tambahin aj di bawahny

deb http://kambing.ui.edu/ubuntu/ lucid-backports main restricted universe multiverse
deb http://kambing.ui.edu/ubuntu/ lucid-proposed main restricted universe multiverse
deb http://kambing.ui.edu/ubuntu/ lucid-security main restricted universe multiverse
deb http://kambing.ui.edu/ubuntu/ lucid-updates main restricted universe multiverse
deb http://kambing.ui.edu/ubuntu/ lucid main restricted universe multiverse


(tu repo dari kambing)


User avatar
thrvers
Posts: 4458
Joined: 01 Jan 2010, 13:28
Location: Jombang, Indonesia
Contact:

Post by thrvers » 22 May 2010, 13:15

'
maap: yg bro rhecizen tulis diatas buat ubuntu 10.04 (Lucid Lynx) sedangkan ini pake jaunty :D

nda masalah ternyata sources.list (bener, jaunty repo)

coba lagi:
$ sudo aptitude update
$ sudo aptitude install libfarsight0.1-3


buat terusin instal pidgin/empathy tuh farsight, jd paket tsb ada yg kurang gt.


User avatar
angel
Posts: 15
Joined: 22 May 2010, 10:46
Contact:

Post by angel » 22 May 2010, 13:18

pake tanda pager ga di depannya? :-(


User avatar
thrvers
Posts: 4458
Joined: 01 Jan 2010, 13:28
Location: Jombang, Indonesia
Contact:

Post by thrvers » 22 May 2010, 13:19

'
nda masalah tuh sources.list walaupun pake pager2 depannya :D
lannjut dah yg q tulis diatas.


User avatar
angel
Posts: 15
Joined: 22 May 2010, 10:46
Contact:

Post by angel » 22 May 2010, 13:23

dan hasilnya seperti ini say : pusing negh

marketing20@marketing12:~$ sudo aptitude install libfarsight0.1-3
Reading package lists... Done
Building dependency tree
Reading state information... Done
Reading extended state information
Initializing package states... Done
The following NEW packages will be installed:
gstreamer0.10-plugins-farsight{a}
The following partially installed packages will be configured:
libfarsight0.1-3 telepathy-stream-engine
0 packages upgraded, 1 newly installed, 0 to remove and 0 not upgraded.
Need to get 131kB of archives. After unpacking 438kB will be used.
Do you want to continue? [Y/n/?] y
Writing extended state information... Done
Get:1 http://id.archive.ubuntu.com jaunty/universe gstreamer0.10-plugins-farsight 0.12.10-2 [131kB]
Fetched 131kB in 9s (14.1kB/s)
(Reading database ... 124645 files and directories currently installed.)
Unpacking gstreamer0.10-plugins-farsight (from .../gstreamer0.10-plugins-farsight_0.12.10-2_i386.deb) ...
dpkg: error processing /var/cache/apt/archives/gstreamer0.10-plugins-farsight_0.12.10-2_i386.deb (--unpack):
trying to overwrite `/usr/lib/gstreamer-0.10/libgstdtmf.so', which is also in package gstreamer0.10-plugins-good
Errors were encountered while processing:
/var/cache/apt/archives/gstreamer0.10-plugins-farsight_0.12.10-2_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
A package failed to install. Trying to recover:
dpkg: dependency problems prevent configuration of libfarsight0.1-3:
libfarsight0.1-3 depends on gstreamer0.10-plugins-farsight; however:
Package gstreamer0.10-plugins-farsight is not installed.
dpkg: error processing libfarsight0.1-3 (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of telepathy-stream-engine:
telepathy-stream-engine depends on libfarsight0.1-3 (>= 0.1.26); however:
Package libfarsight0.1-3 is not configured yet.
dpkg: error processing telepathy-stream-engine (--configure):
dependency problems - leaving unconfigured
Errors were encountered while processing:
libfarsight0.1-3
telepathy-stream-engine
Reading package lists... Done
Building dependency tree
Reading state information... Done
Reading extended state information
Initializing package states... Done
Writing extended state information... Done

marketing20@marketing12:~$


User avatar
rhecizen
Posts: 427
Joined: 09 Jan 2010, 20:41
Location: Indonesia
Contact:

Post by rhecizen » 22 May 2010, 13:35

thrvers wrote:'
maap: yg bro rhecizen tulis diatas buat ubuntu 10.04 (Lucid Lynx) sedangkan ini pake jaunty :D

nda masalah ternyata sources.list (bener, jaunty repo)

coba lagi:
$ sudo aptitude update
$ sudo aptitude install libfarsight0.1-3


buat terusin instal pidgin/empathy tuh farsight, jd paket tsb ada yg kurang gt.

waduh..waduhh,,,
mav2,,,,gagh liat bro

(jadi malu :p )


User avatar
thrvers
Posts: 4458
Joined: 01 Jan 2010, 13:28
Location: Jombang, Indonesia
Contact:

Post by thrvers » 22 May 2010, 15:13

'
wedew pa mungkin repo id.archive.ubuntu.com yg error yah??

coba ganti yah:
$ sudo cp /etc/apt/sources.list
$ sudo gedit /etc/apt/sources.list


hapus semua isinya ganti dengan:
[spoiler]

Code: Select all

deb http://dl2.foss-id.web.id/ubuntu jaunty main restricted universe multiverse
deb-src http://dl2.foss-id.web.id/ubuntu jaunty main restricted universe multiverse
deb http://dl2.foss-id.web.id/ubuntu jaunty-updates main restricted universe multiverse
deb-src http://dl2.foss-id.web.id/ubuntu jaunty-updates main restricted universe multiverse
deb http://dl2.foss-id.web.id/ubuntu jaunty-security main restricted universe multiverse
deb-src http://dl2.foss-id.web.id/ubuntu jaunty-security main restricted universe multiverse
deb http://dl2.foss-id.web.id/ubuntu jaunty-backports main restricted universe multiverse
deb-src http://dl2.foss-id.web.id/ubuntu jaunty-backports main restricted universe multiverse
deb http://dl2.foss-id.web.id/ubuntu jaunty-proposed main restricted universe multiverse
deb-src http://dl2.foss-id.web.id/ubuntu jaunty-proposed main restricted universe multiverse
[/spoiler]
save, kemudian:
$ sudo aptitude update
$ sudo aptitude install libfarsight0.1-3


cmiiw


User avatar
lisnux
Posts: 1763
Joined: 02 Jan 2010, 16:26
Location: Samarinda
Contact:

Post by lisnux » 23 May 2010, 00:48

Atau di remove purge dulu empathy nya baru diinstall lagi dari server yang disarankan bro thtvers diatas


User avatar
angel
Posts: 15
Joined: 22 May 2010, 10:46
Contact:

Post by angel » 24 May 2010, 08:40

trus gimana cara ngapusnya, gw dah coba sudo-apt clean dll ga ke apus, what shoul I delete? let me know :(


User avatar
angel
Posts: 15
Joined: 22 May 2010, 10:46
Contact:

Post by angel » 24 May 2010, 08:52

tapi gimana cara ngapusnya.., kemeren dah gw coba pake clean truss pake remove dll ga ke apus.., apanya c yang salah?


User avatar
sta
Posts: 2003
Joined: 27 Apr 2010, 09:49
Contact:

Post by sta » 24 May 2010, 09:40

mungkin bisa dicoba

# fix broken package
sudo aptitude install -f

kemudian
sudo aptitude update

apa masih ada masalah?


User avatar
angel
Posts: 15
Joined: 22 May 2010, 10:46
Contact:

Post by angel » 24 May 2010, 10:00

iya dah gw coba, pi yaitu balik lagi jatuhnya begitu lagi

marketing20@marketing12:~$ # fix broken package
marketing20@marketing12:~$ sudo aptitude install -f
[sudo] password for marketing20:
Reading package lists... Done
Building dependency tree
Reading state information... Done
Reading extended state information
Initializing package states... Done
Writing extended state information... Done
The following NEW packages will be installed:
gstreamer0.10-plugins-farsight{a}
The following partially installed packages will be configured:
libfarsight0.1-3 telepathy-stream-engine
0 packages upgraded, 1 newly installed, 0 to remove and 0 not upgraded.
Need to get 0B/131kB of archives. After unpacking 438kB will be used.
Do you want to continue? [Y/n/?] y
Writing extended state information... Done
(Reading database ... 124645 files and directories currently installed.)
Unpacking gstreamer0.10-plugins-farsight (from .../gstreamer0.10-plugins-farsight_0.12.10-2_i386.deb) ...
dpkg: error processing /var/cache/apt/archives/gstreamer0.10-plugins-farsight_0.12.10-2_i386.deb (--unpack):
trying to overwrite `/usr/lib/gstreamer-0.10/libgstdtmf.so', which is also in package gstreamer0.10-plugins-good
Errors were encountered while processing:
/var/cache/apt/archives/gstreamer0.10-plugins-farsight_0.12.10-2_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
A package failed to install. Trying to recover:
dpkg: dependency problems prevent configuration of libfarsight0.1-3:
libfarsight0.1-3 depends on gstreamer0.10-plugins-farsight; however:
Package gstreamer0.10-plugins-farsight is not installed.
dpkg: error processing libfarsight0.1-3 (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of telepathy-stream-engine:
telepathy-stream-engine depends on libfarsight0.1-3 (>= 0.1.26); however:
Package libfarsight0.1-3 is not configured yet.
dpkg: error processing telepathy-stream-engine (--configure):
dependency problems - leaving unconfigured
Errors were encountered while processing:
libfarsight0.1-3
telepathy-stream-engine
Reading package lists... Done
Building dependency tree
Reading state information... Done
Reading extended state information
Initializing package states... Done
Writing extended state information... Done


ini udah yang kesekian kalinya say.., bolak balik begini mulu.., ntar apdate lagi tus instal lagi apdate lagi.., pi tetep tuh "error instal" ngeteam di compi gw.., klo gw instal sofware dia bilang

this is the major failure of your sofware management system. Please check for broken packages with synaptic, check the file permissions, and correctness of the file "/etc/apt/source.list and reload the sofware information with 'sudo apt get update' and sudo apt get install -f

capeee dweeeeh


User avatar
angel
Posts: 15
Joined: 22 May 2010, 10:46
Contact:

Post by angel » 24 May 2010, 10:08

kayaknya memang tuh telephatynya musti di apus, pi gimana cara ngapusnya susah?? trus gw liat masalahnya da di gstreamer 10-plugin-farsight , ma dilibfarsight0.1.3 dan ini ada abis nginstal empahty.., :( :(


User avatar
sta
Posts: 2003
Joined: 27 Apr 2010, 09:49
Contact:

Post by sta » 24 May 2010, 10:11

asumsi, mungkin paket2 di indika yang kurang komplit nih

coba
# perintah di bawah ini di copy n paste aja di terminal
sudo mv /etc/apt/sources.list /etc/apt/sources.list_aseli
sudo gedit /etc/apt/sources.list

copy and paste

deb http://kambing.ui.ac.id/ubuntu/ jaunty-backports main restricted universe multiverse
deb http://kambing.ui.ac.id/ubuntu/ jaunty-proposed main restricted universe multiverse
deb http://kambing.ui.ac.id/ubuntu/ jaunty-security main restricted universe multiverse
deb http://kambing.ui.ac.id/ubuntu/ jaunty-updates main restricted universe multiverse
deb http://kambing.ui.ac.id/ubuntu/ jaunty main restricted universe multiverse

sudo aptitude update
sudo aptitude install -f

muup kalo salah


Post Reply

Who is online

Users browsing this forum: No registered users and 14 guests