LAN Card tdk Terdetek

Membahas Perangkat-perangkat keras yang belum dideteksi dengan baik oleh Ubuntu serta solusinya.
Post Reply
User avatar
aguswiadi

LAN Card tdk Terdetek

Post 25 Jan 2011, 16:46

dear all

Mohon bantuan para master linux..
ada yg tau cara install driver LAN card D-Link DFE-528TX??

karena saya baca helpnya tidak mengerti,,maav newbie


terima kasih


User avatar
thrvers
Contact:

Post 25 Jan 2011, 19:26

'
coba cek dulu, biasanya automatis detek
buka terminal, ketik:
$ sudo lshw

ini contoh output network punya q:
[spoiler]

Code: Select all

.....
           *-network
                description: Ethernet interface
                product: L1 Gigabit Ethernet
                vendor: Atheros Communications
                physical id: 0
                bus info: pci@0000:02:00.0
                logical name: eth0
                version: b0
                serial: 00:1d:60:6a:b3:bb
                width: 64 bits
                clock: 33MHz
                capabilities: bus_master cap_list rom ethernet physical
                configuration: broadcast=yes driver=atl1 driverversion=2.1.3 firmware=N/A latency=0 multicast=yes
                resources: irq:44 memory:febc0000-febfffff memory:feba0000-febbffff
.......
[/spoiler]
Coba main2: deteksi hardware komp/laptop di ubuntu

= :D =


User avatar
aguswiadi

Post 26 Jan 2011, 07:57

Makasi agan thrvers...
saya sudah lakukan saran agan tp output networknya hanya terdetect 1 lan card, seharusnya ada 2 lan card..

mohon bantuan agan
berikut saya lampirkan help dari CD instalernya..

nah yg saya bingung gan..itu untuk langkah run di /usr/src/linux setelah saya cek itu tdk ada!! bisa mohon bantuannya agan untuk memberi penjelasan dengan bahasa newbie gan,,,heheh
Attachments

[The extension txt has been deactivated and can no longer be displayed.]



User avatar
thrvers
Contact:

Post 26 Jan 2011, 08:04

'
mungkin yg dimaksud /usr/src/linux-headers-...

linux-headers-... = kernel yg sekarang dipakai [biasanya yg update terbaru]

cek saja kita pakai yg mana:
$ uname -r

= lanjutt.. =


User avatar
aguswiadi

Post 26 Jan 2011, 08:15

kang_oz wrote: kl dah jadi kan.. bisa dijadisiin banyak server tuh .. cuma masalah yang sekarang belum saya pecahkan ubuntu server 10.04 ga nge-detecet LAN CARD marvel yukon gigabit ethernet juga DLink, yang pasti support dari kluarga realtex dan 3com...jadi kepaksa deh nambah LAN CArd PCI slot ..


Para Master skalian ini permasalahan yg saya kutip dari forum..nah ternyata saya sekarang mengalaminya..ubuntu 10.10 dekstop saya tidak detect LAN Card Dlink DFE-528TX...

mohon bantuan para rekan sekalian apabila sudah ada yg mendapat pemecahannya...terima kasih


User avatar
blackshirt
Contact:

Post 26 Jan 2011, 08:38

coba baca ini http://hardware4linux.info/module/8139too/
Components supported by the 8139too module:
....
# D-Link System / DFE-528TX 10/100 Fast Ethernet PCI Adapter [Ethernet controller] (5.0 x 12)
# D-Link System / DFE-538TX 10/100 Ethernet Adapter [Ethernet controller] (5.0 x 5)
...
saya rasa lan card yang bro maksud di atas, sudah disupport di linux dengan modul 8139too :grin:


User avatar
aguswiadi

Post 26 Jan 2011, 08:45

Sebenarnya itu sudah support yah bro...

yang saya mau tanyakan "support" itu apabila kita pasang Hardwarenya maka ubuntu akan langsung mendetect yah??
ato kita harus install lg??

terima kasih bro blackshirt infonya


User avatar
blackshirt
Contact:

Post 26 Jan 2011, 09:06

Sebenarnya itu sudah support yah bro...
saya rasa begitu :grin:

coba modprobe modul 8139too di terminal

Code: Select all

$sudo modprobe 8139too
kalau gak ada warning error, lalu coba di network managernya diatur konfigurasinya, apakah sudah kedetek ..

report baliknya :grin:


User avatar
aguswiadi

Post 26 Jan 2011, 10:12

Woke gan thrvers...

Laporan :
saya sudah lakukan urutan
1. saya copy dfe528.c ke /usr/src/linux-headers-2.6.35-2-generic
2. saya compile dengan command
"gcc -DMODULE -Wall -Wstrict-prototypes -O6 -c dfe528.c" dan hasilnya error...

pesan error :
dfe528.c:91: fatal error : linux/config.h: No such file directory
compilation terminated.

mohon solusinya rekan2..terima kasih


User avatar
aguswiadi

Post 26 Jan 2011, 10:14

Report bro blackshirt

1.tidak ada warning error setelah dilakukan $sudo modprobe 8139too
2.Setelah diliat di Network Manager tidak terdetc LAN Cart D-Linknya..

Mohon solusi berikutnya bro :D


User avatar
blackshirt
Contact:

Post 26 Jan 2011, 10:22

coba kirimkan output
$dmesg
dan
$lspci | grep Network

:grin:


User avatar
thrvers
Contact:

Post 26 Jan 2011, 11:23

'
ow gt :D

$ sudo su
# cd /usr/src
# ln -s Linux-headers-2.6.35-2-generic Linux


kemudian ulangi langkah2 diatas.

Keterangan:
ln -s untuk membuat shortcut [softlink] folder Linux dari folder Linux-headers-2.6.35-2-generic

= :D =


User avatar
aguswiadi

Post 26 Jan 2011, 12:48

Laporan agan thrvers...
solusi diatas sudah saya coba dengan hasil sebagai berikut :
gcc: dfe528.c: No such file or directory
gcc: no input files

kira2 knp yah??


User avatar
aguswiadi

Post 26 Jan 2011, 12:51

Laporan bro blackshirt

ini hasil output yg bro minta..
tolong di bantu yakkk!!


User avatar
thrvers
Contact:

Post 26 Jan 2011, 13:06

'
wah kurang tau taknis gcc nya. mungkin instal saja paket2 dev
cari2 seperti ini: gcc***-dev [ada gcc + ada -dev] <== instal dah

= CMIIW =


User avatar
aguswiadi

Post 26 Jan 2011, 13:12

haha..terima kasih nei agan thrvers...
semoga ada yg berhasil pecahkan untuk pembelajaran kita

ayo master ubuntu yg lain mohon bantuannya!!


User avatar
MasDjo
Contact:

Post 26 Jan 2011, 13:15

Saya juga pake Lancard yg sama (DLink DFE-528TX) disalah satu komputer dan bisa kedetek normal, jadi mungkin ini bukan masalah pd Ubuntu tetapi pd hardware anda.
Jika ada slot PCI lainnya coba lancardnya dipindah dan jika perlu lakukan reset BIOS lewat jumper reset siapa tahu sistem di mainboard rada ngaco :grin:


User avatar
thrvers
Contact:

Post 26 Jan 2011, 13:15

'
bro agus q nemu cuman satu :D coba saja instal :grin:
gcc-4.5-plugin-dev punya maverick [ubuntu 10.10] <== hati2 dependencies juga ada loh :D

= sukses =


User avatar
blackshirt
Contact:

Post 26 Jan 2011, 13:24

$lspci | grep Network

perhatikan penulisan hurufnya.. :grin:


User avatar
MasDjo
Contact:

Post 26 Jan 2011, 13:28

@bro Agus : jangan dobel2 dong kalo bikin postingan, ok
Dan saya rasa topik ini lebih cocok pd forum solusi hardware
Jadi topik gabungan ini saya pindah ke Solusi Hardware .


User avatar
aguswiadi

Post 26 Jan 2011, 14:01

oh maav agan MasDjo..
woke sip..mungkin dipindahkan saja masuk ke Solusi Hardware
akan saya coba reset BIOS

@bro blackshirt
saya sudah tulis $lspci | grep Network dan $lspci | grep network
hasilnya sama gan...tidak terjadi apa2

@thrvers
akan saya coba..

terima kasih rekan2 sekalian atas bantuannya


User avatar
aguswiadi

Post 26 Jan 2011, 14:13

oh maav agan MasDjo..
woke sip..mungkin dipindahkan saja masuk ke Solusi Hardware
akan saya coba reset BIOS

@bro blackshirt
saya sudah tulis $lspci | grep Network dan $lspci | grep network
hasilnya sama gan...tidak terjadi apa2

@thrvers
akan saya coba..

terima kasih rekan2 sekalian atas bantuannya


User avatar
aguswiadi

Post 26 Jan 2011, 14:20

@MasDjo
maav mas..
woke sip dipindahkan saja mas..
saya akan coba solusinya mas

@bro blackshirt
saya sdh tulis $lspci | grep Network maupun $lspci | grep network
tetapi hasilnya sama saja : tidak terjadi apa2

@thrvers
woke,saya akan coba dulu solusinya..

terima kasih rekan2 yg sudah membantu


User avatar
blackshirt
Contact:

Post 26 Jan 2011, 14:21

[ 1.501576] tg3.c:v3.110 (April 9, 2010)
[ 1.501593] tg3 0000:1e:00.0: PCI INT A -> GSI 19 (level, low) -> IRQ 19
[ 1.501601] tg3 0000:1e:00.0: setting latency timer to 64
[ 1.521209] tg3 0000:1e:00.0: eth0: Tigon3 [partno(BCM95723) rev 5784100] (PCI Express) MAC address 68:b5:99:4f:88:11
[ 1.521212] tg3 0000:1e:00.0: eth0: attached PHY is 5784 (10/100/1000Base-T Ethernet) (WireSpeed[1])
[ 1.521215] tg3 0000:1e:00.0: eth0: RXcsums[1] LinkChgREG[0] MIirq[0] ASF[1] TSOcap[1]
[ 1.521217] tg3 0000:1e:00.0: eth0: dma_rwctrl[76180000] dma_mask[64-bit]
tg3 ini adalah driver Broadcomm Tigon3 chipset yang digunakan di beberapa ethernet card


User avatar
aguswiadi

Post 26 Jan 2011, 14:25

itu driver bawaan Desktopnya..
disini menggunakan merk Broadcom NetXtream


User avatar
aguswiadi

Post 08 Feb 2011, 15:26

terima kasih teman2 problem solve...
solusi:
1. membersihkan LAN card dari stiker yg menempel di body lancard
2. reset bios

terima kasih
maju terus ubuntu-indonesia


User avatar
alim

Post 16 Nov 2011, 12:02

kakak...kakak smua..
sya mau tnya nie
saya kan dpat tgas dari guru produktif sya, disuruh bwt gateway internet dan proxy server,pkek ubuntu 11.10 tpi LAN cardnya gag detec...
gmna solusinya? mohon bantuan kakak semua..


Post Reply

Who is online

Users browsing this forum: No registered users and 62 guests