Install modem Smartfren Connex AC682 UI

Membahas Perangkat-perangkat keras yang belum dideteksi dengan baik oleh Ubuntu serta solusinya.
Post Reply
User avatar
Fian_arifin

Install modem Smartfren Connex AC682 UI

Post 13 Jun 2011, 16:36

gan.. ada yang tau install modem Smartfren Connex AC682 UI di ubuntu 11.04 ga?


User avatar
hanz_edo

Post 13 Jun 2011, 18:56

ketik di teminal
eko-eka@K40IJ:~$ lsusb
Bus 008 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 007 Device 002: ID 0a12:0001 Cambridge Silicon Radio, Ltd Bluetooth Dongle (HCI mode)
Bus 007 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 006 Device 004: ID 05c6:9004 Qualcomm, Inc.
Bus 006 Device 002: ID 046d:c058 Logitech, Inc.
Bus 006 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 002: ID 04f2:b071 Chicony Electronics Co., Ltd 2.0M UVC Webcam / CNF7129
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
eko-eka@K40IJ:~$

Dari langkah tersebut kita dapatkan dua informasi penting,
Bus 006 Device 004: ID 05c6:9004 Qualcomm, Inc.

dari informasi yang kita peroleh diatas tinggal kita ketik lagi
eko-eka@K40IJ:~$ sudo modprobe usbserial -v vendor=0x05c6 product=0�9004
masukkan password km
udh gtu selesai deh.....

Oia....
Jngan lupa atur juga network connectionya ya.....!
()


User avatar
thrvers
Contact:

Post 15 Jun 2011, 18:03

'
kak fian sudah dicoba tips dari kak hanz?? [jangan buat trit yg sama berulang kali :( ]

dicoba juga: [Bbagi] Koneksi Internet dg USB-modem + driver + storage

= :( =


User avatar
renon
Contact:

Post 18 Jun 2011, 20:01

mas hanz,kalo lsusb saya keluarnya seperti ini mas, gmn dong?

Bus 007 Device 002: ID 03f0:171d Hewlett-Packard Wireless (Bluetooth + WLAN) Interface [Integrated Module]
Bus 007 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 006 Device 002: ID 15d9:0a4c Dexon
Bus 006 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 005 Device 002: ID 19d2:ffde ONDA Communication S.p.A.
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub


yang mana yang harus saya modprobe


User avatar
saa7_go
Contact:

Post 18 Jun 2011, 21:41

coba aja ikutin panduan yang ada di blog ini.


User avatar
hanz_edo

Post 20 Jun 2011, 18:40

renon wrote:mas hanz,kalo lsusb saya keluarnya seperti ini mas, gmn dong?

Bus 007 Device 002: ID 03f0:171d Hewlett-Packard Wireless (Bluetooth + WLAN) Interface [Integrated Module]
Bus 007 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 006 Device 002: ID 15d9:0a4c Dexon
Bus 006 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 005 Device 002: ID 19d2:ffde ONDA Communication S.p.A.
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub


yang mana yang harus saya modprobe
Ni Punya renoon udah tampil Bus 005 Device 002: ID 19d2:ffde ONDA Communication S.p.A. Setting berikutnya bisa ngikuti dari blog yang di kasih Ohm aaa7_go


User avatar
aptfast
Contact:

Post 21 Jun 2011, 14:11

modemnya aneh neh
sudah di modprobe masih ga kedetek modem nya
padahal dah ngikutin saran bro saa7_go


User avatar
ArzonLinus
Contact:

Post 21 Jun 2011, 14:17

setelah di modprobe di install juga usb-modeswitch terbaru versi 1.1.7


User avatar
aptfast
Contact:

Post 21 Jun 2011, 14:47

ArzonLinus wrote:setelah di modprobe di install juga usb-modeswitch terbaru versi 1.1.7
saya punya dah versi 1.1.7-1
tetep ga bisa


User avatar
renon
Contact:

Post 22 Jun 2011, 10:58

saa7_go wrote:coba aja ikutin panduan yang ada di blog ini.
sudah ikutin, tapi sekarang gak bisa dial.
ini isi wvdial.conf nya :
[Dialer Defaults]
Init1 = ATZ
Init2 = ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
Modem Type = Analog Modem
ISDN = 0
Phone = #777
Modem = /dev/ttyUSB2
Username = smart
Password = smart
Baud = 460800
Command Line = ATDT
Stupid Mode = 1
pas di jalanin :
--> WvDial: Internet dialer version 1.60
--> Cannot get information for serial port.
--> Initializing modem.
--> Sending: ATZ
ATZ
OK
--> Sending: ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
OK
--> Modem initialized.
--> Sending: ATDT#777
--> Waiting for carrier.
ATDT#777
OK
--> Timed out while dialing. Trying again.
--> Sending: ATDT#777
--> Waiting for carrier.
ATDT#777
OK
--> Timed out while dialing. Trying again.
--> Sending: ATDT#777
--> Waiting for carrier.
ATDT#777
OK
^CCaught signal 2: Attempting to exit gracefully...
help mas, btw knp baud nya = 460800 ya? pas wvdialconf kedetectnya 9600


User avatar
aptfast
Contact:

Post 22 Jun 2011, 11:24

renon, modem type nya coba ganti USB Modem
mungkin bisa


User avatar
kuro_kid
Contact:

Post 25 Jun 2011, 12:22

numpang mantau yah kk smua...
msalah sya sma ky kk renon :(
modem kedetek tp dialing trus kga sukses2


User avatar
aptfast
Contact:

Post 25 Jun 2011, 13:54

kuro_kid wrote:numpang mantau yah kk smua...
msalah sya sma ky kk renon :(
modem kedetek tp dialing trus kga sukses2
mending tuh bro
saya punya malah ga mau dial sama sekali :D


User avatar
saa7_go
Contact:

Post 26 Jun 2011, 08:26

renon wrote:
saa7_go wrote:coba aja ikutin panduan yang ada di blog ini.
sudah ikutin, tapi sekarang gak bisa dial.
ini isi wvdial.conf nya :
[Dialer Defaults]
Init1 = ATZ
Init2 = ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
Modem Type = Analog Modem
ISDN = 0
Phone = #777
Modem = /dev/ttyUSB2
Username = smart
Password = smart
Baud = 460800
Command Line = ATDT
Stupid Mode = 1
pas di jalanin :
--> WvDial: Internet dialer version 1.60
--> Cannot get information for serial port.
--> Initializing modem.
--> Sending: ATZ
ATZ
OK
--> Sending: ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
OK
--> Modem initialized.
--> Sending: ATDT#777
--> Waiting for carrier.
ATDT#777
OK
--> Timed out while dialing. Trying again.
--> Sending: ATDT#777
--> Waiting for carrier.
ATDT#777
OK
--> Timed out while dialing. Trying again.
--> Sending: ATDT#777
--> Waiting for carrier.
ATDT#777
OK
^CCaught signal 2: Attempting to exit gracefully...
help mas, btw knp baud nya = 460800 ya? pas wvdialconf kedetectnya 9600
device modem yang ada di blog ini kan pake /dev/ttyUSB0 kenapa kamu set ke /dev/ttyUSB2 ?


User avatar
Fian_arifin

Post 01 Jul 2011, 00:48

gan klo ke detctnya gini:

ttyUSB0: Modem Identifier: ATI � Manufacturer: +GMI: China TeleCom ya, bukan
ttyUSB0: Modem Identifier: ATI � Manufacturer: QUALCOMM INCORPORATED


User avatar
rizaaal
Contact:

Post 01 Jul 2011, 01:13

gan itu udah kedetek sebagai modem apa masih usb storage ya? coba

lsusb

Bus 002 Device 003: ID 064e:f203 Suyin Corp.
Bus 002 Device 002: ID 8087:0020 Intel Corp. Integrated Rate Matching Hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 004: ID 0bda:0158 Realtek Semiconductor Corp. USB 2.0 multicard reader
Bus 001 Device 003: ID f000:3502 Qualcomm Storage
Bus 001 Device 002: ID 8087:0020 Intel Corp. Integrated Rate Matching Hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

yang ane tebelin itu modem ane yang masih kebaca sebagain usbstorage bukan sebagai modem. yang harus dilakuin yaitu ane harus mengeject modem tersebut.

ls /dev/sr*

rizal@empol:~$ ls /dev/sr*
/dev/sr0 /dev/sr1

nah yang sr0 itu biasanya CD ROM, dan yang sr1 itu modem kita.

selanjutnya modem kita itu harus di eject agar kebacanya menjadi modem, bukan usbstorage lagi.

rizal@empol:~$ sudo eject /dev/sr1
[sudo] password for rizal:
rizal@empol:~$

coba lsusb lagi

rizal@empol:~$ lsusb
Bus 002 Device 003: ID 064e:f203 Suyin Corp.
Bus 002 Device 002: ID 8087:0020 Intel Corp. Integrated Rate Matching Hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 004: ID 0bda:0158 Realtek Semiconductor Corp. USB 2.0 multicard reader
Bus 001 Device 003: ID 19f5:9909
Bus 001 Device 002: ID 8087:0020 Intel Corp. Integrated Rate Matching Hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

berubah kan angkanya?
nah yang ane tebelin itu yang harus di modprobe supaya bisa didaftarin ke kernel

rizal@empol:~$ sudo modprobe usbserial vendor=0x19f5 product=0x9909

tunggu beberapa saat, nanti enggak lama harusnya di applet network manager udah kebaca mobile broadbandnya.

koneknya lewat network manager aja kalo susah.

semoga membantu. :)


User avatar
bapak

Post 01 Jul 2011, 12:11

mau nya nih,, !! gimn sih car aktifin wireless yang di disable trus di wirelessnya ko muncul tanda seru,, !!


User avatar
conza

Post 03 Jul 2011, 03:54

ane udah berhasil konekin tu modem gan..caranya dapet di BLOG ini


User avatar
jogorogo

Post 04 Jul 2011, 20:24

wah ketika saya ketik perintah

sudo wvdialconf

kok muncul tulisan "command not found" ya?
tolong dong gan!


User avatar
sake

Post 04 Jul 2011, 22:04

blm di install kali wvdial-nya....


User avatar
gen781
Contact:

Post 05 Jul 2011, 08:01

jogorogo wrote:wah ketika saya ketik perintah

sudo wvdialconf

kok muncul tulisan "command not found" ya?
tolong dong gan!
Ya mungkin blm diinstall wvdialnya.
Atau kalo mau gampang pake network manager aja.
Saya pake network manager gampang2 aja kok settingnya.
Yang penting modemnya dah kedetect sebagai modem bukan CD-ROM atau USB storage.


User avatar
jogorogo

Post 05 Jul 2011, 17:46

iya gan blm. tapi ketika mau saya instal dari software center pakai internet kok muncul tulisan
"failed to download package files"
"check your internet connection"
padahal kalo dipakai buat browser dg mozila lancar gan. solusinya gimana ya gan? makasih buat gan sake dan gen781 atas bantuannya


User avatar
dhiemaz_mitnick
Contact:

Post 05 Jul 2011, 17:53

Coba expand tanda panahnya ketika error tersebut muncul. soalnya disana ada keterangan errornya kenapa..


User avatar
jogorogo

Post 05 Jul 2011, 19:40

tapi tidak ada ni gan, munculnya kayak gini
Attachments
Screenshot.png
Screenshot.png (101.97 KiB) Viewed 2818 times


User avatar
aptfast
Contact:

Post 05 Jul 2011, 21:02

jogorogo wrote:wah ketika saya ketik perintah

sudo wvdialconf

kok muncul tulisan "command not found" ya?
tolong dong gan!
coba install
sudo apt-get install wvdial


User avatar
conza

Post 06 Jul 2011, 01:50

jogorogo wrote:wah ketika saya ketik perintah

sudo wvdialconf

kok muncul tulisan "command not found" ya?
tolong dong gan!
udah install wvdial belum gan???
klo gak bisa mungkin belum di install


User avatar
jogorogo

Post 06 Jul 2011, 13:00

aptfast wrote:
jogorogo wrote:wah ketika saya ketik perintah

sudo wvdialconf

kok muncul tulisan "command not found" ya?
tolong dong gan!
coba install
sudo apt-get install wvdial
ketika saya mau instal wvdial muncul kayak gini gan. padahlal kalau buat internet pakai mozila bisa jew. ploblem apa lagi ya gan? kalo pakai terminal juga gagal trus pakai ubuntu software center.
Attachments
Screenshot.png
Screenshot.png (101.97 KiB) Viewed 2806 times


User avatar
aptfast
Contact:

Post 06 Jul 2011, 13:09

coba install nya pake terminal


User avatar
jogorogo

Post 07 Jul 2011, 15:00

terimakasih atas bantuan agan2 di forum ini, sekarang saya danh bisa conect internet dengan ac682 di ubuntu..

netbook 1015b


User avatar
conza

Post 08 Jul 2011, 21:39

jogorogo wrote:terimakasih atas bantuan agan2 di forum ini, sekarang saya danh bisa conect internet dengan ac682 di ubuntu..

netbook 1015b
samasama


User avatar
jogorogo

Post 09 Jul 2011, 16:25

gan setelah saya terkoneksi dengan internet pakai ac682 kok sering hang sebentar ya, sekitar 1 menit, walau setelah itu biasanya lancar, tapi itu cuman terjadi di awal koneksi, terimakasih


User avatar
myitanium

Post 14 Jul 2011, 15:18

Kalau wvdial tidak ada, anda gak harus pakai gan. ubuntu bawaannya ada pppd. Pakai itu aja juga dah bisa.
untuk pppd bisa lihat di blog ubuntu:
http://www.ubuntugeek.com/setting-up-di ... buntu.html

Untuk referensi lain, bisa cek di blog saya:
http://betweenmeandlinux.wordpress.com/ ... ntu-10-04/
http://betweenmeandlinux.wordpress.com/ ... -di-linux/
http://betweenmeandlinux.wordpress.com/ ... -dan-pppd/


User avatar
annadir

Post 20 Jul 2011, 12:33

kalu untuk modem mobi da yang tau ga ya???


User avatar
aptfast
Contact:

Post 21 Jul 2011, 13:15

saya blm berhasil
setiap kali sehabis eksekusi command sudo wvdialconf hasilnya tdk ditemukan modem... :D


User avatar
aptfast
Contact:

Post 23 Jul 2011, 11:08

akhir nya bisa di detek fungsi modem nya dg wvdial
spt nya gara2 kabel data zteac2726 yg saya pake :D


btw, sedikit OOT neh
saya coba pindahin simcard yg di zteac2726 ke ac682, kok spt ga dpt sinyal ya?
tapi simcard yg ac682 punya dipindahin ke zteac2726 ok2 saja....
ada ide?apa yg harus saya cek lagi?


User avatar
linuxio

Post 25 Jul 2011, 10:06

misi gan, mau tanya nih..
kok saya kalo mau install wvdial, ga bisa ya? Nanti ada tulisan kira'' kaya gini 'unable to find locate package' itu kenapa ya gan?


User avatar
aptfast
Contact:

Post 25 Jul 2011, 11:16

linuxio wrote:misi gan, mau tanya nih..
kok saya kalo mau install wvdial, ga bisa ya? Nanti ada tulisan kira'' kaya gini 'unable to find locate package' itu kenapa ya gan?
waktu install konek ke internet ga?


User avatar
linuxio

Post 25 Jul 2011, 17:47

konek gan, tapi tetep aja ga bisa..


User avatar
linuxio

Post 27 Jul 2011, 18:45

agan-agan yang master, tolong bantu saya..
gini gan, kan pas saya ketik perintah wvdil smart abis kedetect gan, tapi setelahnya langsung disconnect gan, kaya langsung ke eject, kenapa ya gan ?
tolong di bantu ya..


User avatar
aptfast
Contact:

Post 27 Jul 2011, 22:55

linuxio wrote:agan-agan yang master, tolong bantu saya..
gini gan, kan pas saya ketik perintah wvdil smart abis kedetect gan, tapi setelahnya langsung disconnect gan, kaya langsung ke eject, kenapa ya gan ?
tolong di bantu ya..
bisa copas hasil yg muncul di terminal disini?
semakin lengkap informasi nya, semakin mudah bagi yg lain utk membantu :)


User avatar
jeki

Post 01 Aug 2011, 13:21

gan gimn cara disconnectnya nih??


User avatar
ilham2930
Contact:

Post 01 Aug 2011, 15:32

cabut aja modemnya bro....
wkwkwkw...


User avatar
sta

Post 01 Aug 2011, 16:10

jeki wrote:gan gimn cara disconnectnya nih??
coba pada proses wvdial ketik ctrl+c


User avatar
Nexus

Post 02 Aug 2011, 07:00

:grin: cara alternative untuk modem..

1. buka synaptic package manager, lalu pastikan "mobile-broadband-provider-info" udah terinstall. (ketik mobile-broadband-provider- pada kolom pencarian, kalo udah terinstall, box-nya berwarna hijau).

2. tetap di-synaptic, ketik kata "Modem" pada kolom pencarian, lalu pastikan file2 dibawah ini juga udah terinstall, kalo ada yg blum terinstall, install aja.

pada synaptic ketik "Modem" dlm kolom pencarian, lalu install:

- sl-modem-daemon
- sl-modem-source
- modemmanager
- gnome-applets
- ppp
- pppconfig
- isc-dhcp-client
- usb-modeswitch-data
- usb-modeswitch
- pcmciautils

:laugh:


User avatar
aptfast
Contact:

Post 02 Aug 2011, 12:58

Honeycomb wrote::grin: cara alternative untuk modem..

1. buka synaptic package manager, lalu pastikan "mobile-broadband-provider-info" udah terinstall. (ketik mobile-broadband-provider- pada kolom pencarian, kalo udah terinstall, box-nya berwarna hijau).

2. tetap di-synaptic, ketik kata "Modem" pada kolom pencarian, lalu pastikan file2 dibawah ini juga udah terinstall, kalo ada yg blum terinstall, install aja.

pada synaptic ketik "Modem" dlm kolom pencarian, lalu install:

- sl-modem-daemon
- sl-modem-source
- modemmanager
- gnome-applets
- ppp
- pppconfig
- isc-dhcp-client
- usb-modeswitch-data
- usb-modeswitch
- pcmciautils

:laugh:
dah coba dg modem Smartfren Connex AC682 UI?


User avatar
susefreaks
Contact:

Post 03 Aug 2011, 23:01

kalau gini gmana gan? ane udah frustasi nih..
selinux@android:~$ lsusb
Bus 007 Device 003: ID 19d2:ffde ONDA Communication S.p.A.
Bus 007 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 006 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 005 Device 006: ID 1c4f:0003 SiGma Micro HID controller
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 002 Device 002: ID 064e:a103 Suyin Corp.
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
selinux@android:~$ eject /dev/sr1
selinux@android:~$ lsusb
Bus 007 Device 004: ID 19d2:ffdd ONDA Communication S.p.A.
Bus 007 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 006 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 005 Device 006: ID 1c4f:0003 SiGma Micro HID controller
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 002 Device 002: ID 064e:a103 Suyin Corp.
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
selinux@android:~$ sudo modprobe usbserial vendor=0x19d2 product=0xffdd
selinux@android:~$ sudo wvdialconf
Editing `/etc/wvdial.conf'.

Scanning your serial ports for a modem.

Modem Port Scan: S0 S1 S2 S3


Sorry, no modem was detected! Is it in use by another program?
Did you configure it properly with setserial?

Please read the FAQ at http://open.nit.ca/wiki/?WvDial

If you still have problems, send mail to .
selinux@android:~$


User avatar
abbi
Contact:

Post 04 Aug 2011, 05:05

1. Colokan Modem Smart.
2. ketikan perintah

binta@binta:~$ lsusb

Bus 008 Device 002: ID 0a5c:217f Broadcom Corp.
Bus 008 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 007 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 006 Device 016: ID 1c4f:0003 SiGma Micro
Bus 006 Device 004: ID 19d2:ffde ONDA Communication S.p.A.
Bus 006 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 002: ID 04b8:0005 Seiko Epson Corp. Stylus D88+
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 002 Device 005: ID 17ef:4815 Lenovo
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

3. ffde menandakan bahwa modem terdeteksi sebagai cdroom, eject modem agar menjadi ffdd dengan perintah berikut :

binta@binta:~$eject /dev/sr1

4. Ketik perintah lsub lagi


binta@binta:~$ lsusb

Bus 008 Device 002: ID 0a5c:217f Broadcom Corp.
Bus 008 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 007 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 006 Device 016: ID 1c4f:0003 SiGma Micro
Bus 006 Device 004: ID 19d2:ffdd ONDA Communication S.p.A.
Bus 006 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 002: ID 04b8:0005 Seiko Epson Corp. Stylus D88+
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 002 Device 005: ID 17ef:4815 Lenovo
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

5. Setelah menjadi ffdd lakukan modprobe dengan perintah berikut:

binta@binta:~$ sudo modprobe usbserial vendor=0x19d2 product=0xffdd



6. Edit wvdial.conf di text editor gedit atau yang lainnya dengan mengetikan perintah berikut:

binta@binta:~$sudo gedit /etc/wvdial.conf

jika hak akses pada file wvdial.conf belum dirubah (tidak bisa di save) exit gedit (ctrl+Q) kemudian ketikan perintah berikut :

binta@binta:~$sudo chmod 777 /etc/wvdial.conf

ketik perintah ini lagi

binta@binta:~$sudo gedit /etc/wvdial.conf

7. Isikan text dibawah ini kedalam file wvdial.conf

[Dialer abi]
Init = ATZ
Init = ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
Modem Type = USB Modem
Baud = 921600
Modem = /dev/ttyUSB0
Phone = #777
Username =smart
Password =smart
New PPPD = yes
Stupid Mode =1

8. Klik save (ctrl+s) dan keluar (ctrl+Q)

9. Jalankan perintah berikut :

binta@binta:~$ sudo wvdial abi



--> WvDial: Internet dialer version 1.60
--> Cannot get information for serial port.
--> Initializing modem.
--> Sending: ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
ATI
Manufacturer: +GMI: China TeleCom
Model: CBP7.0
Revision: 03.04.25P02
ESN: +GSN: 0x804eda2c
+GCAP: +CEVDO, +CIS707P-A, +CIS-856-A, +CGSM, +MS, +ES, +DS, +FCLASS
OK
--> Modem initialized.
--> Sending: ATDT#777
--> Waiting for carrier.
CONNECT 3100000
--> Carrier detected. Starting PPP immediately.
--> Starting pppd at Sun Jul 10 10:19:06 2011
--> Pid of pppd: 1683
--> Using interface ppp0
--> local IP address 10.255.191.207
--> remote IP address 10.20.31.25
--> primary DNS address 10.17.3.252
--> secondary DNS address 10.17.3.244

10. Jika muncul seperti diatas artinya sudah terkoneksi. Untuk disconnect . Tekan ctrl+ c.

Selesai... Good Luck

kunjungi http://abipramusinta.blogspot.com/2011/ ... buntu.html gan


User avatar
InfoWorld
Contact:

Post 07 Aug 2011, 21:57

OS q ubuntu 10.10...cara yang diomongin kk diatas berhasil pada blankon, tetapi pada ubuntu q emang bisa dikenali hanya saja sebagai GSM, bukan CDMA sehingga tidak dapat dikoneksikan... (kata pengembang blankon sih harus ngutak-atik file xml apalah gitu) ada yang tau g?


User avatar
pingsut
Contact:

Post 21 Sep 2011, 12:38

sekedar menambahkan saja...

1. install wvdial dulu (kalo offline, ambil dari CD Ubuntu-nya)
sudo apt-get install wvdial

2. cek dengan lsusb
lsusb
Bus 003 Device 003: ID 19d2:ffde ONDA Communication S.p.A.
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 002 Device 002: ID 0461:4d3d Primax Electronics, Ltd
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

3. keluarin drive "ZeroCD"
sudo eject /dev/sr1

4. cek dengan lsusb lagi (harusnya sudah beda!)
lsusb
Bus 003 Device 003: ID 19d2:ffdd ONDA Communication S.p.A.
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 002 Device 002: ID 0461:4d3d Primax Electronics, Ltd
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

5. daftarin ke modul modprobe
sudo modprobe usbserial vendor=0x19d2 product=0xffdd

6. mengkonfigurasi wvdial
sudo wvdialconf
Editing `/etc/wvdial.conf'.

Scanning your serial ports for a modem.

Modem Port Scan: S0 S1 S2 S3
WvModem: Cannot get information for serial port.
ttyUSB0: ATQ0 V1 E1 -- OK
ttyUSB0: ATQ0 V1 E1 Z -- OK
ttyUSB0: ATQ0 V1 E1 S0=0 -- OK
ttyUSB0: ATQ0 V1 E1 S0=0 &C1 -- OK
ttyUSB0: ATQ0 V1 E1 S0=0 &C1 &D2 -- OK
ttyUSB0: ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0 -- OK
ttyUSB0: Modem Identifier: ATI -- Manufacturer: +GMI: China TeleCom
ttyUSB0: Speed 9600: AT -- OK
ttyUSB0: Max speed is 9600; that should be safe.
ttyUSB0: ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0 -- OK
WvModem: Cannot get information for serial port.
ttyUSB1: ATQ0 V1 E1 -- failed with 2400 baud, next try: 9600 baud
ttyUSB1: ATQ0 V1 E1 -- failed with 9600 baud, next try: 9600 baud
ttyUSB1: ATQ0 V1 E1 -- and failed too at 115200, giving up.
WvModem: Cannot get information for serial port.
ttyUSB2: ATQ0 V1 E1 -- OK
ttyUSB2: ATQ0 V1 E1 Z -- OK
ttyUSB2: ATQ0 V1 E1 S0=0 -- OK
ttyUSB2: ATQ0 V1 E1 S0=0 &C1 -- OK
ttyUSB2: ATQ0 V1 E1 S0=0 &C1 &D2 -- OK
ttyUSB2: ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0 -- OK
ttyUSB2: Modem Identifier: ATI -- Manufacturer: +GMI: China TeleCom
ttyUSB2: Speed 9600: AT -- OK
ttyUSB2: Max speed is 9600; that should be safe.
ttyUSB2: ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0 -- OK

Found a modem on /dev/ttyUSB0.
Modem configuration written to /etc/wvdial.conf.
ttyUSB0: Speed 9600; init "ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0"
ttyUSB2: Speed 9600; init "ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0"

7. edit konfigurasi yang didapat tadi...
sudo gedit /etc/wvdial.conf

punya saya begini isinya;

[Dialer Defaults]
Init1 = ATZ
Init2 = ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
Stupid Mode = 1
Modem Type = Analog Modem
Command Line = ATDT
ISDN = 0
New PPPD = yes
Phone = #777
Modem = /dev/ttyUSB0
Username = smart
Password = smart
Baud = 9600


8. langsung koneksikan dengan perintah...
sudo wvdial

9. jika sudah konek install usb-modeswitch
sudo apt-get install usb-modeswitch

10. jika sudah selesai install, langsung edit file /lib/udev/rules.d/40-usb_modeswitch.rules
gksu gedit /lib/udev/rules.d/40-usb_modeswitch.rules

tambahkan diatas baris terakhir :
# ZTE AC682
ATTRS{idVendor}=="19d2", ATTRS{idProduct}=="ffde", RUN+="usb_modeswitch '%b/%k'"


11. buat sebuah berkas/ file di /etc/usb_modeswitch.d/ dengan nama "19d2:ffde" (tanpa tanda kutip)
gksu gedit /etc/usb_modeswitch.d/19d2:ffde

copas & masukkan baris ini, lalu simpan:

#Salin dari di sini ##################################################
# ZTE AC682

#ID device Sebelum menjadi modem
DefaultVendor=0x19d2
DefaultProduct=0xffde

#Baris Berikut entah berguna atau tidak
#anda bisa menghapus atau membiarkannya
TargetClass=0xff

#ID device setelah menjadi modem
TargetVendor=0x19d2
TargetProduct=0xffdd

MessageContent="555342431028e585c000000080000671010000000000000000000000000000"

#Salin sampai di sini


12. restart kompie
13. nah, sekarang anda dapat mengecek di >Places >Computer. disitu ada drive "EVDO Rev A"
14. buka terminal

sudo wvdial

NB: saya hanya mencoba ini di Lucid Lynx :D
saya juga mencoba menukar kartu sim-nya, dan gak bisa buat konek internet...ternyata karna;
"ZTE AC2726" 1900 Mhz --->kartu sim teman saya yg 64K
"ZTE AC682" 800/1900 Mhz --->kartu sim saya yg 32K


User avatar
WegigEinherjars

Post 26 Sep 2011, 20:18

Ini cara yang biasa saya pakai, bisa melengkapi yang udah diterangkan bro pingsuit.
Install Modem Smartfren AC682 di Ubuntu 11.04
1. sudo su
2. dmesg
3. eject /dev/sr1 (karena di komputer ku terdeteksi sebagai sr1)
4. dmesg
5. lsusb
6. gedit /etc/usb_modeswitch.conf
7. Isikan ini pada text editor yang baru terbuka
# /etc/usb_modeswitch.conf
#
# Smart ZTE AC682 (EVDO)
#
DefaultVendor = 0x19d2
DefaultProduct = 0xffdd
TargetVendor = 0x19d2
TargetProduct = 0xffdd
MessageContent=
5553424312345678c00000008000069f030000000000000000000000000000
8. gedit /etc/udev/rules.d/99-zte-ac682.rules
9. Isikan ini pada text editor yang baru terbuka
# /etc/udev/rules.d/99-zte-ac682.rules
#
# Smart ZTE AC682 (EVDO)
#
SUBSYSTEM=="usb", SYSFS{idVendor}=="19d2",
SYSFS{idProduct}=="ffdd", RUN+="/usr/sbin/usb_modeswitch �
10. modprobe usbserial vendor=0x19d2 product=0xffdd
11. wvdialconf
12. gedit /etc/wvdial.conf
13. Isikan ini pada text editor yang baru terbuka
[Dialer smart]
Init1 = ATZ
Init2 = ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
Stupid Mode = 1
Modem Type = Analog Modem
Command Line = ATDT
ISDN = 0
New PPPD = yes
Phone = #777
Modem = /dev/ttyUSB0
Username = smart
Password = smart
Baud = 460800
14. wvdial smart
15. Biar ga ribet tiap kali colok modem harus eject cd rom (karena kedetect sebagai cd rom) nya agar dikenali sebagai usb Buka Text Editor, save file dengan akhiran .sh
#!/bin/bash
sudo eject /dev/sr1
sleep 6
sudo modprobe usbserial vendor=0x19d2 product=0xffdd
sleep 6
sudo wvdial smart
16. Tulis di Terminal
sudo chmod +x smart.sh
biar bisa di eksekusi.

nah untuk selanjutnya tinggal tulis diterminal
./smart.sh


User avatar
WegigEinherjars

Post 26 Sep 2011, 20:22

pake ubuntu ato apa?


User avatar
BreKelee

Post 26 Sep 2011, 21:20

10.04...wah...sip..ni bisa jadi acuan....aq coba dlu ya :D makasih..prend..prend...doa'in lancar... :D ...mash newbie...ane gan..ma ubuntu..hehehhe..pingsuit ma einhejars..ane add dlu..siap2 jadi dosen Ubuntu..ngajarin ane...ckckckck :)


User avatar
reeyz

Post 26 Sep 2011, 22:30

ok bro...thank's tutornya






==================================================================
http://www.crewconesia.net.ms


User avatar
WegigEinherjars

Post 27 Sep 2011, 08:35

semoga bermanfaat..


User avatar
harisuciha

Post 24 Oct 2011, 16:52

gini aja mas,,,ikutin tutorialnya pas langkah nginstal kyk libvw,wvdial dll via modem yg udh gampang kedetek ama ubuntu.
ane pinjem modem sierra dlu buat nginstalinnya soalnya males kl udh kejadian dependency..

pas udh beres instal2 br deh pake modem smartnya n lanjutin langkah selanjutnya..
btw baru aja ane selese nginstal smart ane...

smg membantu


User avatar
WegigEinherjars

Post 24 Oct 2011, 22:11

harisuciha wrote:gini aja mas,,,ikutin tutorialnya pas langkah nginstal kyk libvw,wvdial dll via modem yg udh gampang kedetek ama ubuntu.
ane pinjem modem sierra dlu buat nginstalinnya soalnya males kl udh kejadian dependency..

pas udh beres instal2 br deh pake modem smartnya n lanjutin langkah selanjutnya..
btw baru aja ane selese nginstal smart ane...

smg membantu
download paketnya di warnet terdekat dan buka apt-web.dahsy.at. search wvdial sesuai dengan distribusi linux yg digunakan.

estimasi waktu 5 - 10 menit, biaya mungkin 1000. Murah dan cepat.


Post Reply

Who is online

Users browsing this forum: No registered users and 18 guests