Ubuntu 10.04 "No init found. Try passing init= bootarg"

Semua mengenai lingkungan desktop Ubuntu.
User avatar
asterixman
Posts: 12
Joined: 30 Aug 2010, 22:08
Location: Bekasi, Indonesia
Contact:

Ubuntu 10.04 "No init found. Try passing init= bootarg"

Postby asterixman » 18 Mar 2011, 05:17

Tolong bantuan di share jika ada yg pernah mengatasi masalah sbb :

spek notebook :
TOSHIBA L510-B400
Dual Core T4400 @ 2.2GHz
Dual OS Ubuntu 10.04 & WinXP

Seingat saya sebelumnya tidak ada masalah dg OS Ubuntu kesayangan saya,
tapi pas nyalain ga bisa booting ke Ubuntu, cuma keluar layar item ama pesan errornya :
............bla...bla....
mount: mounting /dev on /root/dev failed: No such file or directory
mount: mounting /sys on /root/sys failed: No such file or directory
mount: mounting /proc on /root/proc failed: No such file or directory
Target filesystem doesn't have /sbin/init.
No init found. Try passing init= bootarg.

BusyBox v1.13.1 (Ubuntu 1:1.13.3-1ubuntu11) built-in shell (ash)
Enter 'help' for a list of built-in commands.

(initramfs) _

saya udah gugling dan nyoba beberapa solusi yg saya dapet :

Booting dengan live CD nya Ubuntu 10.04 dan buka terminal

1. saya cek partisi dengan fdisk -l
ubuntu@ubuntu:~$ sudo fdisk -l
Warning: ignoring extra data in partition table 5

Disk /dev/sda: 250.1 GB, 250059350016 bytes
255 heads, 63 sectors/track, 30401 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x08c788a3

Device Boot Start End Blocks Id System
/dev/sda1 * 1 5875 47190906 7 HPFS/NTFS
/dev/sda2 5876 9522 29294527+ 83 Linux
/dev/sda3 9523 30401 167710567+ 5 Extended
/dev/sda5 9523 9791 2160711 82 Linux swap / Solaris
/dev/sda6 27794 30401 20948728+ 7 HPFS/NTFS

2. sudo e2fsck -C0 -p -f -v /dev/sda2

muncul pesan :
ubuntu@ubuntu:~$ sudo e2fsck -C0 -p -f -v /dev/sda2
e2fsck: Device or resource busy while trying to open /dev/sda2
Filesystem mounted or opened exclusively by another program?

trus saya coba juga

3. sudo fsck /dev/sda2
ubuntu@ubuntu:~$ sudo fsck /dev/sda2
fsck from util-linux-ng 2.17.2
e2fsck 1.41.12 (17-May-2010)
fsck.ext4: Device or resource busy while trying to open /dev/sda2
Filesystem mounted or opened exclusively by another program?

masih ga menyelesaikan masalah juga...!!!
Pusing pusing pusing udah 3 hari berturut-turut ini ngutak atik sambil guling2 :cry: (gugling maksudnya) ga ktemu juga solusi yang tepat (ampe setengah pasrah).

buat info tambahan berikut isi file fstab nya :
ubuntu@ubuntu:~$ cat /etc/fstab
aufs / aufs rw 0 0
tmpfs /tmp tmpfs nosuid,nodev 0 0
/dev/sda5 swap swap defaults 0 0

Sori kalo kepanjangan dan bro2 ga ngerti sama bahasanya (maklum bahasa orang yang lagi pusing euy....!)

Mohon pencerahannya bagi yang pernah alami hal yang sama...
terima kasih....
User avatar
asterixman
Posts: 12
Joined: 30 Aug 2010, 22:08
Location: Bekasi, Indonesia
Contact:

Re: Ubuntu 10.04 "No init found. Try passing init= bootarg"

Postby asterixman » 18 Mar 2011, 05:26

Tambahan, ini juga udah di coba :

ubuntu@ubuntu:~$ sudo e2fsck -C0 -p -f -v /dev/sda1
/dev/sda1 is mounted.

WARNING!!! The filesystem is mounted. If you continue you ***WILL***
cause ***SEVERE*** filesystem damage.

Do you really want to continue (y/n)? yes

e2fsck: Bad magic number in super-block while trying to open /dev/sda1
/dev/sda1:
The superblock could not be read or does not describe a correct ext2
filesystem. If the device is valid and it really contains an ext2
filesystem (and not swap or ufs or something else), then the superblock
is corrupt, and you might try running e2fsck with an alternate superblock:
e2fsck -b 8193

ubuntu@ubuntu:~$ sudo e2fsck -b 8193 /dev/sda1
e2fsck 1.41.12 (17-May-2010)
/dev/sda1 is mounted.

WARNING!!! The filesystem is mounted. If you continue you ***WILL***
cause ***SEVERE*** filesystem damage.

Do you really want to continue (y/n)? yes

e2fsck: Bad magic number in super-block while trying to open /dev/sda1

The superblock could not be read or does not describe a correct ext2
filesystem. If the device is valid and it really contains an ext2
filesystem (and not swap or ufs or something else), then the superblock
is corrupt, and you might try running e2fsck with an alternate superblock:
e2fsck -b 8193
User avatar
thrvers
Posts: 4458
Joined: 01 Jan 2010, 13:28
Location: Jombang, Indonesia
Contact:

Re: Ubuntu 10.04 "No init found. Try passing init= bootarg"

Postby thrvers » 18 Mar 2011, 08:01

'
output ini apa yah??
$ sudo blkid
$ cat /etc/boot/grub/grub.cfg

atau sudah coba repair grubnya??
User avatar
asterixman
Posts: 12
Joined: 30 Aug 2010, 22:08
Location: Bekasi, Indonesia
Contact:

Re: Ubuntu 10.04 "No init found. Try passing init= bootarg"

Postby asterixman » 19 Mar 2011, 00:07

Thanks bro thrvers atas pencerahannya.

Setelah saya coba jalanin masih belum menyelesaikan masalah juga...

berikut hasilnya :
ubuntu@ubuntu:~$ sudo blkid
/dev/loop0: TYPE="squashfs"
/dev/sda1: UUID="C0EC00C8EC00BAA4" TYPE="ntfs"
/dev/sda2: UUID="f13e137a-9c3f-4685-b17f-4ea2ff669069" TYPE="ext4"
/dev/sda5: UUID="dd091dea-a66a-43b7-bd5c-d7f6889cde63" TYPE="swap"
/dev/sda6: LABEL="DATA" UUID="52309D7A309D65AF" TYPE="ntfs"
/dev/sda7: LABEL="MY_FILE" UUID="363CFC219FFA4E5C" TYPE="ntfs"
ubuntu@ubuntu:~$ cat /etc/boot/grub/grub.cfg
cat: /etc/boot/grub/grub.cfg: No such file or directory
ubuntu@ubuntu:~$ sudo mount /dev/sda1 /mnt
ubuntu@ubuntu:~$ sudo mount --bind /dev /mnt/dev
mount: mount point /mnt/dev does not exist
ubuntu@ubuntu:~$ sudo mount --bind /dev/pts /mnt/dev/pts
mount: mount point /mnt/dev/pts does not exist
ubuntu@ubuntu:~$ sudo mount --bind /proc /mnt/proc
mount: mount point /mnt/proc does not exist
ubuntu@ubuntu:~$ sudo chroot /mnt
chroot: failed to run command `/bin/bash': No such file or directory
ubuntu@ubuntu:~$ update-grub
grub-mkconfig: You must run this as root
ubuntu@ubuntu:~$ sudo update-grub
/usr/sbin/grub-probe: error: cannot find a device for / (is /dev mounted?).
ubuntu@ubuntu:~$
User avatar
thrvers
Posts: 4458
Joined: 01 Jan 2010, 13:28
Location: Jombang, Indonesia
Contact:

Re: Ubuntu 10.04 "No init found. Try passing init= bootarg"

Postby thrvers » 19 Mar 2011, 11:48

'
salah q kasih itu grub.cfg :MAAF:

harusnya, nda pke etc:
$ cat /boot/grub/grub.cfg

= :o =
User avatar
asterixman
Posts: 12
Joined: 30 Aug 2010, 22:08
Location: Bekasi, Indonesia
Contact:

Re: Ubuntu 10.04 "No init found. Try passing init= bootarg"

Postby asterixman » 20 Mar 2011, 21:09

saya coba jalanin diterminal :

thrvers wrote:'
salah q kasih itu grub.cfg :MAAF:

harusnya, nda pke etc:
$ cat /boot/grub/grub.cfg

= :o =




malah outputnya begini..
ubuntu@ubuntu:~$ cat /boot/grub/grub.cfg
cat: /boot/grub/grub.cfg: No such file or directory

trs saya cek directory grub memang tidak ada grub.cfg

ubuntu@ubuntu:~$ cd /boot/grub/
ubuntu@ubuntu:/boot/grub$ ls
grubenv
ubuntu@ubuntu:/boot/grub$
User avatar
zakezakir
Posts: 33
Joined: 20 Mar 2011, 12:00
Location: Jakarta
Contact:

Re: Ubuntu 10.04 "No init found. Try passing init= bootarg"

Postby zakezakir » 20 Mar 2011, 22:51

berarti grub nya belum di konfigurasi
hehehehe
User avatar
thrvers
Posts: 4458
Joined: 01 Jan 2010, 13:28
Location: Jombang, Indonesia
Contact:

Re: Ubuntu 10.04 "No init found. Try passing init= bootarg"

Postby thrvers » 21 Mar 2011, 18:43

'
sepertinya habis instal grub [yg versi awal - legacy] jadi grub2 nya terhapus :D

coba ini, buat grub legacy:
$ cat /boot/grub/menu.lst

= :D =

Return to “Ubuntu Desktop”

Who is online

Users browsing this forum: No registered users and 2 guests