problem soundcard di lucid

Membahas Perangkat-perangkat keras yang belum dideteksi dengan baik oleh Ubuntu serta solusinya.
User avatar
amanda
Posts: 203
Joined: 22 May 2010, 02:35

problem soundcard di lucid

Postby amanda » 04 Aug 2010, 15:20

aplay -l

Code: Select all

root@amanda:~# aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: Intel [HDA Intel], device 0: ALC883 Analog [ALC883 Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: Intel [HDA Intel], device 1: ALC883 Digital [ALC883 Digital]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: AudioPCI [Ensoniq AudioPCI], device 0: ES1371/1 [ES1371 DAC2/ADC]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: AudioPCI [Ensoniq AudioPCI], device 1: ES1371/2 [ES1371 DAC1]
  Subdevices: 1/1
  Subdevice #0: subdevice #0


cat /proc/asound/cards

Code: Select all

root@amanda:~# cat /proc/asound/cards
 0 [Intel          ]: HDA-Intel - HDA Intel
                      HDA Intel at 0xfdff8000 irq 27
 1 [AudioPCI       ]: ENS1371 - Ensoniq AudioPCI
                      Ensoniq AudioPCI ENS1371 at 0xdf00, irq 20


cat /proc/asound/version

Code: Select all

root@amanda:~# cat /proc/asound/version
Advanced Linux Sound Architecture Driver Version 1.0.22.1.


lspci | grep audio

Code: Select all

root@amanda:~# lspci | grep audio
03:00.0 Multimedia audio controller: Ensoniq ES1371 [AudioPCI-97] (rev 08)


head -n 1 /proc/asound/card*/codec#*

Code: Select all

root@amanda:~# head -n 1 /proc/asound/card*/codec#*
Codec: Realtek ALC883


lspci -v

Code: Select all

root@amanda:~# lspci -v
00:00.0 Host bridge: Intel Corporation 82G33/G31/P35/P31 Express DRAM Controller (rev 10)
   Subsystem: Giga-byte Technology Device 5000
   Flags: bus master, fast devsel, latency 0
   Capabilities: <access denied>
   Kernel driver in use: agpgart-intel
   Kernel modules: intel-agp

00:02.0 VGA compatible controller: Intel Corporation 82G33/G31 Express Integrated Graphics Controller (rev 10)
   Subsystem: Giga-byte Technology Device d000
   Flags: bus master, fast devsel, latency 0, IRQ 26
   Memory at fdf00000 (32-bit, non-prefetchable) [size=512K]
   I/O ports at ff00 [size=8]
   Memory at d0000000 (32-bit, prefetchable) [size=256M]
   Memory at fdc00000 (32-bit, non-prefetchable) [size=1M]
   Capabilities: <access denied>
   Kernel driver in use: i915
   Kernel modules: i915

00:1b.0 Audio device: Intel Corporation N10/ICH 7 Family High Definition Audio Controller (rev 01)
   Subsystem: Giga-byte Technology Device a002
   Flags: bus master, fast devsel, latency 0, IRQ 27
   Memory at fdff8000 (64-bit, non-prefetchable) [size=16K]
   Capabilities: <access denied>
   Kernel driver in use: HDA Intel
   Kernel modules: snd-hda-intel

00:1c.0 PCI bridge: Intel Corporation N10/ICH 7 Family PCI Express Port 1 (rev 01)
   Flags: bus master, fast devsel, latency 0
   Bus: primary=00, secondary=01, subordinate=01, sec-latency=0
   I/O behind bridge: 0000c000-0000cfff
   Memory behind bridge: fd900000-fd9fffff
   Prefetchable memory behind bridge: 00000000fd800000-00000000fd8fffff
   Capabilities: <access denied>
   Kernel driver in use: pcieport
   Kernel modules: shpchp

00:1c.1 PCI bridge: Intel Corporation N10/ICH 7 Family PCI Express Port 2 (rev 01)
   Flags: bus master, fast devsel, latency 0
   Bus: primary=00, secondary=02, subordinate=02, sec-latency=0
   I/O behind bridge: 0000b000-0000bfff
   Memory behind bridge: fde00000-fdefffff
   Prefetchable memory behind bridge: 00000000fdd00000-00000000fddfffff
   Capabilities: <access denied>
   Kernel driver in use: pcieport
   Kernel modules: shpchp

00:1d.0 USB Controller: Intel Corporation N10/ICH7 Family USB UHCI Controller #1 (rev 01)
   Subsystem: Giga-byte Technology Device 5004
   Flags: bus master, medium devsel, latency 0, IRQ 23
   I/O ports at fe00 [size=32]
   Kernel driver in use: uhci_hcd

00:1d.1 USB Controller: Intel Corporation N10/ICH 7 Family USB UHCI Controller #2 (rev 01)
   Subsystem: Giga-byte Technology Device 5004
   Flags: bus master, medium devsel, latency 0, IRQ 19
   I/O ports at fd00 [size=32]
   Kernel driver in use: uhci_hcd

00:1d.2 USB Controller: Intel Corporation N10/ICH 7 Family USB UHCI Controller #3 (rev 01)
   Subsystem: Giga-byte Technology Device 5004
   Flags: bus master, medium devsel, latency 0, IRQ 18
   I/O ports at fc00 [size=32]
   Kernel driver in use: uhci_hcd

00:1d.3 USB Controller: Intel Corporation N10/ICH 7 Family USB UHCI Controller #4 (rev 01)
   Subsystem: Giga-byte Technology Device 5004
   Flags: bus master, medium devsel, latency 0, IRQ 16
   I/O ports at fb00 [size=32]
   Kernel driver in use: uhci_hcd

00:1d.7 USB Controller: Intel Corporation N10/ICH 7 Family USB2 EHCI Controller (rev 01) (prog-if 20)
   Subsystem: Giga-byte Technology Device 5006
   Flags: bus master, medium devsel, latency 0, IRQ 23
   Memory at fdfff000 (32-bit, non-prefetchable) [size=1K]
   Capabilities: <access denied>
   Kernel driver in use: ehci_hcd

00:1e.0 PCI bridge: Intel Corporation 82801 PCI Bridge (rev e1) (prog-if 01)
   Flags: bus master, fast devsel, latency 0
   Bus: primary=00, secondary=03, subordinate=03, sec-latency=32
   I/O behind bridge: 0000d000-0000dfff
   Memory behind bridge: fdb00000-fdbfffff
   Prefetchable memory behind bridge: 00000000fda00000-00000000fdafffff
   Capabilities: <access denied>

00:1f.0 ISA bridge: Intel Corporation 82801GB/GR (ICH7 Family) LPC Interface Bridge (rev 01)
   Subsystem: Giga-byte Technology Device 5001
   Flags: bus master, medium devsel, latency 0
   Capabilities: <access denied>
   Kernel modules: intel-rng

00:1f.1 IDE interface: Intel Corporation 82801G (ICH7 Family) IDE Controller (rev 01) (prog-if 8a [Master SecP PriP])
   Subsystem: Giga-byte Technology Device b001
   Flags: bus master, medium devsel, latency 0, IRQ 18
   I/O ports at 01f0 [size=8]
   I/O ports at 03f4 [size=1]
   I/O ports at 0170 [size=8]
   I/O ports at 0374 [size=1]
   I/O ports at f800 [size=16]
   Kernel driver in use: ata_piix

00:1f.2 IDE interface: Intel Corporation N10/ICH7 Family SATA IDE Controller (rev 01) (prog-if 8f [Master SecP SecO PriP PriO])
   Subsystem: Giga-byte Technology Device b002
   Flags: bus master, 66MHz, medium devsel, latency 0, IRQ 19
   I/O ports at f700 [size=8]
   I/O ports at f600 [size=4]
   I/O ports at f500 [size=8]
   I/O ports at f400 [size=4]
   I/O ports at f300 [size=16]
   Capabilities: <access denied>
   Kernel driver in use: ata_piix

00:1f.3 SMBus: Intel Corporation N10/ICH 7 Family SMBus Controller (rev 01)
   Subsystem: Giga-byte Technology Device 5001
   Flags: medium devsel, IRQ 11
   I/O ports at 0500 [size=32]
   Kernel modules: i2c-i801

02:00.0 Ethernet controller: Atheros Communications Atheros AR8132 / L1c Gigabit Ethernet Adapter (rev c0)
   Subsystem: Giga-byte Technology Device e000
   Flags: bus master, fast devsel, latency 0, IRQ 28
   Memory at fdec0000 (64-bit, non-prefetchable) [size=256K]
   I/O ports at bf00 [size=128]
   Capabilities: <access denied>
   Kernel driver in use: atl1c
   Kernel modules: atl1c

03:00.0 Multimedia audio controller: Ensoniq ES1371 [AudioPCI-97] (rev 08)
   Subsystem: Ensoniq ES1371 [AudioPCI-97]
   Flags: bus master, slow devsel, latency 32, IRQ 20
   I/O ports at df00 [size=64]
   Capabilities: <access denied>
   Kernel driver in use: ENS1371
   Kernel modules: snd-ens1371


habis pasang souncard , aneh nya kalo putar film ditotem player dg posisi jek di pasang soundcard baru suara nya muncul, tp kalo buat putar music pk MPD , MPplayer / dgn minion suaranya g muncul ,

ku coba ganti colokan jeck kabel sound di soundcard lama malah suara hilang (sound preferences juga sudah ku setting) sound yang muncul dg menggunakan soundcard lama hanya sound menu log in (setelah proses booting), selebih nya g ngeluarin suara...

soundcard baru >> cuma totem yang mengeluarkan suara
soundcard lama >> cuma sound menu login yang mengeluarkan suara

help me dong......................ini yang rusak soundcard nya / pulseaudio nya / bagaimana yah?bingung sih,,soalnya di OS win$ soundcard nya berjalan lancar
User avatar
thrvers
Posts: 4458
Joined: 01 Jan 2010, 13:28
Location: Jombang, Indonesia
Contact:

Re: problem soundcard di lucid

Postby thrvers » 04 Aug 2010, 15:25

'
sama jg kek na :( kadang jg gitu.
q coba utak-atik SoundPreferences - TAB Hardware
Profile q ganti2 (sambil nyalain MPD) AnalogStereoOutput vs. AnalogStereoDuplex

jalan lagi :D
User avatar
amanda
Posts: 203
Joined: 22 May 2010, 02:35

Re: problem soundcard di lucid

Postby amanda » 04 Aug 2010, 15:32

iya nih maz kadang MPD bisa jalan(posisi jek di soundcard lama dg soundcard baru terpasang)

kadang bisa kadang enggang :(

Return to “Solusi Hardware Ubuntu”

Who is online

Users browsing this forum: No registered users and 1 guest