[ASK]pppoe dan ubuntu server 14.10

Diskusi tentang Ubuntu Server baik webserver, database server, samba server dan service lainnya serta jaringan menggunakan Sistem Operasi Ubuntu.
User avatar
n3wkid
Posts: 58
Joined: 02 Dec 2014, 13:21

[ASK]pppoe dan ubuntu server 14.10

Postby n3wkid » 15 Jan 2015, 10:33

Dear All,

saya mengikuti dan mempraktekkan tutorial dari om opi mengenai server.

1. modem sudah saya seting bridge
2. IP untuk eth0 saya sudah set, --> IP static untuk konek ke modem speedy
3. IP untuk eth1 untuk lokal juga sudah saya set,dan client dapat IP DHCP dari server.
4. install pppoe nya juga sudah beserta konfigurasinya.
5. sudah saya nat , iptables -t nat -A POSTROUTING -o ppp0 -j MASQUERADE
6. saya sudah simpan konfigurasi NAT ini biar g ilang waktu PC Server restart.
7. saya reboot dan saya cek lagi untuk iptables nya : iptables -t nat -L
8. ketika saya ping dari pc client, koneksi internetnya tidak berhasil.
9. untuk pengaturan DNS nya juga sudah.

ini masalahnya dimana lagi ya om..? mohon pencerahan

terimakasih
User avatar
n3wkid
Posts: 58
Joined: 02 Dec 2014, 13:21

Re: [ASK]pppoe dan ubuntu server 14.10

Postby n3wkid » 19 Jan 2015, 09:10

Yach.. gada yang respon :(
User avatar
Etles_T3am
Posts: 260
Joined: 26 Nov 2014, 17:08
Location: Malang-Jatim, Indonesia

Re: [ASK]pppoe dan ubuntu server 14.10

Postby Etles_T3am » 19 Jan 2015, 09:30

Ni masternya pppoe Bro :D langsung saja menuju TKP :D

>> http://darmawan-salihun.blogspot.tw/200 ... linux.html
User avatar
n3wkid
Posts: 58
Joined: 02 Dec 2014, 13:21

Re: [ASK]pppoe dan ubuntu server 14.10

Postby n3wkid » 19 Jan 2015, 09:36

Makasih agan Etles, saya coba dl...
User avatar
Etles_T3am
Posts: 260
Joined: 26 Nov 2014, 17:08
Location: Malang-Jatim, Indonesia

Re: [ASK]pppoe dan ubuntu server 14.10

Postby Etles_T3am » 19 Jan 2015, 11:44

Laa sumonggo agan n3wkid, Semoga ada "sesuatu" nya syahrini disitu :D
User avatar
n3wkid
Posts: 58
Joined: 02 Dec 2014, 13:21

Re: [ASK]pppoe dan ubuntu server 14.10

Postby n3wkid » 29 Jan 2015, 11:11

Saya tu bingung...

modem --- eth0-server-eth1--switch-pc

waktu saya nat ke arah eth0, internet dari client jalan..

iptables -t nat -A POSTROUTING -o eth0 -j MASQUERADE

Kenapa waktu iptables -t nat -A POSTROUTING -o ppp0 -j MASQUERADE
,ping dari pc client tidak bisa diteruskan dari server?

padahal saya menggunakan pc server ini sebagai router yang menggunakan pppoe



dan disini konfigurasi pppoeconf, useDNSpeer nya saya set No

tolong di bantu
User avatar
Etles_T3am
Posts: 260
Joined: 26 Nov 2014, 17:08
Location: Malang-Jatim, Indonesia

Re: [ASK]pppoe dan ubuntu server 14.10

Postby Etles_T3am » 29 Jan 2015, 12:18

Kang @n3wkid berikut contoh pada settingan punya saya beserta tweakingnya menggunakan Ubuntu Server 12.04 :


>> Konfigurasi file /etc/network/interfaces > Konfigurasi file /etc/sysctl.conf > Konfigurasi file /etc/rc.local > Konfigurasi file /etc/dhcp/dhcpd.conf > Konfigurasi /etc/default/isc-dhcp-server <<

:~$ sudo nano /etc/default/isc-dhcp-server

Cari line berikut ini ;

INTERFACES=""

ubahlah menjadi

INTERFACES="eth1"

Save dan exit nano lalu lakukan 2 perintah command ;

:~$ sudo service isc-dhcp-server stop
:~$ sudo service isc-dhcp-server start


Note: Disini saya menggunakan IP Address 172.22.22.0/24 dengan "eth0" bukan dengan "pppoe" jadi silahkan disesuaikan dengan IP sampean dan jenis connections nya.

Silahkan kang @n3wkid jika settingan sampean ada yg kurang, Silahkan di telisik :D
User avatar
n3wkid
Posts: 58
Joined: 02 Dec 2014, 13:21

Re: [ASK]pppoe dan ubuntu server 14.10

Postby n3wkid » 29 Jan 2015, 13:38

halo om, ini detail konfigurasi pada ubuntu 14.10 milik saya.
modem di set menjadi mode bridge

1. konfigurasi interface
#untuk WAN
auto eth0
iface eth0 inet static
address 192.168.1.2
netmask 255.255.255.0
network 192.168.1.0
broadcast 192.168.1.255
gateway 192.168.1.254
dns-nameservers 192.168.1.254

#untuk LAN
auto eth1
iface eth1 inet static
address 192.168.11.1
netmask 255.255.255.0
network 192.168.11.0
broadcast 192.168.11.255
dns-nameservers 192.168.11.1
dns-search local

#pppoe
auto dsl-provider
iface dsl-provider inet ppp
pre-up /bin/ip link set eth0 up #line maintained by pppoeconf
provider dsl-provider

2. konfigurasi dhcp

#A slightly......
subnet 192.168.11.0 netmask 255.255.255.0 {
range 192.168.11.11 192.168.11.211;
option domain-name-servers 192.168.11.1;
option domain-name "local";
option routers 192.168.11.1;
option broadcast-address 192.168.11.255;
default-lease-time 600;
max-lease-time 7200;
}

3. untuk /etc/default/isc-dhcp-server

INTERFACES="eth1"

4. Untuk sysctl juga sudah di hilangkan tanda "#"

net.ipv4.conf.default.rp_filter=1
net.ipv4.conf.all.rp_filter=1
net.ipv4.ip_forward=1

5. untuk konfigurasi pppoeconf, saya sesuaikan dengan instruksi konfigurasi pppoe kecuali men seting "No" untuk "usednspeer"

6. berkali-kali di hapus ip 192.168.1.254 di /etc/resolv.conf dan ketika reboot, ip 192.168.1.254 nongol lagi di /etc/resolv.conf

7. saya juga sudah seting DNS servernya dan sukses

8. Saya reboot, setelah itu saya ping dari server ke modem dan koneksi berhasil untuk internet

9. saya kembali cari informasi ppp0 nya dengan perintah "plog"
tapi nihil, dan saya ketikkan kembali landscape-sysinfo,
disitu tertera IP dari masing-masing device "eth0,eth1, dan ppp0"

10. server dan client bisa ping dengan sebatas lokal dan agar bisa client saya dpt inet melalui server, pertama itu saya nat mengarahkan ppp0 ke eth1 dan tanpa reboot:

iptables -t nat -A POSTROUTING -o ppp0 -j MASQUERADE


11. saya ping google dari client yang sudah dapat IP DHCP dari server sebelumnya. namun gagal.

mohon pencerahannya om



tambahan:
jika saya ubah dhcp nya pada option-name-servers menjadi

#A slightly......
subnet 192.168.11.0 netmask 255.255.255.0 {
range 192.168.11.11 192.168.11.211;
option domain-name-servers 192.168.11.1,192.168.1.254;
option domain-name "local";
option routers 192.168.11.1;
option broadcast-address 192.168.11.255;
default-lease-time 600;
max-lease-time 7200;
}

Saya reboot kembali dan saya nat kembali ke :

iptables -t nat -A POSTROUTING -o eth0 -j MASQUERADE


saya melakukan ping ke inet melalui pc client, ini malah bisa konek.. :crazy:


tolong dulu om, nanggung ne belajarnya..
:cry:
User avatar
n3wkid
Posts: 58
Joined: 02 Dec 2014, 13:21

Re: [ASK]pppoe dan ubuntu server 14.10

Postby n3wkid » 30 Jan 2015, 09:25

saya menggunakan

ppp [0.716756] generic driver version 2.4.2.

apakah ini ada pengaruh juga??

waktu saya jalankan plog,
itu tidak ada informasi apapun. dan apakah pppoe nya belum bisa dial? mohon tanggapannya

*pppoe sudah running saat pertama booting
User avatar
n3wkid
Posts: 58
Joined: 02 Dec 2014, 13:21

Re: [ASK]pppoe dan ubuntu server 14.10

Postby n3wkid » 30 Jan 2015, 14:13

permasalahannya kemungkinan besar ada pada replaced files ppp yang bawaan milik ubuntu server 14.10.

saya uninstall kembali pppoe dan pakai bawaan dari ubuntu server 14.10 sendiri. dan waktu saya plog, baru nampak informasinya.

ya mungkin sampai disitu aja. lom bisa ping sebab mungkin urusan ip route nya belum kelar.

jika di ping dari server, maka unreachable.

dan di forum ini sudah ada yang bahas, dan saudara kita tu cuma mindahin lokasi ppp0 nya diatas eth0 pada interfacesnya

namun tidak berlaku dengan konfigurasi saya..

tambah runyam dunia...
User avatar
Etles_T3am
Posts: 260
Joined: 26 Nov 2014, 17:08
Location: Malang-Jatim, Indonesia

Re: [ASK]pppoe dan ubuntu server 14.10

Postby Etles_T3am » 30 Jan 2015, 20:35

Mungkin permasalahannya juga pada IP tables Firewall. Disini akan saya coba memberikan contoh beberapa perintah command konfigurasi/set up IP tables firewall, Ma'af klu mungkin saya kurang Expert soal server :)

>> Set Default Policies > Block An IP Address > Allow Services To Respond To Requests > Allow Specific IP Address To Access Service > Allow Services To Connect > Restrict Outgoing Connections To Specific IP Addresses > Load Balancing > Allow NIS Connections > Prevent DOS Attacks > Log Anything That Failed <<

iptables -N LOGGING
iptables -A INPUT -j LOGGING
iptables -A LOGGING -m limit --limit 2/min -j LOG --log-prefix "IPTables Packet Dropped: " --log-level 7
iptables -A LOGGING -j DROP

Berikut juga saya kasih rincian port yang saya pakai :

http = port 80
https = port 443
rsync = 873
mysql = 3306
email sending = 25
email receive = 143/110

Silahkan di obok-obok konfigurasi server sampean dan siapa tahu contoh di atas berguna dan mungkin ada konfigurasi yang kurang tepat sampean terapkan, Dan saya yakin sampean lebih expert ketimbang saya, Salam.

Etles
User avatar
n3wkid
Posts: 58
Joined: 02 Dec 2014, 13:21

Re:[ASK]pppoe dan ubuntu server 14.10

Postby n3wkid » 31 Jan 2015, 01:59

Hehehe..makasih om ats konfigurasi firewallnya..
sy bukan expert,om.. sy cm masyarakat biasa saja..

ya bnr yg om bilang..ini tggal mslh ip routenya aj kl ttp mmgunakan ppp0..
seperti thread sy yg bru soal ip route.anyway akan sy pelajari lagi ini soal pppoe ini di ubuntu 14.10 server.wkt jua yg bikin mepet..tpi ini mmg bikin mumet mmg soal pppoe ini.

pokoke inget teman2 yg lain,kl fresh install ubuntu 14.10 yg konek ke internet,cb deh perhatikan dl direktori ppp sdh ada apa blm : dpkg -s pppoe
(ini sy sadari waktu uninstall pppoe dan iseng mw pastiin ada apa g,wktu jalankan pppoeconf malah aktif lgi, nah disini lah sebab musababnya.ternyata bawaan pppoe ini sdh ada sblmny di ubuntu14)

Kl katanya installed dan status ok, brrti kita cm jalankan pppoeconf.

jika opsi kedua yakni kita install lagi pppoe nya,dikhwtirkan nantinya wktu menjalankan pon dsl-provider dan jalankan plog tuk liat info yg kita ingin,maka hasil dari plog nya bakal gada info.
so mau tak mw uninstall smw la dl pppoe nya bru new install gi dan seting mcm semula.

Akhir cerita sy pake cara kedua dulu yaitu
Ip static di eth0 dari modem dan ip di eth1 nya tuk lokal
di nat ke eth0. Dan sukses mcm biasa dri client ke inet

Sementara ini G jadi pake pppoe.
Terimakasih om

Return to “Ubuntu Server”

Who is online

Users browsing this forum: No registered users and 2 guests