[ASK] ttg mail server yg tiba2 gabisa kirim email

Aplikasi-aplikasi diubuntu: • Aplikasi Grafis •
Aplikasi Internet •
Aplikasi Office •
Aplikasi Sound & Video •
Aplikasi Programming
User avatar
adidot
Posts: 5
Joined: 22 Sep 2014, 17:05

[ASK] ttg mail server yg tiba2 gabisa kirim email

Postby adidot » 02 Oct 2014, 16:45

hallo kakak2 ubuntu indonesia,
minta tolong nih, sy baru bangun mail server di ubuntu 12.10 dgn bind, postfix dan dovecot.
sebelumnya lancar, tapi baru baru ini jadi ga bisa kirim email

ini log nya setelah sy coba kirim email dari domain sy ke yahoo mail :

[SPOILER=/var/log/mail.log]Oct 2 13:36:07 ns1 dovecot: imap(noreply): Disconnected: Logged out in=79 out=705
Oct 2 13:36:08 ns1 dovecot: imap-login: Login: user=, method=PLAIN, rip=127.0.0.1, lip=127.0.0.1, mpid=20815, secured, sess$
Oct 2 13:36:08 ns1 dovecot: imap(noreply): Disconnected: Logged out in=79 out=705
Oct 2 13:36:25 ns1 postfix/smtp[20766]: 55C95122F54: to=, relay=none, delay=20, delays=0.05/0/20/0, dsn=4.4.3, status=deferred (Host or domain name not found. Name service error for name=yahoo.co.id type=MX: Host not found, try again)
[/SPOILER]

[SPOILER=/var/log/mail.err]Oct 2 13:08:01 dovecot: last message repeated 10 times
Oct 2 13:10:01 ns1 dovecot: imap-login: Error: read(anvil) failed: EOF
Oct 2 13:11:02 dovecot: last message repeated 5 times
[/SPOILER]

[SPOILER=var/log/dovecot.log]Oct 02 13:38:43 auth: Debug: client in: AUTH 1 PLAIN service=imap secured session=Y04n3moEUwB/AAAB lip=127.0.0.1$
Oct 02 13:38:43 auth: Debug: auth client connected (pid=20915)
Oct 02 13:38:43 auth-worker(20916): Debug: Loading modules from directory: /usr/lib/dovecot/modules/auth
Oct 02 13:38:43 auth-worker(20916): Debug: pam(noreply,127.0.0.1): lookup service=dovecot
Oct 02 13:38:43 auth-worker(20916): Debug: pam(noreply,127.0.0.1): #1/1 style=1 msg=Password:
Oct 02 13:38:43 auth: Debug: client out: OK 1 user=noreply
Oct 02 13:38:43 auth: Debug: master in: REQUEST 3511681025 20814 1 2320707bf1b9c79505fa7656fba9fcba
Oct 02 13:38:43 auth: Debug: passwd(noreply,127.0.0.1,): lookup
Oct 02 13:38:43 auth: Debug: master out: USER 3511681025 noreply system_groups_user=noreply uid=1003 gid=1003 $
Oct 02 13:38:43 imap(noreply): Debug: Effective uid=1003, gid=1003, home=/home/noreply
Oct 02 13:38:43 imap(noreply): Debug: Namespace inbox: type=private, prefix=, sep=, inbox=yes, hidden=no, list=yes, subscriptions=yes$
Oct 02 13:38:43 imap(noreply): Debug: fs: root=/home/noreply/mail, index=, control=, inbox=/var/mail/noreply, alt=
[/SPOILER]

terus ini config2 sy :

[SPOILER=/etc/postfix/main.cf]# See /usr/share/postfix/main.cf.dist for a commented, more complete version

# Debian specific: Specifying a file name will cause the first
# line of that file to be used as the name. The Debian default
# is /etc/mailname.
#myorigin = /etc/mailname

smtpd_banner = $myhostname ESMTP $mail_name (Ubuntu)
biff = no

# appending .domain is the MUA's job.
append_dot_mydomain = no

# Uncomment the next line to generate "delayed mail" warnings
#delay_warning_time = 4h

readme_directory = no

# TLS parameters
smtpd_tls_cert_file=/etc/ssl/certs/ssl-cert-snakeoil.pem
smtpd_tls_key_file=/etc/ssl/private/ssl-cert-snakeoil.key
smtpd_use_tls=yes
smtpd_tls_session_cache_database = btree:${data_directory}/smtpd_scache
smtp_tls_session_cache_database = btree:${data_directory}/smtp_scache
smtpd_sasl_type = dovecot

# See /usr/share/doc/postfix/TLS_README.gz in the postfix-doc package for
# information on enabling SSL in the smtp client.

myhostname = mail.domainsaya.com
mydomain = domainsaya.com
alias_maps = hash:/etc/aliases
alias_database = hash:/etc/aliases
myorigin = domainsaya.com
mydestination = mail.domainsaya.com, ns.domainsaya.com, localhost.domainsaya.com, localhost, $myhostname, $myorigin, $mydomain
relayhost =
mynetworks = 182.253.0.0/16 127.0.0.0/8 [::ffff:127.0.0.0]/104 [::1]/128
mailbox_size_limit = 0
recipient_delimiter = +
inet_interfaces = all
[/SPOILER]

[SPOILER=/etc/dovecot/conf.d/10-auth.conf]disable_plaintext_auth = no
auth_mechanisms = plain login
!include auth-system.conf.ext
[/SPOILER]

[SPOILER=/etc/dovecot/conf.d/10-mail.conf]mail_location = mbox:~/mail:INBOX=/var/mail/%u
namespace inbox {
inbox = yes
}
mail_privileged_group = mail
[/SPOILER]

[SPOILER=/etc/dovecot/conf.d/10-master.conf]
default_process_limit = 199999
default_client_limit = 199999
service imap-login {
inet_listener imap {
port = 143
}
inet_listener imaps {
port = 993
ssl = yes
}
}
service pop3-login {
inet_listener pop3 {
port = 110
}
inet_listener pop3s {
port = 995
ssl = yes
}
}
service auth {
unix_listener auth-userdb {
mode = 0600
user = root
}
}
[/SPOILER]

di test telnet bisa, kirim pake squirrelmail bisa, cek status semua service bind, postfix dan dovecot semuanya start..tapi ya itu ga keterima ke email penerima.

tolong ya kakak2, thx sebelumnya :blush: :blush:
User avatar
sr_aja
Posts: 597
Joined: 10 Dec 2012, 11:21
Location: Jakarta

Re: [ASK] ttg mail server yg tiba2 gabisa kirim email

Postby sr_aja » 02 Oct 2014, 17:43

sepertinya ada masalah dengan bind nya
kemungkinan besar si mail server tidak bisa resolv domain luar:
perhatikan error yg saya bold

Code: Select all

Oct 2 13:36:25 ns1 postfix/smtp[20766]: 55C95122F54: to=<adityo_t@yahoo.co.id>, relay=none, delay=20, delays=0.05/0/20/0, dsn=4.4.3, status=deferred [b](Host or domain name not found. Name service error for name=yahoo.co.id type=MX: Host not found, try again[/b])

cek file /etc/resolv.conf
coba rubah primary nameserver ke google (8.8.8.8)
jika berhasil, cek konfigurasi bind nya; aktifkan fasilitas domain forwarding pada bind.

btw; apakah ada queue di mailservernya?
User avatar
adidot
Posts: 5
Joined: 22 Sep 2014, 17:05

Re: [ASK] ttg mail server yg tiba2 gabisa kirim email

Postby adidot » 02 Oct 2014, 18:22

sr_aja wrote:sepertinya ada masalah dengan bind nya
kemungkinan besar si mail server tidak bisa resolv domain luar:
perhatikan error yg saya bold

Code: Select all

Oct 2 13:36:25 ns1 postfix/smtp[20766]: 55C95122F54: to=<adityo_t@yahoo.co.id>, relay=none, delay=20, delays=0.05/0/20/0, dsn=4.4.3, status=deferred [b](Host or domain name not found. Name service error for name=yahoo.co.id type=MX: Host not found, try again[/b])

cek file /etc/resolv.conf
coba rubah primary nameserver ke google (8.8.8.8)
jika berhasil, cek konfigurasi bind nya; aktifkan fasilitas domain forwarding pada bind.

btw; apakah ada queue di mailservernya?


saya sudah ubah di etc/resolv.conf jadi bgini :
#Dynamic resolv.conf(5) file for glibc resolver(3) generated by resolvconf(8)
#DO NOT EDIT THIS FILE BY HAND -- YOUR CHANGES WILL BE OVERWRITTEN
name server 8.8.8.8


kemudian utk buka fasilitas forwarding pada bind apakah ada di /etc/bind/named.conf.options bukan?
saya buka jadi begini :
options {
directory "var/cache/bind";

// If there is a firewall between you and nameservers you want
// to talk to, you may need to fix the firewall to allow multiple
// ports to talk. See http://www.kb.cert.org/vuls/id/800113

// If your ISP provided one or more IP addresses for stable
// nameservers, you probably want to use them as forwarders.
// Uncomment the following block, and insert the addresses replacing
// the all-0's placeholder.
// forward only;
forwarders {
8.8.8.8;
};


tetap tidak bisa :(

oia, log utk cek queue ada dimana ya, klo di /var/log/mail.log ada banyak aktifitas yg seperti ini :
Sep 28 09:20:27 ns1 postfix/qmgr[8408]: 757EE122F96: from=, size=5483, nrcpt=1 (queue active)
Sep 28 09:20:27 ns1 postfix/qmgr[8408]: 767F0122F60: from=, size=4646, nrcpt=1 (queue active)
Sep 28 09:20:27 ns1 postfix/qmgr[8408]: 752CA122F4A: from=, size=4790, nrcpt=1 (queue active)
Sep 28 09:20:27 ns1 postfix/qmgr[8408]: 76D28122F4C: from=, size=4628, nrcpt=1 (queue active)
Sep 28 09:20:27 ns1 postfix/qmgr[8408]: 7829C122F59: from=, size=4748, nrcpt=1 (queue active)
Sep 28 09:20:27 ns1 postfix/qmgr[8408]: 71E34122F5E: from=, size=4634, nrcpt=1 (queue active)
Sep 28 09:20:27 ns1 postfix/qmgr[8408]: 73711122F50: from=, size=5496, nrcpt=1 (queue active)
Sep 28 09:20:27 ns1 postfix/qmgr[8408]: 304F0122FB3: from=, size=5493, nrcpt=1 (queue active)
Sep 28 09:20:27 ns1 postfix/qmgr[8408]: 176ED12287F: from=, size=3146, nrcpt=1 (queue active)


lalu

Sep 28 09:20:27 ns1 postfix/smtp[20797]: 6CB2A122F17: to=, relay=none, delay=252560, delays=252560/0.03/0/0, dsn=4.4.3, status=deferred (Host or domain name not found. Name service error for name=onemedic.co.id type=MX: Host not found, try again)
Sep 28 09:20:27 ns1 postfix/error[20803]: 687B4122EEC: to=, relay=none, delay=84601, delays=84601/0.05/0/0, dsn=4.4.3, status=deferred (delivery temporarily suspended: Host or domain name not found. Name service error for name=onemedic.co.id type=MX: Host not found, try again)
Sep 28 09:25:27 ns1 postfix/smtp[20910]: A02A612302F: to=, relay=none, delay=244189, delays=244189/0.02/0/0, dsn=4.4.3, status=deferred (Host or domain name not found. Name service error for name=gmail.com type=MX: Host not found, try again


ini kemungkinan dari aplikasi ticketing system sy yg ngirim notifikasi lewat email..

jd kira2 gmn kak?
User avatar
sr_aja
Posts: 597
Joined: 10 Dec 2012, 11:21
Location: Jakarta

Re: [ASK] ttg mail server yg tiba2 gabisa kirim email

Postby sr_aja » 02 Oct 2014, 20:43

@adidot;
untuk mengecek mail queue postix cukup.ketikkan perintah
mailq (enter)

jika ada banyak error code postfix salah satunya adalah suspend
jika status suspend; maka ada 2 kemungkinan
1) mailserver anda di anggap sebagai server yg merelay aktifitas spammer
2) configurasi mx record mailserver anda salah, sehingga server2 yg menerapkan syatem filtering akan menganggap server email tersebut tdk valid

silahkan pm alamat domain anda, dan hasil dari perintah mailq
(krn jika di ketahui khalayak, akan menimbulkan potensi pemanfaatan celah relay mail)
nanti saya akan bales lwt pm juga, semoga malem ini gw bisa online di laptop untuk testing audit mailserver mu...

salam
User avatar
adidot
Posts: 5
Joined: 22 Sep 2014, 17:05

[SOLVED] ttg mailserver yg tiba2 gbisa kirim email

Postby adidot » 09 Oct 2014, 22:00

ternyata masalahnya ada di regulasi ISP saya, yg memblock DNS google (8.8.8.8). akhirnya saya ganti menggunakan DNS bawaan ISP, dan kirim email berhasil kembali

saya ganti DNS di forwarders di /etc/bind/named.conf.options

Code: Select all

options {
        directory "var/cache/bind";

        // If there is a firewall between you and nameservers you want
        // to talk to, you may need to fix the firewall to allow multiple
        // ports to talk.  See http://www.kb.cert.org/vuls/id/800113

        // If your ISP provided one or more IP addresses for stable
        // nameservers, you probably want to use them as forwarders.
        // Uncomment the following block, and insert the addresses replacing
        // the all-0's placeholder.
        forward first;
        forwarders {
        //DNS ISP
          203.142.xx.xxx;    <-- isikan DNS 1 mu
          203.142.xx.xxx;    <-- isikan DNS 2 mu
        };

Return to “Aplikasi Ubuntu”

Who is online

Users browsing this forum: No registered users and 8 guests