[HELP] mengenai unmet dependencies Ubuntu 14.04

Diskusi tentang Ubuntu Server baik webserver, database server, samba server dan service lainnya serta jaringan menggunakan Sistem Operasi Ubuntu.
User avatar
ogie
Posts: 2
Joined: 27 Aug 2014, 10:19

[HELP] mengenai unmet dependencies Ubuntu 14.04

Postby ogie » 27 Aug 2014, 10:25

Assalamu'alaikum
saya mau minta tolong nih ubuntu server 14.04 saya ketika melakukan perintah sudo apt-get upgrade terdapat erro seperti dibawah ini:

smuth@smuth:~$ sudo apt-get upgrade
Reading package lists... Done
Building dependency tree
Reading state information... Done
You might want to run 'apt-get -f install' to correct these.
The following packages have unmet dependencies:
musixtex : Depends: tex-common (>= 2.00) but it is not installed
preview-latex-style : Depends: tex-common but it is not installed
Recommends: doc-base but it is not installed
rubber : Depends: texlive-latex-base but it is not installed or
tetex-bin but it is not installable
texlive-base : Depends: tex-common (>= 2.00) but it is not installed
Depends: luatex (>= 0.46.0-5) but it is not installed
Recommends: lmodern (>= 0.93.3-1) but it is not installed
texlive-bibtex-extra : Depends: tex-common (>= 2.00) but it is not installed
Depends: texlive-latex-base (>= 2009-1) but it is not installed
texlive-binaries : Depends: tex-common (>= 2.00) but it is not installed
texlive-common : Depends: tex-common (>= 2.0) but it is not installed
texlive-doc-base : Depends: tex-common (>= 2.00) but it is not installed
texlive-doc-bg : Depends: tex-common (>= 2.00) but it is not installed
texlive-doc-cs+sk : Depends: tex-common (>= 2.00) but it is not installed
texlive-doc-de : Depends: tex-common (>= 2.00) but it is not installed
texlive-doc-en : Depends: tex-common (>= 2.00) but it is not installed
texlive-doc-es : Depends: tex-common (>= 2.00) but it is not installed
texlive-doc-fi : Depends: tex-common (>= 2.00) but it is not installed
texlive-doc-fr : Depends: tex-common (>= 2.00) but it is not installed
texlive-doc-it : Depends: tex-common (>= 2.00) but it is not installed
texlive-doc-ja : Depends: tex-common (>= 2.00) but it is not installed
texlive-doc-ko : Depends: tex-common (>= 2.00) but it is not installed
texlive-doc-mn : Depends: tex-common (>= 2.00) but it is not installed
texlive-doc-nl : Depends: tex-common (>= 2.00) but it is not installed
texlive-doc-pt : Depends: tex-common (>= 2.00) but it is not installed
texlive-doc-ru : Depends: tex-common (>= 2.00) but it is not installed
texlive-doc-si : Depends: tex-common (>= 2.00) but it is not installed
texlive-doc-th : Depends: tex-common (>= 2.00) but it is not installed
texlive-doc-tr : Depends: tex-common (>= 2.00) but it is not installed
texlive-doc-uk : Depends: tex-common (>= 2.00) but it is not installed
texlive-doc-vi : Depends: tex-common (>= 2.00) but it is not installed
texlive-doc-zh : Depends: tex-common (>= 2.00) but it is not installed
texlive-extra-utils : Depends: tex-common (>= 2.00) but it is not installed
Recommends: lacheck but it is not installed
texlive-font-utils : Depends: tex-common (>= 2.00) but it is not installed
texlive-fonts-extra-doc : Depends: tex-common (>= 2.00) but it is not installed
texlive-fonts-recommended : Depends: tex-common (>= 2.00) but it is not installed
texlive-fonts-recommended-doc : Depends: tex-common (>= 2.00) but it is not installed
texlive-formats-extra : Depends: tex-common (>= 2.00) but it is not installed
Depends: texlive-latex-base (>= 2009-1) but it is not installed
texlive-games : Depends: tex-common (>= 2.00) but it is not installed
Depends: texlive-latex-base (>= 2009-1) but it is not installed
texlive-generic-recommended : Depends: tex-common (>= 2.00) but it is not installed
texlive-humanities : Depends: tex-common (>= 2.00) but it is not installed
Depends: texlive-latex-base (>= 2009-1) but it is not installed
texlive-humanities-doc : Depends: tex-common (>= 2.00) but it is not installed
texlive-lang-african : Depends: tex-common (>= 2.00) but it is not installed
texlive-lang-arabic : Depends: tex-common (>= 2.00) but it is not installed
texlive-lang-armenian : Depends: tex-common (>= 2.00) but it is not installed
texlive-lang-croatian : Depends: tex-common (>= 2.00) but it is not installed
texlive-lang-cyrillic : Depends: tex-common (>= 2.00) but it is not installed
Depends: texlive-latex-base (>= 2009-1) but it is not installed
texlive-lang-czechslovak : Depends: tex-common (>= 2.00) but it is not installed
Depends: texlive-latex-base (>= 2009-1) but it is not installed
texlive-lang-danish : Depends: tex-common (>= 2.00) but it is not installed
texlive-lang-dutch : Depends: tex-common (>= 2.00) but it is not installed
texlive-lang-finnish : Depends: tex-common (>= 2.00) but it is not installed
texlive-lang-french : Depends: tex-common (>= 2.00) but it is not installed
texlive-lang-german : Depends: tex-common (>= 2.00) but it is not installed
texlive-lang-hebrew : Depends: tex-common (>= 2.00) but it is not installed
texlive-lang-hungarian : Depends: tex-common (>= 2.00) but it is not installed
texlive-lang-indic : Depends: tex-common (>= 2.00) but it is not installed
Recommends: latex-sanskrit (>= 2.2-1) but it is not installed
texlive-lang-italian : Depends: tex-common (>= 2.00) but it is not installed
texlive-lang-latin : Depends: tex-common (>= 2.00) but it is not installed
texlive-lang-latvian : Depends: tex-common (>= 2.00) but it is not installed
texlive-lang-lithuanian : Depends: tex-common (>= 2.00) but it is not installed
texlive-lang-mongolian : Depends: tex-common (>= 2.00) but it is not installed
texlive-lang-norwegian : Depends: tex-common (>= 2.00) but it is not installed
texlive-lang-other : Depends: tex-common (>= 2.00) but it is not installed
texlive-lang-portuguese : Depends: tex-common (>= 2.00) but it is not installed
texlive-lang-spanish : Depends: tex-common (>= 2.00) but it is not installed
texlive-lang-swedish : Depends: tex-common (>= 2.00) but it is not installed
texlive-lang-tibetan : Depends: tex-common (>= 2.00) but it is not installed
texlive-lang-ukenglish : Depends: tex-common (>= 2.00) but it is not installed
texlive-lang-vietnamese : Depends: tex-common (>= 2.00) but it is not installed
texlive-latex-base-doc : Depends: tex-common (>= 2.00) but it is not installed
texlive-latex-extra-doc : Depends: tex-common (>= 2.00) but it is not installed
texlive-latex-recommended : Depends: tex-common (>= 2.00) but it is not installed
Depends: texlive-latex-base (>= 2009-1) but it is not installed
Recommends: prosper (>= 1.00.4+cvs.2006.10.22-1) but it is not installed
Recommends: latex-beamer (>= 3.06.dfsg.1-0.1) but it is not installed
Recommends: latex-xcolor (>= 2.09-1) but it is not installed
texlive-latex-recommended-doc : Depends: tex-common (>= 2.00) but it is not installed
texlive-latex3 : Depends: tex-common (>= 2.00) but it is not installed
Depends: texlive-latex-base (>= 2009-1) but it is not installed
texlive-math-extra : Depends: tex-common (>= 2.00) but it is not installed
Depends: texlive-latex-base (>= 2009-1) but it is not installed
texlive-metapost-doc : Depends: tex-common (>= 2.00) but it is not installed
texlive-music : Depends: tex-common (>= 2.00) but it is not installed
Depends: texlive-latex-base (>= 2009-1) but it is not installed
texlive-omega : Depends: tex-common (>= 2.00) but it is not installed
Depends: texlive-latex-base (>= 2009-1) but it is not installed
texlive-pictures-doc : Depends: tex-common (>= 2.00) but it is not installed
texlive-plain-extra : Depends: tex-common (>= 2.00) but it is not installed
texlive-pstricks-doc : Depends: tex-common (>= 2.00) but it is not installed
texlive-publishers : Depends: tex-common (>= 2.00) but it is not installed
Depends: texlive-latex-base (>= 2009-1) but it is not installed
texlive-publishers-doc : Depends: tex-common (>= 2.00) but it is not installed
texlive-science-doc : Depends: tex-common (>= 2.00) but it is not installed
texlive-xetex : Depends: tex-common (>= 2.00) but it is not installed
Depends: texlive-latex-base (>= 2009-1) but it is not installed
Recommends: lmodern but it is not installed
tipa : Depends: texlive-latex-base but it is not installed
Depends: tex-common (>= 2.00) but it is not installed
E: Unmet dependencies. Try using -f.

mohon bantuan untuk menyelesaikan masalahnya
terimakasih
User avatar
Malsasa
Posts: 2974
Joined: 07 Jun 2010, 22:37
Location: Mojokerto, Indonesia
Contact:

Re: [HELP] mengenai unmet dependencies Ubuntu 14.04

Postby Malsasa » 27 Aug 2014, 11:30

Coba perintah sudo apt-get -f install.
User avatar
ogie
Posts: 2
Joined: 27 Aug 2014, 10:19

Re: [HELP] mengenai unmet dependencies Ubuntu 14.04

Postby ogie » 27 Aug 2014, 12:12

masih tida bisa, tapi lagi coba pakai $ sudo apt-get update && sudo apt-get -f install && sudo
apt-get-dist-upgrade
User avatar
sr_aja
Posts: 602
Joined: 10 Dec 2012, 11:21
Location: Jakarta

Re: [HELP] mengenai unmet dependencies Ubuntu 14.04

Postby sr_aja » 02 Sep 2014, 00:07

coba cek apakah paket "tex-common" sdh ada apa belon?
dpkg -l | grep tex-common

kl blm ada coba install, ini masalah kebutuhan paket
jd dlm gnu/linux terkadang ada keterkaitan antara paket yg di butuhkan dgn paket lain itu lbh dikenal dgn dependensi... semacam sharing library kl di win.
contoh kecil ketika kita ingin install office 2007 di win xp prof.. maka OS akan meminta kita menginstall dot met..

atau browser misalnya ingin buka youtube.. pasti akan membutuhkan flash player

pokoke mirip2 gitu deh..

option -f biasanya atau lbh tepatnya gw anggep dgn pemaksaan kehendak :D
jd apt kgk peduli apakah aplikasi yg di install mau di remove atau mau di prrtahankan pokoke perintah yg di depan hrs di eksekusi

Return to “Ubuntu Server”

Who is online

Users browsing this forum: veryvan and 14 guests