E: Unable to correct problems, you have held

Pertanyaan umum seputar distribusi Ubuntu yang menjadi distro wajib members ubuntu-indonesia.com
User avatar
linuxerMuna
Posts: 1
Joined: 06 May 2014, 10:47

E: Unable to correct problems, you have held

Postby linuxerMuna » 06 May 2014, 10:52

gan ane dapat masalah ini,,,tiap ane mw install aplikasi di ubuntu 14.04 gw dapet pesan gini ::


irfan@irfan-X200CA:~$ sudo apt-get install vlc
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
vlc : Depends: vlc-nox (= 2.1.2+git20140426+r54526+18+11~ubuntu14.04.1) but it is not going to be installed
Depends: libsdl-image1.2 (>= 1.2.10) but it is not going to be installed
Depends: libsdl1.2debian (>= 1.2.11) but it is not installable
Depends: libxcb-composite0 but it is not installable
Depends: libxcb-keysyms1 (>= 0.3.9) but it is not installable
Depends: libxcb-xv0 (>= 1.2) but it is not installable
Recommends: vlc-plugin-notify (= 2.1.2+git20140426+r54526+18+11~ubuntu14.04.1) but it is not going to be installed
Recommends: vlc-plugin-pulse (= 2.1.2+git20140426+r54526+18+11~ubuntu14.04.1) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

udah ane update n upgrade tpi tetap saja,,mhon pencerahannya
User avatar
Malsasa
Posts: 2974
Joined: 07 Jun 2010, 22:37
Location: Mojokerto, Indonesia
Contact:

Re: E: Unable to correct problems, you have held

Postby Malsasa » 06 May 2014, 11:06

Yang paling penting bukan sudo apt-get upgrade, tetapi apa isi sources.list. Coba paste ke sini isinya.
User avatar
mhoosey
Posts: 203
Joined: 04 Oct 2013, 00:51
Location: Jakarta, Indonesia
Contact:

Re: E: Unable to correct problems, you have held

Postby mhoosey » 06 May 2014, 13:08

Dependency unmet, artinya ada yang kurang librarynya.

Coba pakai synaptic. Cari VLC, klik kanan, pilih "Mark for Installation",

terus klik kanan lagi, pilih "Install Recomendation (kalau gak salah)"

Baru apply.
User avatar
blackshirt
Posts: 2336
Joined: 02 Jan 2010, 17:00
Location: Solo dan Kebumen
Contact:

Re: E: Unable to correct problems, you have held

Postby blackshirt » 07 May 2014, 16:16

campuran sources.listnya ...

Return to “Pertanyaan Umum”

Who is online

Users browsing this forum: No registered users and 8 guests