aplikasi gambas3

Aplikasi-aplikasi diubuntu: • Aplikasi Grafis •
Aplikasi Internet •
Aplikasi Office •
Aplikasi Sound & Video •
Aplikasi Programming
User avatar
henel
Posts: 20
Joined: 14 Nov 2011, 10:55

aplikasi gambas3

Postby henel » 02 Jun 2013, 07:56

Dear,
Mohon bantuan, saya sedang membuat program dengan gambas untuk dihubungkan dengan mesin, saya sudah install gambas2 di UBUNTU 10.04 dan saat ini saya punya problem di dalam gb.chart, dimana saya tidak bisa merubah warna chart-nya, kalau baca-baca problem gb.chart di gambas2 disebabkan masalah gb,chart yang masih punya bug, sarannya untuk upgrade ke gambas3.
Pertanyaannya:
1. dimana saya bisa download gambas3? (dulu waktu gambas2 saya lakukan installasi offline dengan men-download file dengan extensi *.deb sebanyak 79 file di lupa webnya).
2. kalau pc saya sudah ada gambas2, apa yang harus saya lakukan? maaf saya belum familiar dengan perintah linux untuk install maupun uninstall program.

terima kasih banyak atas bantuannya
salam

hendry
User avatar
nif
Posts: 2818
Joined: 31 Mar 2011, 07:48

Re: aplikasi gambas3

Postby nif » 02 Jun 2013, 08:24

gambas3 ada di PPA; ppa:nemh/gambas3

komputernya terkoneksi internet enggak om?
kalo iya, coba;

Code: Select all

sudo add-apt-repository ppa:nemh/gambas3
sudo apt-get update
sudo apt-get install gambas3

kalo enggak terkoneksi internet silahkan coba gunakan apt-id di signature saya.

btw, Ubuntu 10.04 sudah versi lama om. sebaiknya pertimbangkan juga untuk pindah ke 12.04 LTS

cmiiw
User avatar
henel
Posts: 20
Joined: 14 Nov 2011, 10:55

Re: aplikasi gambas3

Postby henel » 02 Jun 2013, 11:14

untuk install gambas3, gambas2 langsung ditindas atau di uninstall?
thank
User avatar
nif
Posts: 2818
Joined: 31 Mar 2011, 07:48

Re: aplikasi gambas3

Postby nif » 02 Jun 2013, 13:14

saya kurang tau sih, tak pernah pake gambas, tapi mungkin memang sebaiknya gambas2 di-uninstall dulu;
sudo apt-get purge gambas2

cmiiw
User avatar
henel
Posts: 20
Joined: 14 Nov 2011, 10:55

Re: aplikasi gambas3

Postby henel » 02 Jun 2013, 16:02

sudah download gambas3 package launchpad.net sejumlah 71 file dengan extensi *.deb dan setelah diinstall banyak errornya. Berikut beberapa yang bisa simpan:
Tampilkan
=============================================================
1lucid2_all.deb) ...
Unpacking replacement gambas3-gb-args ...
Preparing to replace gambas3-gb-cairo 3.4.1-1lucid2 (using gambas3-gb-cairo_3.4.1-1lucid2_i386.deb) ...
Unpacking replacement gambas3-gb-cairo ...
Preparing to replace gambas3-gb-chart 3.4.1-1lucid2 (using gambas3-gb-chart_3.4.1-1lucid2_all.deb) ...
Unpacking replacement gambas3-gb-chart ...
Preparing to replace gambas3-gb-complex 3.4.1-1lucid2 (using gambas3-gb-complex_3.4.1-1lucid2_i386.deb) ...
Unpacking replacement gambas3-gb-complex ...
Preparing to replace gambas3-gb-compress 3.4.1-1lucid2 (using gambas3-gb-compress_3.4.1-1lucid2_i386.deb) ...
Unpacking replacement gambas3-gb-compress ...
Preparing to replace gambas3-gb-compress-bzlib2 3.4.1-1lucid2 (using gambas3-gb-compress-bzlib2_3.4.1-1lucid2_i386.deb) ...
Unpacking replacement gambas3-gb-compress-bzlib2 ...
Preparing to replace gambas3-gb-compress-zlib 3.4.1-1lucid2 (using gambas3-gb-compress-zlib_3.4.1-1lucid2_i386.deb) ...
Unpacking replacement gambas3-gb-compress-zlib ...
Preparing to replace gambas3-gb-crypt 3.4.1-1lucid2 (using gambas3-gb-crypt_3.4.1-1lucid2_i386.deb) ...
Unpacking replacement gambas3-gb-crypt ...
Preparing to replace gambas3-gb-data 3.4.1-1lucid2 (using gambas3-gb-data_3.4.1-1lucid2_i386.deb) ...
Unpacking replacement gambas3-gb-data ...
Preparing to replace gambas3-gb-db 3.4.1-1lucid2 (using gambas3-gb-db_3.4.1-1lucid2_i386.deb) ...
Unpacking replacement gambas3-gb-db ...
Preparing to replace gambas3-gb-db-form 3.4.1-1lucid2 (using gambas3-gb-db-form_3.4.1-1lucid2_all.deb) ...
Unpacking replacement gambas3-gb-db-form ...
Preparing to replace gambas3-gb-db-mysql 3.4.1-1lucid2 (using gambas3-gb-db-mysql_3.4.1-1lucid2_i386.deb) ...
Unpacking replacement gambas3-gb-db-mysql ...
Preparing to replace gambas3-gb-db-odbc 3.4.1-1lucid2 (using gambas3-gb-db-odbc_3.4.1-1lucid2_i386.deb) ...
Unpacking replacement gambas3-gb-db-odbc ...
Preparing to replace gambas3-gb-db-postgresql 3.4.1-1lucid2 (using gambas3-gb-db-postgresql_3.4.1-1lucid2_i386.deb) ...
Unpacking replacement gambas3-gb-db-postgresql ...
Preparing to replace gambas3-gb-db-sqlite2 3.4.1-1lucid2 (using gambas3-gb-db-sqlite2_3.4.1-1lucid2_i386.deb) ...
Unpacking replacement gambas3-gb-db-sqlite2 ...
Preparing to replace gambas3-gb-db-sqlite3 3.4.1-1lucid2 (using gambas3-gb-db-sqlite3_3.4.1-1lucid2_i386.deb) ...
Unpacking replacement gambas3-gb-db-sqlite3 ...
Preparing to replace gambas3-gb-dbus 3.4.1-1lucid2 (using gambas3-gb-dbus_3.4.1-1lucid2_i386.deb) ...
Unpacking replacement gambas3-gb-dbus ...
Preparing to replace gambas3-gb-desktop 3.4.1-1lucid2 (using gambas3-gb-desktop_3.4.1-1lucid2_i386.deb) ...
Unpacking replacement gambas3-gb-desktop ...
Preparing to replace gambas3-gb-eval-highlight 3.4.1-1lucid2 (using gambas3-gb-eval-highlight_3.4.1-1lucid2_all.deb) ...
Unpacking replacement gambas3-gb-eval-highlight ...
Preparing to replace gambas3-gb-form 3.4.1-1lucid2 (using gambas3-gb-form_3.4.1-1lucid2_all.deb) ...
Unpacking replacement gambas3-gb-form ...
Preparing to replace gambas3-gb-form-dialog 3.4.1-1lucid2 (using gambas3-gb-form-dialog_3.4.1-1lucid2_all.deb) ...
Unpacking replacement gambas3-gb-form-dialog ...
Preparing to replace gambas3-gb-form-mdi 3.4.1-1lucid2 (using gambas3-gb-form-mdi_3.4.1-1lucid2_all.deb) ...
Unpacking replacement gambas3-gb-form-mdi ...
Preparing to replace gambas3-gb-form-stock 3.4.1-1lucid2 (using gambas3-gb-form-stock_3.4.1-1lucid2_all.deb) ...
Unpacking replacement gambas3-gb-form-stock ...
Preparing to replace gambas3-gb-gsl 3.4.1-1lucid2 (using gambas3-gb-gsl_3.4.1-1lucid2_i386.deb) ...
Unpacking replacement gambas3-gb-gsl ...
Preparing to replace gambas3-gb-gtk 3.4.1-1lucid2 (using gambas3-gb-gtk_3.4.1-1lucid2_i386.deb) ...
Unpacking replacement gambas3-gb-gtk ...
Preparing to replace gambas3-gb-gtk-opengl 3.4.1-1lucid2 (using gambas3-gb-gtk-opengl_3.4.1-1lucid2_i386.deb) ...
Unpacking replacement gambas3-gb-gtk-opengl ...
Preparing to replace gambas3-gb-gui 3.4.1-1lucid2 (using gambas3-gb-gui_3.4.1-1lucid2_i386.deb) ...
Unpacking replacement gambas3-gb-gui ...
Preparing to replace gambas3-gb-gui-opengl 3.4.1-1lucid2 (using gambas3-gb-gui-opengl_3.4.1-1lucid2_i386.deb) ...
Unpacking replacement gambas3-gb-gui-opengl ...
Preparing to replace gambas3-gb-httpd 3.4.1-1lucid2 (using gambas3-gb-httpd_3.4.1-1lucid2_i386.deb) ...
Unpacking replacement gambas3-gb-httpd ...
Preparing to replace gambas3-gb-image 3.4.1-1lucid2 (using gambas3-gb-image_3.4.1-1lucid2_i386.deb) ...
Unpacking replacement gambas3-gb-image ...
Preparing to replace gambas3-gb-image-effect 3.4.1-1lucid2 (using gambas3-gb-image-effect_3.4.1-1lucid2_i386.deb) ...
Unpacking replacement gambas3-gb-image-effect ...
Preparing to replace gambas3-gb-image-imlib 3.4.1-1lucid2 (using gambas3-gb-image-imlib_3.4.1-1lucid2_i386.deb) ...
Unpacking replacement gambas3-gb-image-imlib ...
Preparing to replace gambas3-gb-image-io 3.4.1-1lucid2 (using gambas3-gb-image-io_3.4.1-1lucid2_i386.deb) ...
Unpacking replacement gambas3-gb-image-io ...
Preparing to replace gambas3-gb-libxml 3.4.1-1lucid2 (using gambas3-gb-libxml_3.4.1-1lucid2_i386.deb) ...
Unpacking replacement gambas3-gb-libxml ...
Preparing to replace gambas3-gb-map 3.4.1-1lucid2 (using gambas3-gb-map_3.4.1-1lucid2_all.deb) ...
Unpacking replacement gambas3-gb-map ...
Preparing to replace gambas3-gb-memcached 3.4.1-1lucid2 (using gambas3-gb-memcached_3.4.1-1lucid2_all.deb) ...
Unpacking replacement gambas3-gb-memcached ...
Preparing to replace gambas3-gb-mime 3.4.1-1lucid2 (using gambas3-gb-mime_3.4.1-1lucid2_i386.deb) ...
Unpacking replacement gambas3-gb-mime ...
Preparing to replace gambas3-gb-mysql 3.4.1-1lucid2 (using gambas3-gb-mysql_3.4.1-1lucid2_i386.deb) ...
Unpacking replacement gambas3-gb-mysql ...
Preparing to replace gambas3-gb-ncurses 3.4.1-1lucid2 (using gambas3-gb-ncurses_3.4.1-1lucid2_i386.deb) ...
Unpacking replacement gambas3-gb-ncurses ...
Preparing to replace gambas3-gb-net 3.4.1-1lucid2 (using gambas3-gb-net_3.4.1-1lucid2_i386.deb) ...
Unpacking replacement gambas3-gb-net ...
Preparing to replace gambas3-gb-net-curl 3.4.1-1lucid2 (using gambas3-gb-net-curl_3.4.1-1lucid2_i386.deb) ...
Unpacking replacement gambas3-gb-net-curl ...
Preparing to replace gambas3-gb-net-pop3 3.4.1-1lucid2 (using gambas3-gb-net-pop3_3.4.1-1lucid2_i386.deb) ...
Unpacking replacement gambas3-gb-net-pop3 ...
Preparing to replace gambas3-gb-net-smtp 3.4.1-1lucid2 (using gambas3-gb-net-smtp_3.4.1-1lucid2_i386.deb) ...
Unpacking replacement gambas3-gb-net-smtp ...
Preparing to replace gambas3-gb-opengl 3.4.1-1lucid2 (using gambas3-gb-opengl_3.4.1-1lucid2_i386.deb) ...
Unpacking replacement gambas3-gb-opengl ...
Preparing to replace gambas3-gb-opengl-glsl 3.4.1-1lucid2 (using gambas3-gb-opengl-glsl_3.4.1-1lucid2_i386.deb) ...
Unpacking replacement gambas3-gb-opengl-glsl ...
Preparing to replace gambas3-gb-opengl-glu 3.4.1-1lucid2 (using gambas3-gb-opengl-glu_3.4.1-1lucid2_i386.deb) ...
Unpacking replacement gambas3-gb-opengl-glu ...
Preparing to replace gambas3-gb-option 3.4.1-1lucid2 (using gambas3-gb-option_3.4.1-1lucid2_i386.deb) ...
Unpacking replacement gambas3-gb-option ...
Preparing to replace gambas3-gb-pcre 3.4.1-1lucid2 (using gambas3-gb-pcre_3.4.1-1lucid2_i386.deb) ...
Unpacking replacement gambas3-gb-pcre ...
Preparing to replace gambas3-gb-pdf 3.4.1-1lucid2 (using gambas3-gb-pdf_3.4.1-1lucid2_i386.deb) ...
Unpacking replacement gambas3-gb-pdf ...
Preparing to replace gambas3-gb-qt4 3.4.1-1lucid2 (using gambas3-gb-qt4_3.4.1-1lucid2_i386.deb) ...
Unpacking replacement gambas3-gb-qt4 ...
Preparing to replace gambas3-gb-qt4-ext 3.4.1-1lucid2 (using gambas3-gb-qt4-ext_3.4.1-1lucid2_i386.deb) ...
Unpacking replacement gambas3-gb-qt4-ext ...
Preparing to replace gambas3-gb-qt4-opengl 3.4.1-1lucid2 (using gambas3-gb-qt4-opengl_3.4.1-1lucid2_i386.deb) ...
Unpacking replacement gambas3-gb-qt4-opengl ...
Preparing to replace gambas3-gb-qt4-webkit 3.4.1-1lucid2 (using gambas3-gb-qt4-webkit_3.4.1-1lucid2_i386.deb) ...
Unpacking replacement gambas3-gb-qt4-webkit ...
Preparing to replace gambas3-gb-report 3.4.1-1lucid2 (using gambas3-gb-report_3.4.1-1lucid2_all.deb) ...
Unpacking replacement gambas3-gb-report ...
Preparing to replace gambas3-gb-sdl 3.4.1-1lucid2 (using gambas3-gb-sdl_3.4.1-1lucid2_i386.deb) ...
Unpacking replacement gambas3-gb-sdl ...
Preparing to replace gambas3-gb-sdl-sound 3.4.1-1lucid2 (using gambas3-gb-sdl-sound_3.4.1-1lucid2_i386.deb) ...
Unpacking replacement gambas3-gb-sdl-sound ...
Preparing to replace gambas3-gb-settings 3.4.1-1lucid2 (using gambas3-gb-settings_3.4.1-1lucid2_all.deb) ...
Unpacking replacement gambas3-gb-settings ...
Preparing to replace gambas3-gb-signal 3.4.1-1lucid2 (using gambas3-gb-signal_3.4.1-1lucid2_i386.deb) ...
Unpacking replacement gambas3-gb-signal ...
Preparing to replace gambas3-gb-v4l 3.4.1-1lucid2 (using gambas3-gb-v4l_3.4.1-1lucid2_i386.deb) ...
Unpacking replacement gambas3-gb-v4l ...
Preparing to replace gambas3-gb-vb 3.4.1-1lucid2 (using gambas3-gb-vb_3.4.1-1lucid2_i386.deb) ...
Unpacking replacement gambas3-gb-vb ...
Preparing to replace gambas3-gb-web 3.4.1-1lucid2 (using gambas3-gb-web_3.4.1-1lucid2_all.deb) ...
Unpacking replacement gambas3-gb-web ...
Preparing to replace gambas3-gb-xml 3.4.1-1lucid2 (using gambas3-gb-xml_3.4.1-1lucid2_i386.deb) ...
Unpacking replacement gambas3-gb-xml ...
Preparing to replace gambas3-gb-xml-html 3.4.1-1lucid2 (using gambas3-gb-xml-html_3.4.1-1lucid2_i386.deb) ...
Unpacking replacement gambas3-gb-xml-html ...
Preparing to replace gambas3-gb-xml-rpc 3.4.1-1lucid2 (using gambas3-gb-xml-rpc_3.4.1-1lucid2_all.deb) ...
Unpacking replacement gambas3-gb-xml-rpc ...
Preparing to replace gambas3-gb-xml-xslt 3.4.1-1lucid2 (using gambas3-gb-xml-xslt_3.4.1-1lucid2_i386.deb) ...
Unpacking replacement gambas3-gb-xml-xslt ...
Preparing to replace gambas3-ide 3.4.1-1lucid2 (using gambas3-ide_3.4.1-1lucid2_all.deb) ...
Unpacking replacement gambas3-ide ...
Preparing to replace gambas3-runtime 3.4.1-1lucid2 (using gambas3-runtime_3.4.1-1lucid2_i386.deb) ...
Unpacking replacement gambas3-runtime ...
Preparing to replace gambas3-script 3.4.1-1lucid2 (using gambas3-script_3.4.1-1lucid2_all.deb) ...
Unpacking replacement gambas3-script ...
Setting up gambas3-dev (3.4.1-1lucid2) ...
Setting up gambas3-examples (3.4.1-1lucid2) ...
Setting up gambas3-gb-complex (3.4.1-1lucid2) ...
Setting up gambas3-gb-compress (3.4.1-1lucid2) ...
Setting up gambas3-gb-compress-bzlib2 (3.4.1-1lucid2) ...
Setting up gambas3-gb-compress-zlib (3.4.1-1lucid2) ...
Setting up gambas3-gb-crypt (3.4.1-1lucid2) ...
Setting up gambas3-gb-data (3.4.1-1lucid2) ...
dpkg: dependency problems prevent configuration of gambas3-gb-db-mysql:
gambas3-gb-db-mysql depends on libmysqlclient16 (>= 5.1.21-1); however:
Package libmysqlclient16 is not installed.
dpkg: error processing gambas3-gb-db-mysql (--install):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of gambas3-gb-db-odbc:
gambas3-gb-db-odbc depends on unixodbc (>= 2.2.11); however:
Package unixodbc is not installed.
dpkg: error processing gambas3-gb-db-odbc (--install):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of gambas3-gb-db-postgresql:
gambas3-gb-db-postgresql depends on libpq5 (>= 8.4~0cvs20090328); however:
Package libpq5 is not installed.
dpkg: error processing gambas3-gb-db-postgresql (--install):
dependency problems - leaving unconfigured
Setting up gambas3-gb-gsl (3.4.1-1lucid2) ...
dpkg: dependency problems prevent configuration of gambas3-gb-gtk-opengl:
gambas3-gb-gtk-opengl depends on libgtkglext1; however:
Package libgtkglext1 is not installed.
dpkg: error processing gambas3-gb-gtk-opengl (--install):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of gambas3-gb-gui-opengl:
gambas3-gb-gui-opengl depends on gambas3-gb-gtk-opengl (>= 3.4.1-1lucid2); however:
Package gambas3-gb-gtk-opengl is not configured yet.
dpkg: error processing gambas3-gb-gui-opengl (--install):
dependency problems - leaving unconfigured
Setting up gambas3-gb-httpd (3.4.1-1lucid2) ...
Setting up gambas3-gb-image (3.4.1-1lucid2) ...
Setting up gambas3-gb-image-effect (3.4.1-1lucid2) ...
dpkg: dependency problems prevent configuration of gambas3-gb-image-imlib:
gambas3-gb-image-imlib depends on libimlib2; however:
Package libimlib2 is not installed.
dpkg: error processing gambas3-gb-image-imlib (--install):
dependency problems - leaving unconfigured
Setting up gambas3-gb-image-io (3.4.1-1lucid2) ...
Setting up gambas3-gb-libxml (3.4.1-1lucid2) ...
Setting up gambas3-gb-mime (3.4.1-1lucid2) ...
dpkg: dependency problems prevent configuration of gambas3-gb-mysql:
gambas3-gb-mysql depends on gambas3-gb-db-mysql (>= 3.4.1-1lucid2); however:
Package gambas3-gb-db-mysql is not configured yet.
dpkg: error processing gambas3-gb-mysql (--install):
dependency problems - leaving unconfigured
Setting up gambas3-gb-ncurses (3.4.1-1lucid2) ...
Setting up gambas3-gb-net (3.4.1-1lucid2) ...
Setting up gambas3-gb-net-curl (3.4.1-1lucid2) ...
dpkg: dependency problems prevent configuration of gambas3-gb-opengl:
gambas3-gb-opengl depends on libglew1.5 (>= 1.5.2); however:
Package libglew1.5 is not installed.
dpkg: error processing gambas3-gb-opengl (--install):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of gambas3-gb-opengl-glsl:
gambas3-gb-opengl-glsl depends on libglew1.5 (>= 1.5.2); however:
Package libglew1.5 is not installed.
gambas3-gb-opengl-glsl depends on gambas3-gb-opengl (>= 3.4.1-1lucid2); however:
Package gambas3-gb-opengl is not configured yet.
dpkg: error processing gambas3-gb-opengl-glsl (--install):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of gambas3-gb-opengl-glu:
gambas3-gb-opengl-glu depends on gambas3-gb-opengl (>= 3.4.1-1lucid2); however:
Package gambas3-gb-opengl is not configured yet.
dpkg: error processing gambas3-gb-opengl-glu (--install):
dependency problems - leaving unconfigured
Setting up gambas3-gb-option (3.4.1-1lucid2) ...
Setting up gambas3-gb-pcre (3.4.1-1lucid2) ...
Setting up gambas3-gb-pdf (3.4.1-1lucid2) ...
dpkg: dependency problems prevent configuration of gambas3-gb-qt4:
gambas3-gb-qt4 depends on libqt4-network (>= 4:4.5.3); however:
Package libqt4-network is not installed.
gambas3-gb-qt4 depends on libqt4-qt3support (>= 4:4.5.3); however:
Package libqt4-qt3support is not installed.
gambas3-gb-qt4 depends on libqt4-sql (>= 4:4.5.3); however:
Package libqt4-sql is not installed.
gambas3-gb-qt4 depends on libqt4-svg (>= 4:4.5.3); however:
Package libqt4-svg is not installed.
gambas3-gb-qt4 depends on libqtcore4 (>= 4:4.6.1); however:
Package libqtcore4 is not installed.
gambas3-gb-qt4 depends on libqtgui4 (>= 4:4.6.1); however:
Package libqtgui4 is not installed.
dpkg: error processing gambas3-gb-qt4 (--install):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of gambas3-gb-qt4-ext:
gambas3-gb-qt4-ext depends on libqt4-network (>= 4:4.5.3); however:
Package libqt4-network is not installed.
gambas3-gb-qt4-ext depends on libqt4-qt3support (>= 4:4.5.3); however:
Package libqt4-qt3support is not installed.
gambas3-gb-qt4-ext depends on libqt4-sql (>= 4:4.5.3); however:
Package libqt4-sql is not installed.
gambas3-gb-qt4-ext depends on libqtcore4 (>= 4:4.6.1); however:
Package libqtcore4 is not installed.
gambas3-gb-qt4-ext depends on libqtgui4 (>= 4:4.5.3); however:
Package libqtgui4 is not installed.
gambas3-gb-qt4-ext depends on gambas3-gb-qt4 (>= 3.4.1-1lucid2); however:
Package gambas3-gb-qt4 is not configured yet.
dpkg: error processing gambas3-gb-qt4-ext (--install):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of gambas3-gb-qt4-opengl:
gambas3-gb-qt4-opengl depends on libqt4-network (>= 4:4.5.3); however:
Package libqt4-network is not installed.
gambas3-gb-qt4-opengl depends on libqt4-opengl (>= 4:4.5.3); however:
Package libqt4-opengl is not installed.
gambas3-gb-qt4-opengl depends on libqt4-qt3support (>= 4:4.5.3); however:
Package libqt4-qt3support is not installed.
gambas3-gb-qt4-opengl depends on libqt4-sql (>= 4:4.5.3); however:
Package libqt4-sql is not installed.
gambas3-gb-qt4-opengl depends on libqt4-svg (>= 4:4.5.3); however:
Package libqt4-svg is not installed.
gambas3-gb-qt4-opengl depends on libqtcore4 (>= 4:4.5.3); however:
Package libqtcore4 is not installed.
gambas3-gb-qt4-opengl depends on libqtgui4 (>= 4:4.5.3); however:
Package libqtgui4 is not installed.
gambas3-gb-qt4-opengl depends on gambas3-gb-opengl (>= 3.4.1-1lucid2); however:
Package gambas3-gb-opengl is not configured yet.
gambas3-gb-qt4-opengl depends on gambas3-gb-qt4 (>= 3.4.1-1lucid2); however:
Package gambas3-gb-qt4 is not configured yet.
dpkg: error processing gambas3-gb-qt4-opengl (--install):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of gambas3-gb-qt4-webkit:
gambas3-gb-qt4-webkit depends on libqt4-dbus (>= 4:4.5.3); however:
Package libqt4-dbus is not installed.
gambas3-gb-qt4-webkit depends on libqt4-network (>= 4:4.5.3); however:
Package libqt4-network is not installed.
gambas3-gb-qt4-webkit depends on libqt4-webkit (>= 4:4.6.1); however:
Package libqt4-webkit is not installed.
gambas3-gb-qt4-webkit depends on libqt4-xml (>= 4:4.5.3); however:
Package libqt4-xml is not installed.
gambas3-gb-qt4-webkit depends on libqtcore4 (>= 4:4.6.1); however:
Package libqtcore4 is not installed.
gambas3-gb-qt4-webkit depends on libqtgui4 (>= 4:4.5.3); however:
Package libqtgui4 is not installed.
gambas3-gb-qt4-webkit depends on gambas3-gb-qt4 (>= 3.4.1-1lucid2); however:
Package gambas3-gb-qt4 is not configured yet.
dpkg: error processing gambas3-gb-qt4-webkit (--install):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of gambas3-gb-sdl:
gambas3-gb-sdl depends on libglew1.5 (>= 1.5.2); however:
Package libglew1.5 is not installed.
gambas3-gb-sdl depends on libsdl-ttf2.0-0; however:
Package libsdl-ttf2.0-0 is not installed.
dpkg: error processing gambas3-gb-sdl (--install):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of gambas3-gb-sdl-sound:
gambas3-gb-sdl-sound depends on libsdl-mixer1.2 (>= 1.2.6); however:
Package libsdl-mixer1.2 is not installed.
dpkg: error processing gambas3-gb-sdl-sound (--install):
dependency problems - leaving unconfigured
Setting up gambas3-gb-signal (3.4.1-1lucid2) ...
Setting up gambas3-gb-v4l (3.4.1-1lucid2) ...
Setting up gambas3-gb-vb (3.4.1-1lucid2) ...
dpkg: dependency problems prevent configuration of gambas3-ide:
gambas3-ide depends on debhelper; however:
Package debhelper is not installed.
gambas3-ide depends on fakeroot; however:
Package fakeroot is not installed.
gambas3-ide depends on gambas3-gb-qt4-ext (>= 3.4.1-1lucid2); however:
Package gambas3-gb-qt4-ext is not configured yet.
gambas3-ide depends on gambas3-gb-qt4-webkit (>= 3.4.1-1lucid2); however:
Package gambas3-gb-qt4-webkit is not configured yet.
dpkg: error processing gambas3-ide (--install):
dependency problems - leaving unconfigured
Setting up gambas3-runtime (3.4.1-1lucid2) ...
dpkg: dependency problems prevent configuration of gambas3:
gambas3 depends on gambas3-gb-db-odbc (>= 3.4.1-1lucid2); however:
Package gambas3-gb-db-odbc is not configured yet.
gambas3 depends on gambas3-gb-db-postgresql (>= 3.4.1-1lucid2); however:
Package gambas3-gb-db-postgresql is not configured yet.
gambas3 depends on gambas3-gb-gui-opengl (>= 3.4.1-1lucid2); however:
Package gambas3-gb-gui-opengl is not configured yet.
gambas3 depends on gambas3-gb-image-imlib (>= 3.4.1-1lucid2); however:
Package gambas3-gb-image-imlib is not configured yet.
gambas3 depends on gambas3-gb-mysql (>= 3.4.1-1lucid2); however:
Package gambas3-gb-mysql is not configured yet.
gambas3 depends on gambas3-gb-opengl-glsl (>= 3.4.1-1lucid2); however:
Package gambas3-gb-opengl-glsl is not configured yet.
gambas3 depends on gambas3-gb-opengl-glu (>= 3.4.1-1lucid2); however:
Package gambas3-gb-opengl-glu is not configured yet.
gambas3 depends on gambas3-gb-sdl (>= 3.4.1-1lucid2); however:
Package gambas3-gb-sdl is not configured yet.
gambas3 depends on gambas3-gb-sdl-sound (>= 3.4.1-1lucid2); however:
Package gambas3-gb-sdl-sound is not configured yet.
gambas3 depends on gambas3-ide (>= 3.4.1-1lucid2); however:
Package gambas3-ide is not configured yet.
dpkg: error processing gambas3 (--install):
dependency problems - leaving unconfigured
Setting up gambas3-gb-cairo (3.4.1-1lucid2) ...
dpkg: dependency problems prevent configuration of gambas3-gb-chart:
gambas3-gb-chart depends on gambas3-gb-qt4-ext (>= 3.4.1-1lucid2); however:
Package gambas3-gb-qt4-ext is not configured yet.
dpkg: error processing gambas3-gb-chart (--install):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of gambas3-gb-desktop:
gambas3-gb-desktop depends on gambas3-gb-qt4 (>= 3.4.1-1lucid2); however:
Package gambas3-gb-qt4 is not configured yet.
dpkg: error processing gambas3-gb-desktop (--install):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of gambas3-gb-eval-highlight:
gambas3-gb-eval-highlight depends on gambas3-gb-qt4-ext (>= 3.4.1-1lucid2); however:
Package gambas3-gb-qt4-ext is not configured yet.
dpkg: error processing gambas3-gb-eval-highlight (--install):
dependency problems - leaving unconfigured
Setting up gambas3-gb-gtk (3.4.1-1lucid2) ...
dpkg: dependency problems prevent configuration of gambas3-gb-gui:
gambas3-gb-gui depends on gambas3-gb-qt4 (>= 3.4.1-1lucid2); however:
Package gambas3-gb-qt4 is not configured yet.
dpkg: error processing gambas3-gb-gui (--install):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of gambas3-gb-memcached:
gambas3-gb-memcached depends on gambas3-gb-gui (>= 3.4.1-1lucid2); however:
Package gambas3-gb-gui is not configured yet.
dpkg: error processing gambas3-gb-memcached (--install):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of gambas3-gb-form:
gambas3-gb-form depends on gambas3-gb-gui (>= 3.4.1-1lucid2); however:
Package gambas3-gb-gui is not configured yet.
dpkg: error processing gambas3-gb-form (--install):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of gambas3-gb-form-dialog:
gambas3-gb-form-dialog depends on gambas3-gb-form (>= 3.4.1-1lucid2); however:
Package gambas3-gb-form is not configured yet.
dpkg: error processing gambas3-gb-form-dialog (--install):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of gambas3-gb-form-mdi:
gambas3-gb-form-mdi depends on gambas3-gb-form (>= 3.4.1-1lucid2); however:
Package gambas3-gb-form is not configured yet.
dpkg: error processing gambas3-gb-form-mdi (--install):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of gambas3-gb-form-stock:
gambas3-gb-form-stock depends on gambas3-gb-form (>= 3.4.1-1lucid2); however:
Package gambas3-gb-form is not configured yet.
dpkg: error processing gambas3-gb-form-stock (--install):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of gambas3-gb-report:
gambas3-gb-report depends on gambas3-gb-form (>= 3.4.1-1lucid2); however:
Package gambas3-gb-form is not configured yet.
dpkg: error processing gambas3-gb-report (--install):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of gambas3-gb-db-form:
gambas3-gb-db-form depends on gambas3-gb-form (>= 3.4.1-1lucid2); however:
Package gambas3-gb-form is not configured yet.
dpkg: error processing gambas3-gb-db-form (--install):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of gambas3-gb-map:
gambas3-gb-map depends on gambas3-gb-db-form (>= 3.4.1-1lucid2); however:
Package gambas3-gb-db-form is not configured yet.
dpkg: error processing gambas3-gb-map (--install):
dependency problems - leaving unconfigured
Processing triggers for shared-mime-info ...
Processing triggers for man-db ...
Processing triggers for hicolor-icon-theme ...
Setting up gambas3-script (3.4.1-1lucid2) ...
Setting up gambas3-gb-args (3.4.1-1lucid2) ...
Setting up gambas3-gb-db (3.4.1-1lucid2) ...
Setting up gambas3-gb-db-sqlite2 (3.4.1-1lucid2) ...
Setting up gambas3-gb-db-sqlite3 (3.4.1-1lucid2) ...
Setting up gambas3-gb-dbus (3.4.1-1lucid2) ...
Setting up gambas3-gb-net-pop3 (3.4.1-1lucid2) ...
Setting up gambas3-gb-net-smtp (3.4.1-1lucid2) ...
Setting up gambas3-gb-settings (3.4.1-1lucid2) ...
Setting up gambas3-gb-web (3.4.1-1lucid2) ...
Setting up gambas3-gb-xml (3.4.1-1lucid2) ...
Setting up gambas3-gb-xml-html (3.4.1-1lucid2) ...
Setting up gambas3-gb-xml-rpc (3.4.1-1lucid2) ...
Setting up gambas3-gb-xml-xslt (3.4.1-1lucid2) ...
Processing triggers for desktop-file-utils ...
Processing triggers for python-gmenu ...
Rebuilding /usr/share/applications/desktop.en_US.utf8.cache...
Processing triggers for python-support ...
Errors were encountered while processing:
gambas3-gb-db-mysql
gambas3-gb-db-odbc
gambas3-gb-db-postgresql
gambas3-gb-gtk-opengl
gambas3-gb-gui-opengl
gambas3-gb-image-imlib
gambas3-gb-mysql
gambas3-gb-opengl
gambas3-gb-opengl-glsl
gambas3-gb-opengl-glu
gambas3-gb-qt4
gambas3-gb-qt4-ext
gambas3-gb-qt4-opengl
gambas3-gb-qt4-webkit
gambas3-gb-sdl
gambas3-gb-sdl-sound
gambas3-ide
gambas3
gambas3-gb-chart
gambas3-gb-desktop
gambas3-gb-eval-highlight
gambas3-gb-gui
gambas3-gb-memcached
gambas3-gb-form
gambas3-gb-form-dialog
gambas3-gb-form-mdi
gambas3-gb-form-stock
gambas3-gb-report
gambas3-gb-db-form
gambas3-gb-map
hendryawan@ubuntu:~$
=====================================================

Bingung aku.....apa yang harus saya lakukan lagi?
please bantu saya...
thank

hen
User avatar
offline
Posts: 2672
Joined: 17 Feb 2010, 21:03
Location: Kebumen

Re: aplikasi gambas3

Postby offline » 02 Jun 2013, 16:15

melihat sekilas errornya tampak pada dependensinya.
mungkin ubuntunya si om perlu diupgrade semua packagesnya sedangkan ubuntu desktop 10.04 sudah berakhir masa LTSnya.
cmiiw
User avatar
ounowey
Posts: 30
Joined: 29 Sep 2012, 20:19
Location: karawang, indonesia
Contact:

Re: aplikasi gambas3

Postby ounowey » 16 Jun 2013, 11:18

kawan, ngonekin form-form gimana? biar nilai objek disatu form bisa dibaca di form lainnya.. makasih
User avatar
henel
Posts: 20
Joined: 14 Nov 2011, 10:55

Re: aplikasi gambas3

Postby henel » 21 Jun 2013, 12:34

Kalau pingin variable bisa di baca di form yang lain, buat module baru misal namanya "test" dan diisi variable misal PUBLIC var1 as Integer.
Dalam program class tinggal menggunakan variable name test.var1 untuk digunakan. itu yang saya lakukan untuk sharing variable antar form :D

Return to “Aplikasi Ubuntu”

Who is online

Users browsing this forum: No registered users and 6 guests