[SOLVED] setting modem Haier CE682 blom berhasil

Membahas Perangkat-perangkat keras yang belum dideteksi dengan baik oleh Ubuntu serta solusinya.
User avatar
panghaidar
Posts: 10
Joined: 20 Feb 2013, 00:13

[SOLVED] setting modem Haier CE682 blom berhasil

Postby panghaidar » 20 Feb 2013, 10:13

Permisi mastah2 Ubuntu, newbie butuh bantuan setting modem di ubuntu 12.04, laptop ane HP 520. ane udah nyobain berbagai cara and sumber tapi hasil output dari terminal gak sesuai dengan tutorial mereka. Berikut ane posting hasil output dari terminal dan isiannya. makasih sebelumnnya :)

1.$ lsusb

Code: Select all

Bus 002 Device 002: ID 046d:c052 Logitech, Inc.
Bus 002 Device 003: ID 201e:1022  (klo di lsusb tapi modem dicopot,ini ilang)
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub


2. ~$ sudo eject /dev/sr1 trs lsusb output sama kyk dipoin 1
3. ~$ dmesg | tail
Tampilkan

Code: Select all

[ 1780.416097] usb 2-1: new full-speed USB device number 14 using uhci_hcd
[ 1780.579433] usb 2-1: New USB device found, idVendor=201e, idProduct=1022
[ 1780.579440] usb 2-1: New USB device strings: Mfr=1, Product=2, SerialNumber=11
[ 1780.579444] usb 2-1: Product: CBP7.1
[ 1780.579448] usb 2-1: Manufacturer: China TeleCom
[ 1780.579451] usb 2-1: SerialNumber: \xffffffc3\xffffffbf\xffffffbf\xffffffc3\xffffffbf\xffffffbf\xffffffc3\xffffffbf\xffffffbf\xffffffc3\xffffffbf\xffffffbf\xffffffc3\xffffffbf\xffffffbf\xffffffc3\xffffffbf\xffffffbf\xffffffc3\xffffffbf\xffffffbf\xffffffc3\xffffffbf\xffffffbf\xffffffc3\xffffffbf\xffffffbf\xffffffc3\xffffffbf\xffffffbf
[ 1780.595742] scsi10 : usb-storage 2-1:1.3
[ 1781.600478] scsi 10:0:0:0: Direct-Access     SDVDISK  EVDO ReV A       7.00 PQ: 0 ANSI: 0 CCS
[ 1781.605142] sd 10:0:0:0: Attached scsi generic sg2 type 0
[ 1781.614463] sd 10:0:0:0: [sdb] Attached SCSI removable disk


4. ~$ sudo gedit /etc/usb_modeswitch.conf
ane isi
Tampilkan

Code: Select all

# Configuration for the usb_modeswitch package, a mode switching tool for
# USB devices providing multiple states or modes
#
# Evaluated by the wrapper script /usr/sbin/usb_modeswitch_dispatcher
#
# To enable an option, set it to "1", "yes" or "true" (case doesn't matter)
# Everything else counts as "disable"


# Disable automatic mode switching globally (e.g. to access the original
# install storage)

DisableSwitching=0


# Enable logging (results in a extensive report file in /var/log, named
# "usb_modeswitch_<interface-name>" and probably others

EnableLogging=0
# /etc/usb_modeswitch.conf
#
# Smart Haier CE682 (EVDO)
#
DefaultVendor = 0x201e
DefaultProduct = 0�1022
TargetVendor = 00x201e
TargetProduct = 0�1022
MessageContent=�5553424312345678c00000008000069f030000000000000000000000000000′′


5. ~$ sudo /etc/udev/rules.d/99-zte-ce682.rules

ane isi:

Tampilkan

Code: Select all

# /etc/udev/rules.d/99-zte-ce682.rules
#
# Smart Haier CE682 (EVDO)
#
SUBSYSTEM==�usb�, SYSFS{idVendor}==�201e�,
SYSFS{idProduct}==�1022′′, RUN+=�/usr/sbin/usb_modeswitch �default-vendor 0x201e �default-product 0�1022 �message-content 5553424312345678c00000008000069f030000000000000000000000000000′′


6. $ sudo modprobe usbserial vendor=0x201e product=0x1022
FATAL: Error inserting usbserial (/lib/modules/3.5.0-23-generic/kernel/drivers/usb/serial/usbserial.ko): Invalid argument

7. ~$ sudo wvdialconf

Code: Select all

Editing `/etc/wvdial.conf'.

Scanning your serial ports for a modem.

Modem Port Scan<*1>: S0   S1   S2   S3   S4   S5   S6   S7   
Modem Port Scan<*1>: S8   S9   S10  S11  S12  S13  S14  S15 
Modem Port Scan<*1>: S16  S17  S18  S19  S20  S21  S22  S23 
Modem Port Scan<*1>: S24  S25  S26  S27  S28  S29  S30  S31 


Sorry, no modem was detected!  Is it in use by another program?
Did you configure it properly with setserial?


8. ~$ sudo gedit /etc/wvdial.conf

Code: Select all

[Dialer smart]
Init1 = ATZ
Init2 = ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
Stupid Mode = 1
Modem Type = Analog Modem
Command Line = ATDT
ISDN = 0
New PPPD = yes
Phone = #777
Modem = /dev/ttyUSB0
Username = smart
Password = smart
Baud = 460800


9. ~$sudo wvdial smart

Code: Select all

wvdial smart
--> WvDial: Internet dialer version 1.61
--> Cannot open /dev/ttyUSB0: No such file or directory
--> Cannot open /dev/ttyUSB0: No such file or directory
--> Cannot open /dev/ttyUSB0: No such file or directory




Image
Last edited by panghaidar on 27 Feb 2016, 21:34, edited 1 time in total.
Reason: solved
User avatar
Malsasa
Posts: 2974
Joined: 07 Jun 2010, 22:37
Location: Mojokerto, Indonesia
Contact:

Re: HELP!5hari setting modem Haier CE682 blom berhasil

Postby Malsasa » 20 Feb 2013, 10:23

Masya Allah, Anda sabar sekali. Coba saya bantu:

Setahu saya, inti permasalahan di sini, modem Anda tidak ditemukan berada di ttyUSB0. CMIIW.

Code: Select all

Cannot open /dev/ttyUSB0: No such file or directory


Itu buktinya.

Intinya, si modem kudu dideteksi berada pastinya di ttyUSB mana (0/1/2/3).

Apakah akang sudah mencari berkas bernama smarpret.tar.gz di Google? Saya instal CE682 pakai aplikasi itu di 12.04, lancar. Bisa ngenet dan nggak ribet sama sekali.

Saya harap akang tidak menyerah....

:grin:
User avatar
panghaidar
Posts: 10
Joined: 20 Feb 2013, 00:13

Re: HELP!5hari setting modem Haier CE682 blom berhasil

Postby panghaidar » 20 Feb 2013, 10:37

[quote=Malsasa]Masya Allah, Anda sabar sekali. Coba saya bantu:

Setahu saya, inti permasalahan di sini, modem Anda tidak ditemukan berada di ttyUSB0. CMIIW.

Code: Select all

Cannot open /dev/ttyUSB0: No such file or directory


Itu buktinya.

Intinya, si modem kudu dideteksi berada pastinya di ttyUSB mana (0/1/2/3).

Apakah akang sudah mencari berkas bernama smarpret.tar.gz di Google? Saya instal CE682 pakai aplikasi itu di 12.04, lancar. Bisa ngenet dan nggak ribet sama sekali.

Saya harap akang tidak menyerah....

:grin:

klo nyerah engga om krna udh sifat ku #cliiinngg! :))
ane coba dlu om makasih banget