cara setting agar NAT pada mikrotik ter-disable

Pertanyaan umum seputar distribusi Ubuntu yang menjadi distro wajib members ubuntu-indonesia.com
User avatar
ajma
Posts: 36
Joined: 31 Dec 2012, 01:38

cara setting agar NAT pada mikrotik ter-disable

Postby ajma » 03 Feb 2013, 22:20

saya ingin menanyakan gmn cara seting ubuntu server supaya nat Tranparen proxy terdisable otomatis pda saat mati lampu dan aktif kembali pada saat lampu dihidupkan,,,karena proxy saya sering eror karena lampu sering mati hidup..
Mohon bantuannya para master,,
User avatar
q_p
Posts: 3109
Joined: 14 Oct 2012, 13:01
Contact:

Re: cara setting agar NAT pada mikrotik ter-disable

Postby q_p » 03 Feb 2013, 22:52

Ini urusannya di mikrotik mas, bukan di ubuntu server yang mati karena listrik padam.
"Skeneraio 1 "
Prinsipnya anda buat skrip/rules di mikrotik yang melakukan =
1. Ping secara reguler dalam interval tertentu ke Ubuntu server
2. Jika ada reply (berarti listrik nyala) mikrotik tetap menjalan rule "tranparent proxy"
3. Jika tdk ada reply dari ubuntu-server (berarti listrik padam) mikrotik akan menjalan rules "disable tranparent proxy"
tapi cara ini menurut saya masih kurang sreg.
"Skenario2"
1. Sediakan satu alat misalnya AP yang nyala terus kecuali listrik padam.
2. Siapkan UPS untuk ubuntu server, sehingga ketika listrik padam ubuntu masih bisa menjalankan "skrip auto shutdown". Untuk mengurangi dampak kerusakan HDD. Cara kerja skrip ini sama dengan yang di atas, hanya obyek yang di ping adalah AP tadi dan yang di eksekusi adalah shutdown -h now.

Code: Select all

#!/bin/sh

ersa11="192.168.0.111"    #ip AP sesuaikan

ALIVE=0
for IP in $ersa11; do
ping -q -c1 -w5 $IP
if [ $? -eq 0 ]; then
ALIVE=1
echo "$IP is alive: $(date)" >> /var/log/shutdown.log
break
fi
done

if [ $ALIVE -eq 0 ]; then
echo "***ShutDown*** $(date)" >>  /var/log/shutdown.log
echo "###########################" >>  /var/log/shutdown.log
/sbin/shutdown -h now
fi

3. Buat skrip seperti dimaksud di skenerio1 di mikrotik dengan obyek ping ke AP.
User avatar
bellec
Posts: 104
Joined: 04 Aug 2011, 02:07
Location: indonesia

Re: cara setting agar NAT pada mikrotik ter-disable

Postby bellec » 27 Aug 2013, 13:37

script ini ("Skenario2") apakah langsung jalan apabila kehilangan reply dari AP mas ? atau masih ada perintah lain setelah buat script ini ?
User avatar
q_p
Posts: 3109
Joined: 14 Oct 2012, 13:01
Contact:

Re: cara setting agar NAT pada mikrotik ter-disable

Postby q_p » 27 Aug 2013, 17:02

bellec wrote:script ini ("Skenario2") apakah langsung jalan apabila kehilangan reply dari AP mas ? atau masih ada perintah lain setelah buat script ini ?

Bisa mas dan harap di catat ya, script tsb bukan untuk mem-bypass nat ya.
User avatar
bellec
Posts: 104
Joined: 04 Aug 2011, 02:07
Location: indonesia

Re: cara setting agar NAT pada mikrotik ter-disable

Postby bellec » 27 Aug 2013, 23:26

sudah saya coba mas tapi nga jalan mas, dimana letak kesalahan saya mas Pragola_pati ? :confused:
User avatar
q_p
Posts: 3109
Joined: 14 Oct 2012, 13:01
Contact:

Re: cara setting agar NAT pada mikrotik ter-disable

Postby q_p » 28 Aug 2013, 00:59

bellec wrote:sudah saya coba mas tapi nga jalan mas, dimana letak kesalahan saya mas Pragola_pati ? :confused:

Begini saja =
  1. Buat file baru dengan nama shutdown_pln.sh dan simpan di /opt

    Code: Select all

    ~#nano /opt/shutdown_pln.sh
    kopikan skrip tsb. baris "[color:#660000]ersa11="192.168.0.111" #ip AP sesuaikan[/color]" bisa anda ganti dengan perangkat lain atau komputer yang ber-ip dan mati pada saat pln mati.
  2. Agar bisa di-eksekusi =

    Code: Select all

    ~#chmod +x /opt/shutdown_pln.sh
  3. Masukkan path file tsb ke crontab, atur agar setiap interval "sekian menit" meng-eksekusi "/opt/shutdown_pln.sh"
  4. restart mesin anda
  5. untuk melakukan test, matikan alat yang disebutkan dalam baris "[color:#660000]ersa11="192.168.0.111" #ip AP sesuaikan[/color]".
User avatar
bellec
Posts: 104
Joined: 04 Aug 2011, 02:07
Location: indonesia

Re: cara setting agar NAT pada mikrotik ter-disable

Postby bellec » 28 Aug 2013, 02:33

terimakasih untuk waktunya mas, sebelum dapat petunjuk dari mas diatas, saya mencoba seperti ini
mas Pragola_Pati, tapi tanpa dicabut alat yang di ping, server
tetap mati dalam waktu yang ditentukan dengan crontab

cd /root
nano shutdown.sh

Code: Select all

#!/bin/sh

bullet="192.168.100.2"   

ALIVE=0
for IP in $bullet; do
ping -q -c1 -w5 $IP
if [ $? -eq 0 ]; then
ALIVE=1
echo "$IP is alive: $(date)" >> /var/log/shutdown.log
break
fi
done

if [ $ALIVE -eq 0 ]; then
echo "***ShutDown*** $(date)" >>  /var/log/shutdown.log
echo "###########################" >>  /var/log/shutdown.log
/sbin/shutdown -h now
fi


ubah permission dengan perintah ini
chmod +x /root/shutdown.sh

saya masukan script ini ke crontab -e
Tampilkan
0,2,4,6,8,10,12,14,16,18,20,22,24,26,28,30,32,34,38,40,42,44,46,48,50,52,54,56,58 * * * * /root/shutdown.sh


tapi masalahnya setiap 2 menit langsung shutdown mesinnya, sementara ini untuk crontabnya saya hapus mas, agar tidak jalan
mohon dibantu lagi mas dimana letak kesalahannya, :confused:
o ya saya melihat dari link ini mas here
User avatar
q_p
Posts: 3109
Joined: 14 Oct 2012, 13:01
Contact:

Re: cara setting agar NAT pada mikrotik ter-disable

Postby q_p » 28 Aug 2013, 05:23

crontab -nya =

Code: Select all

*/2 * * * *     sh /root/shutdown.sh
jika dalam interval 2 menit.

Code: Select all

*/5 * * * *     sh /root/shutdown.sh
jika dalam interval 5 menit.
Coba jalankan scrip tsb dalam keadaan bullet hidup. hasilnya harusnya seperti ini dan proxy anda tetap nyala=

Code: Select all

PING 192.168.100.2 (192.168.100.2) 56(84) bytes of data.

--- 192.168.100.2 ping statistics ---
1 packets transmitted, 1 received, 0% packet loss, time 0ms
rtt min/avg/max/mdev = 0.151/0.151/0.151/0.000 ms

Jika bullet anda matikan, hasilnya seperti di bawah ini dan proxy anda ikut mati =

Code: Select all

PING 192.168.100.2 (192.168.100.2) 56(84) bytes of data.

--- 192.168.100.2 ping statistics ---
5 packets transmitted, 0 received, 100% packet loss, time 4000ms
User avatar
bellec
Posts: 104
Joined: 04 Aug 2011, 02:07
Location: indonesia

Re: cara setting agar NAT pada mikrotik ter-disable

Postby bellec » 28 Aug 2013, 14:09

Tampilkan
64 bytes from 192.168.100.2: icmp_req=8 ttl=63 time=0.504 ms
64 bytes from 192.168.100.2: icmp_req=9 ttl=63 time=0.506 ms
64 bytes from 192.168.100.2: icmp_req=10 ttl=63 time=0.550 ms
64 bytes from 192.168.100.2: icmp_req=11 ttl=63 time=0.473 ms
^C
--- 192.168.100.2 ping statistics ---
11 packets transmitted, 10 received, 9% packet loss, time 10006ms
rtt min/avg/max/mdev = 0.473/0.585/1.095/0.180 ms

seperti ini mas kalau saya coba ping ke AP nya ! :confused:
sepertinya ada yg salah.
User avatar
q_p
Posts: 3109
Joined: 14 Oct 2012, 13:01
Contact:

Re: cara setting agar NAT pada mikrotik ter-disable

Postby q_p » 28 Aug 2013, 14:30

Code: Select all

~# ping -q -c1 -w5 192.168.100.2
Dengan perintah di atas bagaimana hasilnya ?
User avatar
bellec
Posts: 104
Joined: 04 Aug 2011, 02:07
Location: indonesia

Re: cara setting agar NAT pada mikrotik ter-disable

Postby bellec » 28 Aug 2013, 21:17

ini hasilnya mas :D
Tampilkan
PING 192.168.100.2 (192.168.100.2) 56(84) bytes of data.

--- 192.168.100.2 ping statistics ---
2 packets transmitted, 1 received, 50% packet loss, time 1007ms
rtt min/avg/max/mdev = 6.101/6.101/6.101/0.000 ms
User avatar
q_p
Posts: 3109
Joined: 14 Oct 2012, 13:01
Contact:

Re: cara setting agar NAT pada mikrotik ter-disable

Postby q_p » 28 Aug 2013, 22:36

Menurut saya tidak ada masalah pada skrip-nya. coba anda ganti ping-target dengan alat lain, sehingga diperoleh '0% packet loss'
User avatar
bellec
Posts: 104
Joined: 04 Aug 2011, 02:07
Location: indonesia

Re: cara setting agar NAT pada mikrotik ter-disable

Postby bellec » 04 Sep 2013, 21:13

solved Mas Pragola_Pati, saya ganti ke Modem deteksinya
terimakasih bimbingannya Mas :D
Tampilkan
--- 192.168.10.1 ping statistics ---
7 packets transmitted, 7 received, 0% packet loss, time 6002ms
rtt min/avg/max/mdev = 0.863/0.931/1.118/0.089 ms

Return to “Pertanyaan Umum”

Who is online

Users browsing this forum: No registered users and 9 guests