mohon bantuan "ERROR DI LINUX MINT"

Pertanyaan umum seputar distribusi Ubuntu yang menjadi distro wajib members ubuntu-indonesia.com
User avatar
kouzoku
Posts: 8
Joined: 29 Jan 2013, 10:52

mohon bantuan "ERROR DI LINUX MINT"

Postby kouzoku » 29 Jan 2013, 11:37

agan2 sekalian mohon maaf sebelumnya kalau ada yg salah.

saya lagi belajar linux, saat ini linux yang terpakai di saya adalah linux mint 32 bit cinnamon. saya ingin bertanya beberapa hal kalau anda mau membantu.

1. lebih baik mana linux mint 32 atau 64? versi?

2. beberapa hari yg lalu saya mendownload gwget-1.0.4.tar.gz
Kemudian saya extrac dan lanjutkan ./configure hasilnya tanpa error. saat saya make dan make install itu errornya muncul seperti ini:


/usr/include/glib-2.0/glib/gerror.h:22:2: error: #error "Only can be included directly."
In file included from main.c:28:0:
main_window.h:56:24: warning: �dragtypes� defined but not used [-Wunused-variable]
make[3]: *** [main.o] Error 1
make[3]: Leaving directory `/home/andika/Downloads/gwget-1.0.4/src'
make[2]: *** [all] Error 2
make[2]: Leaving directory `/home/andika/Downloads/gwget-1.0.4/src'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/home/andika/Downloads/gwget-1.0.4'
make: *** [all] Error 2

apakah yg harus saya lakukan? apa masih ada beberapa library atau tools yg kurang? modul2 mungkin?
error di atas terjadi tidak hanya di gwget saja, tapi terjadi saat saya ingin menginstall.


3. saya harus memasang applikasi, tools, lib apa saja agar berjalan tanpa bug di linux mint nadia 14.

maaf OS yg saya pakai untuk kegiatan sehari2 sebelumnya punya Microso....t

mohon pencerahannya dari anda. Terima kasih jika ada yang mau membantu

Salam dari warga baru
User avatar
Alakulihal
Posts: 233
Joined: 04 Sep 2012, 11:43
Location: Riau paling pojok dan pelosok
Contact:

Re: mohon bantuan "ERROR DI LINUX MINT"

Postby Alakulihal » 29 Jan 2013, 12:37

gag ngerti. yg dibawah mungkin tau.
User avatar
nif
Posts: 2817
Joined: 31 Mar 2011, 07:48

Re: mohon bantuan "ERROR DI LINUX MINT"

Postby nif » 29 Jan 2013, 12:52

coba jawab;
1. sesuaikan tipe prosesor dan besar RAM. Kalo prosesornya mendukung dan RAM cukup besar, pake 64 bit aja. Versi ; saya lebih prefer 13.
2 & 3 Yang om kouzoku lakukan adalah compile program dari source code. Memang cukup susah dan butuh tool&lib yang berbeda-beda tergantung kebutuhan programnya. Kalo niatnya cuma mau pasang aplikasi, tak perlu compile sendiri. Pake yang versi .deb aja, tinggal pasang :smile:

cmiiw
User avatar
kouzoku
Posts: 8
Joined: 29 Jan 2013, 10:52

Re: mohon bantuan "ERROR DI LINUX MINT"

Postby kouzoku » 29 Jan 2013, 13:35

terima kasih buat saudara2ku yang sudah membantu, boleh saya melanjutkan jawaban saudara nif,

jika ada suatu aplikasi yang tidak mempunyai *.deb dan hanya ada yg berextension *.tar.bz2 apa yg harus dilakunkan jika sudah meng extract serta ./configure ?

jika eeror seperti punya saya menurut saudara tool dan lib apa yg musti saya tambahin?
User avatar
sta
Posts: 2003
Joined: 27 Apr 2010, 09:49
Contact:

Re: mohon bantuan "ERROR DI LINUX MINT"

Postby sta » 29 Jan 2013, 14:13

kouzoku wrote:jika ada suatu aplikasi yang tidak mempunyai *.deb dan hanya ada yg berextension *.tar.bz2 apa yg harus dilakunkan jika sudah meng extract serta ./configure ?
biasanya ada file sejenis README, coba baca2
User avatar
kouzoku
Posts: 8
Joined: 29 Jan 2013, 10:52

Re: mohon bantuan "ERROR DI LINUX MINT"

Postby kouzoku » 29 Jan 2013, 14:51

ini isi readme nya.


Gwget: Gnome2 wget Front-end.
David Sede�o Fern�ndez

Gwget uses Gnome 2 development Platform.

Homepage: http://www.gnome.org/projects/gwget/

---
David Sede�o Fern�ndez


-----------------------------------------------------------------------


kalau install file yg ber extension namafile.linux itu gimana caranya
User avatar
nif
Posts: 2817
Joined: 31 Mar 2011, 07:48

Re: mohon bantuan "ERROR DI LINUX MINT"

Postby nif » 29 Jan 2013, 15:04

sta wrote:
kouzoku wrote:jika ada suatu aplikasi yang tidak mempunyai *.deb dan hanya ada yg berextension *.tar.bz2 apa yg harus dilakunkan jika sudah meng extract serta ./configure ?
biasanya ada file sejenis README, coba baca2

setuju sama om sta. Kalo kondisinya seperti itu memang harus compile sendiri. Biasanya; ./configure, make, sudo make install, tapi tidak semua pasti seperti itu, jadi silahkan lihat keterangan di Readme dan coba cari di Google.

kouzoku wrote:ini isi readme nya.


Gwget: Gnome2 wget Front-end.
David Sede�o Fern�ndez

Gwget uses Gnome 2 development Platform.

Homepage: http://www.gnome.org/projects/gwget/

---
David Sede�o Fern�ndez


Cinnamon base-nya Gnome 3. Wajar kalo instalasi gagal.

kouzoku wrote:kalau install file yg ber extension namafile.linux itu gimana caranya

belum pernah denger :confused:
btw, di Linux masalah ekstensi tidak terlalu penting. Kita bisa buat file teks dengan ekstensi .exe atau yang lainnya, dan tetap akan dikenali sebagai text file :smile:

cmiiw
User avatar
kouzoku
Posts: 8
Joined: 29 Jan 2013, 10:52

Re: mohon bantuan "ERROR DI LINUX MINT"

Postby kouzoku » 29 Jan 2013, 16:12

terima kasih banyak untuk agan atas bimbingannya.

file berextension *.linux juga baru aja saya dapet. waktu iseng-iseng temen minta downloadkan sebuah aplikasi.

salam warga baru

Return to “Pertanyaan Umum”

Who is online

Users browsing this forum: No registered users and 3 guests