[ASK] arti The following packages have unmet depe

Aplikasi-aplikasi diubuntu: • Aplikasi Grafis •
Aplikasi Internet •
Aplikasi Office •
Aplikasi Sound & Video •
Aplikasi Programming
User avatar
manaloe
Posts: 41
Joined: 21 Dec 2011, 09:15
Location: Kutacane, Indonesia
Contact:

[ASK] arti The following packages have unmet depe

Postby manaloe » 24 Nov 2012, 22:23

para agan2 sekalian sebenarnya pengertian berikut pada saat instalasi apa sich..?
The following packages have unmet dependencies:
audacious : Depends: audacious-plugins (>= 2.4.2) but it is not going to be installed
Depends: gtk2-engines-pixbuf but it is not going to be installed
E: Unable to correct problems, you have held broken packages.
rata2 tiap instal paket dr terminal maupun dr ubuntu software center itu2 az masalahnya.. tolong dijelasin donk gan..
User avatar
q_p
Posts: 3109
Joined: 14 Oct 2012, 13:01
Contact:

Re: [ASK] arti The following packages have unmet depe

Postby q_p » 24 Nov 2012, 23:00

CMIIW ya mas... :)
audacious tergantung pada :
audacious-plugins (>= 2.4.2) yang tidak ter-install
gtk2-engines-pixbuf yang tidak ter-install
Kemungkinan anda belum menambahkan ppa ke file /etc/apt/sources.list

Code: Select all

sudo add-apt-repository ppa:nilarimogard/webupd8
sudo apt-get update
sudo apt-get install audacious
User avatar
offline
Posts: 2672
Joined: 17 Feb 2010, 21:03
Location: Kebumen

Re: [ASK] arti The following packages have unmet depe

Postby offline » 25 Nov 2012, 05:32

btw sudah coba ganti alamat repositori/mirrornya?
User avatar
manaloe
Posts: 41
Joined: 21 Dec 2011, 09:15
Location: Kutacane, Indonesia
Contact:

Re: [ASK] arti The following packages have unmet depe

Postby manaloe » 27 Nov 2012, 15:16

masih sama pesannya mas..,
CMIIW itu apaan ya mas :-)
waktu jalankan "sudo add-apt-repository ppa:nilarimogard/webupd8"
ini pesan yg tampil :
Traceback (most recent call last):
File "/usr/bin/add-apt-repository", line 77, in
ppa_info = get_ppa_info_from_lp(user, ppa_name)
File "/usr/lib/python2.7/dist-packages/softwareproperties/ppa.py", line 65, in get_ppa_info_from_lp
lp_page = urlopen(req).read()
File "/usr/lib/python2.7/urllib2.py", line 126, in urlopen
return _opener.open(url, data, timeout)
File "/usr/lib/python2.7/urllib2.py", line 400, in open
response = meth(req, response)
File "/usr/lib/python2.7/urllib2.py", line 513, in http_response
'http', request, response, code, msg, hdrs)
File "/usr/lib/python2.7/urllib2.py", line 432, in error
result = self._call_chain(*args)
File "/usr/lib/python2.7/urllib2.py", line 372, in _call_chain
result = func(*args)
File "/usr/lib/python2.7/urllib2.py", line 619, in http_error_302
return self.parent.open(new, timeout=req.timeout)
File "/usr/lib/python2.7/urllib2.py", line 400, in open
response = meth(req, response)
File "/usr/lib/python2.7/urllib2.py", line 513, in http_response
'http', request, response, code, msg, hdrs)
File "/usr/lib/python2.7/urllib2.py", line 438, in error
return self._call_chain(*args)
File "/usr/lib/python2.7/urllib2.py", line 372, in _call_chain
result = func(*args)
File "/usr/lib/python2.7/urllib2.py", line 521, in http_error_default
raise HTTPError(req.get_full_url(), code, msg, hdrs, fp)
urllib2.HTTPError: HTTP Error 404: Not Found
aram@ubuntu1110:~$ apt-get update
E: Could not open lock file /var/lib/apt/lists/lock - open (13: Permission denied)
E: Unable to lock directory /var/lib/apt/lists/
E: Could not open lock file /var/lib/dpkg/lock - open (13: Permission denied)
E: Unable to lock the administration directory (/var/lib/dpkg/), are you root?
aram@ubuntu1110:~$ sudo add-apt-repository ppa:nilarimogard/weupd8
Traceback (most recent call last):
File "/usr/bin/add-apt-repository", line 77, in
ppa_info = get_ppa_info_from_lp(user, ppa_name)
File "/usr/lib/python2.7/dist-packages/softwareproperties/ppa.py", line 65, in get_ppa_info_from_lp
lp_page = urlopen(req).read()
File "/usr/lib/python2.7/urllib2.py", line 126, in urlopen
return _opener.open(url, data, timeout)
File "/usr/lib/python2.7/urllib2.py", line 400, in open
response = meth(req, response)
File "/usr/lib/python2.7/urllib2.py", line 513, in http_response
'http', request, response, code, msg, hdrs)
File "/usr/lib/python2.7/urllib2.py", line 432, in error
result = self._call_chain(*args)
File "/usr/lib/python2.7/urllib2.py", line 372, in _call_chain
result = func(*args)
File "/usr/lib/python2.7/urllib2.py", line 619, in http_error_302
return self.parent.open(new, timeout=req.timeout)
File "/usr/lib/python2.7/urllib2.py", line 400, in open
response = meth(req, response)
File "/usr/lib/python2.7/urllib2.py", line 513, in http_response
'http', request, response, code, msg, hdrs)
File "/usr/lib/python2.7/urllib2.py", line 438, in error
return self._call_chain(*args)
File "/usr/lib/python2.7/urllib2.py", line 372, in _call_chain
result = func(*args)
File "/usr/lib/python2.7/urllib2.py", line 521, in http_error_default
raise HTTPError(req.get_full_url(), code, msg, hdrs, fp)
urllib2.HTTPError: HTTP Error 404: Not Found
User avatar
manaloe
Posts: 41
Joined: 21 Dec 2011, 09:15
Location: Kutacane, Indonesia
Contact:

Re: [ASK] arti The following packages have unmet depe

Postby manaloe » 27 Nov 2012, 15:17

sudah sy ganti ke repo kambing
mirror yang bagus apa ya mas?
User avatar
q_p
Posts: 3109
Joined: 14 Oct 2012, 13:01
Contact:

Re: [ASK] arti The following packages have unmet depe

Postby q_p » 27 Nov 2012, 15:48

Aneh ya, ditempat saya kok jalan. Ini hasilnya
Tampilkan

Code: Select all

root@ersa12-AO532h:/home/ersa12# add-apt-repository ppa:nilarimogard/webupd8
...
...
...
Press [ENTER] to continue or ctrl-c to cancel adding it

gpg: keyring `/tmp/tmpiJdgaN/secring.gpg' created
gpg: keyring `/tmp/tmpiJdgaN/pubring.gpg' created
gpg: requesting key 4C9D234C from hkp server keyserver.ubuntu.com
gpg: /tmp/tmpiJdgaN/trustdb.gpg: trustdb created
gpg: key 4C9D234C: public key "Launchpad webupd8" imported
gpg: Total number processed: 1
gpg:               imported: 1  (RSA: 1)
OK
root@ersa12-AO532h:/home/ersa12
###update
Coba seperti ini mas, setelah anda edit sources.list. lakukan perintah apt-get update. lalu ulangi lagi cara saya di atas.
User avatar
manaloe
Posts: 41
Joined: 21 Dec 2011, 09:15
Location: Kutacane, Indonesia
Contact:

Re: [ASK] arti The following packages have unmet depe

Postby manaloe » 27 Nov 2012, 15:56

neh lg ganti repo dari kambing ke dl2.foss ntar dibakari ya mas
User avatar
q_p
Posts: 3109
Joined: 14 Oct 2012, 13:01
Contact:

Re: [ASK] arti The following packages have unmet depe

Postby q_p » 27 Nov 2012, 16:00

OK, ntar saya yang ngompori aja :)
User avatar
manaloe
Posts: 41
Joined: 21 Dec 2011, 09:15
Location: Kutacane, Indonesia
Contact:

Re: [ASK] arti The following packages have unmet depe

Postby manaloe » 27 Nov 2012, 16:04

setelah ganti sources.list ke dl2.foss
ketik perintah ppa td sudah sama kyk yg mas tampilkan..
tapi pas intasll audaciousnya
masih seperti ini mas

The following packages have unmet dependencies:
audacious : Depends: audacious-plugins (>= 3.2.4) but it is not going to be installed
Depends: gtk2-engines-pixbuf but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

apakah "audacious-plugins" dan "gtk2-engines-pixbuf" harus di install satu persatu mas?
User avatar
q_p
Posts: 3109
Joined: 14 Oct 2012, 13:01
Contact:

Re: [ASK] arti The following packages have unmet depe

Postby q_p » 27 Nov 2012, 16:09

Perintah apt-get update sudah dijalankan sebelum apt-get install ?
User avatar
manaloe
Posts: 41
Joined: 21 Dec 2011, 09:15
Location: Kutacane, Indonesia
Contact:

Re: [ASK] arti The following packages have unmet depe

Postby manaloe » 27 Nov 2012, 16:10

sudah beberapa x mas
User avatar
manaloe
Posts: 41
Joined: 21 Dec 2011, 09:15
Location: Kutacane, Indonesia
Contact:

Re: [ASK] arti The following packages have unmet depe

Postby manaloe » 27 Nov 2012, 16:14

sebagai bahan analisis ini sources.list yg pertama
deb http://kambing.ui.edu/ubuntu/ natty main restricted universe multiverse
deb-src http://kambing.ui.edu/ubuntu/ natty main restricted universe multiverse
deb http://kambing.ui.edu/ubuntu/ natty-updates main restricted universe multiverse
deb-src http://kambing.ui.edu/ubuntu/ natty-updates main restricted universe multiverse
deb http://kambing.ui.edu/ubuntu/ natty-security main restricted universe multiverse
deb-src http://kambing.ui.edu/ubuntu/ natty-security main restricted universe multiverse

ini sources.list yang sekarang :
deb http://dl2.foss-id.web.id/ubuntu/ oneiric main restricted universe multiverse
deb http://dl2.foss-id.web.id/ubuntu/ oneiric-updates main restricted universe multiverse
deb http://dl2.foss-id.web.id/ubuntu/ oneiric-security main restricted universe multiverse
deb http://dl2.foss-id.web.id/ubuntu/ oneiric-backports main restricted universe multiverse
deb http://dl2.foss-id.web.id/ubuntu/ oneiric-proposed main restricted universe multiverse
User avatar
q_p
Posts: 3109
Joined: 14 Oct 2012, 13:01
Contact:

Re: [ASK] arti The following packages have unmet depe

Postby q_p » 27 Nov 2012, 16:18

Ganti oneiric atau natty atau precise dengan versi ubuntu yang anda gunakan mas. misalnya punya saya (sebagai second opini):

Code: Select all

deb http://kambing.ui.ac.id/ubuntu/ precise-proposed main restricted universe multiverse
deb http://kambing.ui.ac.id/ubuntu/ precise-security main restricted universe multiverse
deb http://kambing.ui.ac.id/ubuntu/ precise-updates main restricted universe multiverse
deb http://kambing.ui.ac.id/ubuntu/ precise main restricted universe multiverse
User avatar
manaloe
Posts: 41
Joined: 21 Dec 2011, 09:15
Location: Kutacane, Indonesia
Contact:

Re: [ASK] arti The following packages have unmet depe

Postby manaloe » 27 Nov 2012, 16:23

oke. dicoba mas..
ubuntu 11.04 yg benar natty ya mas
User avatar
manaloe
Posts: 41
Joined: 21 Dec 2011, 09:15
Location: Kutacane, Indonesia
Contact:

Re: [ASK] arti The following packages have unmet depe

Postby manaloe » 27 Nov 2012, 16:25

ow.. alah. rupanya versinya 11.10 oeneric
User avatar
q_p
Posts: 3109
Joined: 14 Oct 2012, 13:01
Contact:

Re: [ASK] arti The following packages have unmet depe

Postby q_p » 27 Nov 2012, 16:36

Gitu ya mas ? BTW, bagaimanapun hasilnya tolong diposting di sini ya mas .. :)
User avatar
manaloe
Posts: 41
Joined: 21 Dec 2011, 09:15
Location: Kutacane, Indonesia
Contact:

Re: [ASK] arti The following packages have unmet depe

Postby manaloe » 27 Nov 2012, 16:37

masih tetap mas..
kl instal dari ubuntu software center gini pesannya :
The following packages have unmet dependencies:

audacious: Depends: libaudclient2 (= 3.2.4-1~webupd8~oneiric2) but 3.2.4-1~webupd8~oneiric2 is to be installed
Depends: libaudcore1 (= 3.2.4-1~webupd8~oneiric2) but 3.2.4-1~webupd8~oneiric2 is to be installed
Depends: libice6 (>= 1:1.0.0) but 2:1.0.7-2 is to be installed
User avatar
q_p
Posts: 3109
Joined: 14 Oct 2012, 13:01
Contact:

Re: [ASK] arti The following packages have unmet depe

Postby q_p » 27 Nov 2012, 16:45

Harusnya muncul seperti ini :
Tampilkan

Code: Select all

root@ersa12-AO532h:/home/ersa12# apt-get install audacious
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following packages were automatically installed and are no longer required:
  linux-headers-3.2.0-29 linux-headers-3.2.0-29-generic-pae
Use 'apt-get autoremove' to remove them.
The following extra packages will be installed:
  audacious-plugins audacious-plugins-data gtk2-engines-pixbuf libaudclient2 libaudcore1 libavcodec53
  libavformat53 libavutil51 libbinio1ldbl libbs2b0 libcddb2 libcue1 libfaad2 libfluidsynth1 libgsm1 libguess1
  libmms0 libmodplug1 libmowgli2 libmp3lame0 libmpg123-0 libresid-builder0c2a libschroedinger-1.0-0 libsidplay2
  libva1 libvpx1
The following NEW packages will be installed:
  audacious audacious-plugins audacious-plugins-data gtk2-engines-pixbuf libaudclient2 libaudcore1 libavcodec53
  libavformat53 libavutil51 libbinio1ldbl libbs2b0 libcddb2 libcue1 libfaad2 libfluidsynth1 libgsm1 libguess1
  libmms0 libmodplug1 libmowgli2 libmp3lame0 libmpg123-0 libresid-builder0c2a libschroedinger-1.0-0 libsidplay2
  libva1 libvpx1
0 upgraded, 27 newly installed, 0 to remove and 0 not upgraded.
Need to get 11.2 MB of archives.
After this operation, 30.3 MB of additional disk space will be used.
Do you want to continue [Y/n]?
Ketik 'y' tekan enter.
###Update
Coba anda lakukan install lewat terminal seperti dalam contoh2 di atas.
User avatar
manaloe
Posts: 41
Joined: 21 Dec 2011, 09:15
Location: Kutacane, Indonesia
Contact:

Re: [ASK] arti The following packages have unmet depe

Postby manaloe » 27 Nov 2012, 16:56

masih unmet dependencies mas
...
User avatar
offline
Posts: 2672
Joined: 17 Feb 2010, 21:03
Location: Kebumen

Re: [ASK] arti The following packages have unmet depe

Postby offline » 27 Nov 2012, 17:02

aku ingin tahu versi ubuntumu itu versi apa?
boleh tampilan /etc/apt/sources.list dilampirkan di sini?

Return to “Aplikasi Ubuntu”

Who is online

Users browsing this forum: No registered users and 19 guests