Help please...perl: warning: Setting locale failed

Pertanyaan umum seputar distribusi Ubuntu yang menjadi distro wajib members ubuntu-indonesia.com
User avatar
chudy3004
Posts: 1
Joined: 05 May 2012, 23:36

Help please...perl: warning: Setting locale failed

Postby chudy3004 » 17 May 2012, 20:42

malem master-master ubuntu :cool: , ane newbie yang punya msalah nih gan...ane punya eror dimasalah terminal ketika mo masuk root...jadi pas ane ketik
----------------------------------------------------
chudy@hati4dyan:~$ sudo su
[sudo] password for chudy:
----------------------------------------------------

lalu muncul....

----------------------------------------------------
perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
LANGUAGE = "en",
LC_ALL = (unset),
LC_PAPER = "en_US.UTF-8",
LC_ADDRESS = "en_US.UTF-8",
LC_MONETARY = "en_US.utf8",
LC_NUMERIC = "en_US.utf8",
LC_TELEPHONE = "en_US.UTF-8",
LC_IDENTIFICATION = "en_US.UTF-8",
LC_MEASUREMENT = "en_US.utf8",
LC_TIME = "en_US.utf8",
LC_NAME = "en_US.UTF-8",
LANG = "en"
are supported and installed on your system.
perl: warning: Falling back to the standard locale ("C").
----------------------------------------------------

ane sih udah mondari mandir di google & ketemu problem solved nya yaitu :

----------------------------------------------------
8000050000:~# apt-get install multipath-tools
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following extra packages will be installed:
dmsetup kpartx libaio1
Suggested packages:
multipath-tools-boot
The following NEW packages will be installed:
dmsetup kpartx libaio1 multipath-tools
0 upgraded, 4 newly installed, 0 to remove and 0 not upgraded.
Need to get 266kB of archives.
After this operation, 950kB of additional disk space will be used.
Do you want to continue [Y/n]? y
Get:1 http://ftp.de.debian.org lenny/main dmsetup 2:1.02.27-4 [39.7kB]
Get:2 http://ftp.de.debian.org lenny/main kpartx 0.4.8-14+lenny2 [26.0kB]
Get:3 http://ftp.de.debian.org lenny/main libaio1 0.3.107-3 [7414B]
Get:4 http://ftp.de.debian.org lenny/main multipath-tools 0.4.8-14+lenny2 [193kB]
Fetched 266kB in 1s (154kB/s)
perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
LANGUAGE = (unset),
LC_ALL = (unset),
LANG = "en_US.utf8"
are supported and installed on your system.
perl: warning: Falling back to the standard locale ("C").
locale: Cannot set LC_CTYPE to default locale: No such file or directory
locale: Cannot set LC_MESSAGES to default locale: No such file or directory
locale: Cannot set LC_ALL to default locale: No such file or directory
Selecting previously deselected package dmsetup.
(Reading database ... 27499 files and directories currently installed.)
Unpacking dmsetup (from .../dmsetup_2%3a1.02.27-4_amd64.deb) ...
Selecting previously deselected package kpartx.
Unpacking kpartx (from .../kpartx_0.4.8-14+lenny2_amd64.deb) ...
Selecting previously deselected package libaio1.
Unpacking libaio1 (from .../libaio1_0.3.107-3_amd64.deb) ...
Selecting previously deselected package multipath-tools.
Unpacking multipath-tools (from .../multipath-tools_0.4.8-14+lenny2_amd64.deb) ...
Processing triggers for man-db ...
perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
LANGUAGE = (unset),
LC_ALL = (unset),
LANG = "en_US.utf8"
are supported and installed on your system.
perl: warning: Falling back to the standard locale ("C").
/usr/bin/mandb: can't set the locale; make sure $LC_* and $LANG are correct
manconv: can't set the locale; make sure $LC_* and $LANG are correct
manconv: can't set the locale; make sure $LC_* and $LANG are correct
manconv: can't set the locale; make sure $LC_* and $LANG are correct
manconv: can't set the locale; make sure $LC_* and $LANG are correct
manconv: can't set the locale; make sure $LC_* and $LANG are correct
manconv: can't set the locale; make sure $LC_* and $LANG are correct
manconv: can't set the locale; make sure $LC_* and $LANG are correct
manconv: can't set the locale; make sure $LC_* and $LANG are correct
manconv: can't set the locale; make sure $LC_* and $LANG are correct
manconv: can't set the locale; make sure $LC_* and $LANG are correct
manconv: can't set the locale; make sure $LC_* and $LANG are correct
Setting up dmsetup (2:1.02.27-4) ...
Setting up kpartx (0.4.8-14+lenny2) ...
Setting up libaio1 (0.3.107-3) ...
Setting up multipath-tools (0.4.8-14+lenny2) ...
perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
LANGUAGE = (unset),
LC_ALL = (unset),
LANG = "en_US.utf8"
are supported and installed on your system.
perl: warning: Falling back to the standard locale ("C").
Starting multipath daemon: multipathd.
perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
LANGUAGE = (unset),
LC_ALL = (unset),
LANG = "en_US.utf8"
are supported and installed on your system.
perl: warning: Falling back to the standard locale ("C").
8000050000:~#

export LANGUAGE=en_US.UTF-8
export LANG=en_US.UTF-8
export LC_ALL=en_US.UTF-8
locale-gen en_US.UTF-8
dpkg-reconfigure locales
----------------------------------------------------
Sumber Problem Solved-nya

dan berhasil ternyata :D , tapi cuma untuk user biasa aja...kalo pas mo masuk root tetep aja keluar error perl: warning: Setting locale failed - nya :cry: . padahal ane udah setting locale nya di user & di root

(sekalian klo bisa jelasin juga itu gara-gara apa ya??? :confused: )
User avatar
ichan49
Posts: 218
Joined: 02 Nov 2011, 20:25
Location: Pontianak, Indonesia
Contact:

Re: Help please...perl: warning: Setting locale failed

Postby ichan49 » 22 May 2012, 17:55

kalo mau explore folder via root, lewat nautilus aja kk, itu salah satu solusi yang ane pake,.. :grin:

Return to “Pertanyaan Umum”

Who is online

Users browsing this forum: No registered users and 30 guests